X2Go Bug report logs - #764
Language layout switching not working if shortcut the same on server and client

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Glueon <glueon@contactroot.com>

Date: Fri, 23 Jan 2015 14:05:01 UTC

Severity: normal

Found in version 4.0.3.1

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 23 Jan 2015 14:02:52 +0000
From glueon@contactroot.com  Fri Jan 23 15:02:52 2015
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: *
X-Spam-Status: No, score=1.6 required=5.0 tests=BAYES_50,RDNS_NONE,
	T_DKIM_INVALID,URIBL_BLOCKED autolearn=no version=3.3.2
Received: from server.contactroot.com (unknown [213.152.181.64])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id EABFB3BC69
	for <submit@bugs.x2go.org>; Fri, 23 Jan 2015 15:02:51 +0100 (CET)
Received: from localhost (localhost.localdomain [127.0.0.1])
	by server.contactroot.com (Postfix) with ESMTP id BCF4BB1E06B6
	for <submit@bugs.x2go.org>; Fri, 23 Jan 2015 09:02:50 -0500 (EST)
Authentication-Results: server.contactroot.com (amavisd-new); dkim=pass
	reason="pass (just generated, assumed good)" header.d=contactroot.com
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=contactroot.com;
	 h=content-transfer-encoding:content-type:content-type:subject
	:subject:to:mime-version:user-agent:from:from:date:date
	:message-id; s=dkim; t=1422021769; x=1422885770; bh=Q4FJVsUsjuLa
	tPoYo+kpx9yZFR8ZfW+XfrBlDHwrJZo=; b=HG2/AJtOxawgaDNsXoYlRyYm7cp4
	kiLYUY/AdSpxsDkXGN1TODbnKgPkqEge2BsOmkfyBk3oiwrKbK7e9Hv+a3D95Vux
	HV4yfodw9y3ZIBIDSWY/wpjB9k3HmaCYBqBj4fEJOnq16ZWCEO4Cc/Feeg/YfTO2
	GtWQVbG2TS9rN7o=
X-Virus-Scanned: Debian amavisd-new at contactroot.com
Received: from server.contactroot.com ([127.0.0.1])
	by localhost (server.contactroot.com [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id Oo8NU_SU53Hz for <submit@bugs.x2go.org>;
	Fri, 23 Jan 2015 09:02:49 -0500 (EST)
Received: from [178.162.199.32] (unknown [178.162.199.32])
	by server.contactroot.com (Postfix) with ESMTPSA id A38F1B1E06B4
	for <submit@bugs.x2go.org>; Fri, 23 Jan 2015 09:02:48 -0500 (EST)
Message-ID: <54C2536B.6040707@contactroot.com>
Date: Fri, 23 Jan 2015 16:58:03 +0300
From: Glueon <glueon@contactroot.com>
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Icedove/31.3.0
MIME-Version: 1.0
To: submit@bugs.x2go.org
Subject: Language layout switching not working if shortcut the same on server
 and client
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 7bit
Package: x2goclient
Version: 4.0.3.1

Hello x2go dev team,

I have Ubuntu 14.04.1 LTS on a client machine and use ALT+SHIFT to 
switch the keyboard layout.
As a client a use X2Go Client V. 4.0.3.1 - the latest thing available 
from your repository at the moment.

On a remote machine I have Debian Wheezy with KDE 4.8.4 and the latest 
x2go server from http://packages.x2go.org/debian. So should be 
4.0.1.18-0x2go1+git20141006.949+wheezy.main.1

The problem is that if in KDE Keyboard settings in "Layouts" as a main 
shortcut for switching layout i'll select the same layout I use locally 
(ALT+SHIFT in my case) it will not work properly.
If you work on a remote machine and hit ALT+SHIFT - layout only switches 
on a local machine. If you hit ALT+SHIFT multiple times quite fast 
sometimes layout on a remote machine switches too. Sometimes not.

I tried to set different keyboard settings in the session settings - 
does not help. If I set something other than the 'do not configure' 
after connecting to the remote instead of 2 layouts I have a third one - 
undef. Which will disappear if I just go to keyboard settings and apply 
the same settings i had. Maybe that resets some settings which x2go does 
after connection is established. But that 'undef' thing is not what 
bothers me.

Problem with the layout switching has appeared long ago-  since  the 
Ubuntu 13. As I remeber 12 was the latest one which worked normally. 
After the upgrade from 12 to 13 even locally ALT+SHIFT combo didn't 
work. That was a really big problem and that has a confirmed bug 
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1218322. 
There are some other related bugs, I can try to find them if needed.
It is partially fixed - at least ALT+SHIFT  now works locally but since 
that time I have a problem witch x2go as I described earlier.

I tried to use CAPS Lock on both machines - same problem. As I remember 
I tried installing MATE instead of KDE - didn't help.
I believe that problem is in Ubuntu - in how it now intercepts keyboard 
shortcuts. Through the 12->13 transition they changed something.
Please take a look at the problem. Currently I have different shortcuts 
on remote a local machine. It's quite uncofortable.


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Mon Mar 4 05:58:04 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.