X2Go Bug report logs - #764
Language layout switching not working if shortcut the same on server and client

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Glueon <glueon@contactroot.com>

Date: Fri, 23 Jan 2015 14:05:01 UTC

Severity: normal

Found in version 4.0.3.1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#764; Package x2goclient. (Fri, 23 Jan 2015 14:05:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Glueon <glueon@contactroot.com>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Fri, 23 Jan 2015 14:05:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Glueon <glueon@contactroot.com>
To: submit@bugs.x2go.org
Subject: Language layout switching not working if shortcut the same on server and client
Date: Fri, 23 Jan 2015 16:58:03 +0300
Package: x2goclient
Version: 4.0.3.1

Hello x2go dev team,

I have Ubuntu 14.04.1 LTS on a client machine and use ALT+SHIFT to 
switch the keyboard layout.
As a client a use X2Go Client V. 4.0.3.1 - the latest thing available 
from your repository at the moment.

On a remote machine I have Debian Wheezy with KDE 4.8.4 and the latest 
x2go server from http://packages.x2go.org/debian. So should be 
4.0.1.18-0x2go1+git20141006.949+wheezy.main.1

The problem is that if in KDE Keyboard settings in "Layouts" as a main 
shortcut for switching layout i'll select the same layout I use locally 
(ALT+SHIFT in my case) it will not work properly.
If you work on a remote machine and hit ALT+SHIFT - layout only switches 
on a local machine. If you hit ALT+SHIFT multiple times quite fast 
sometimes layout on a remote machine switches too. Sometimes not.

I tried to set different keyboard settings in the session settings - 
does not help. If I set something other than the 'do not configure' 
after connecting to the remote instead of 2 layouts I have a third one - 
undef. Which will disappear if I just go to keyboard settings and apply 
the same settings i had. Maybe that resets some settings which x2go does 
after connection is established. But that 'undef' thing is not what 
bothers me.

Problem with the layout switching has appeared long ago-  since  the 
Ubuntu 13. As I remeber 12 was the latest one which worked normally. 
After the upgrade from 12 to 13 even locally ALT+SHIFT combo didn't 
work. That was a really big problem and that has a confirmed bug 
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1218322. 
There are some other related bugs, I can try to find them if needed.
It is partially fixed - at least ALT+SHIFT  now works locally but since 
that time I have a problem witch x2go as I described earlier.

I tried to use CAPS Lock on both machines - same problem. As I remember 
I tried installing MATE instead of KDE - didn't help.
I believe that problem is in Ubuntu - in how it now intercepts keyboard 
shortcuts. Through the 12->13 transition they changed something.
Please take a look at the problem. Currently I have different shortcuts 
on remote a local machine. It's quite uncofortable.


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Dec 12 03:42:49 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.