X2Go Bug report logs - #1025
Still various unstranslated GUI elements

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Date: Tue, 12 Apr 2016 11:55:02 UTC

Severity: minor

Found in version 4.0.5.1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1025; Package x2goclient. (Tue, 12 Apr 2016 11:55:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 12 Apr 2016 11:55:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: submit@bugs.x2go.org
Subject: Still various unstranslated GUI elements
Date: Tue, 12 Apr 2016 11:52:56 +0000
[Message part 1 (text/plain, inline)]
Package: x2goclient
Severity: minor
Version: 4.0.5.1

Hi all,

I still see various untranslated string in X2Go Client 4.0.5.1:

  (1) The little down-arrow on session cards:
       "Session preferences..."
       "Create session icon on desktop"

  (2) Main menu: Session -> "Session Management", "Create session  
icon on desktop"

  (3) Session Prefernces dialog window:

      Session Tab

      [x] Try autologin ...

      Input/Output Tab

      (.) Auto-detect keyboard settings

      Sharing

      [x] Use port forwarding...

      About X2Go Client

      -> Description text is in English

  (4) possibly more...

I checked this with LANG=de_DE.UTF-8 and LANG=es_ES.UTF-8. The issues  
occur in both languages, so I presume the causes are in the original  
code somewhere.

Greets,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/mailxchange/kronolith/fb.php?u=m.gabriel%40das-netzwerkteam.de
[Message part 2 (application/pgp-signature, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1025; Package x2goclient. (Wed, 04 May 2016 04:00:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mihai Moldovan <ionic@ionic.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 04 May 2016 04:00:02 GMT) Full text and rfc822 format available.

Message #10 received at 1025@bugs.x2go.org (full text, mbox):

From: Mihai Moldovan <ionic@ionic.de>
To: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>, 1025@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1025: Still various unstranslated GUI elements
Date: Wed, 4 May 2016 05:56:13 +0200
[Message part 1 (text/plain, inline)]
On 12.04.2016 01:52 PM, Mike Gabriel wrote:
> I still see various untranslated string in X2Go Client 4.0.5.1:
>
> I checked this with LANG=de_DE.UTF-8 and LANG=es_ES.UTF-8. The issues  
> occur in both languages, so I presume the causes are in the original  
> code somewhere.

I wasn't able to reproduce any of this, at least on OS X (although some strings
were not displayed there at all, but what I checked was fine.)

Did you see a mixture of translated and untranslated strings, or was everything
untranslated?



Mihai


[signature.asc (application/pgp-signature, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1025; Package x2goclient. (Wed, 04 May 2016 12:00:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 04 May 2016 12:00:02 GMT) Full text and rfc822 format available.

Message #15 received at 1025@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Mihai Moldovan <ionic@ionic.de>
Cc: 1025@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1025: Still various unstranslated GUI elements
Date: Wed, 04 May 2016 11:56:59 +0000
[Message part 1 (text/plain, inline)]
Hi Mihai,

On  Mi 04 Mai 2016 05:56:13 CEST, Mihai Moldovan wrote:

> On 12.04.2016 01:52 PM, Mike Gabriel wrote:
>> I still see various untranslated string in X2Go Client 4.0.5.1:
>>
>> I checked this with LANG=de_DE.UTF-8 and LANG=es_ES.UTF-8. The issues
>> occur in both languages, so I presume the causes are in the original
>> code somewhere.
>
> I wasn't able to reproduce any of this, at least on OS X (although  
> some strings
> were not displayed there at all, but what I checked was fine.)
>
> Did you see a mixture of translated and untranslated strings, or was  
> everything
> untranslated?

The issue was observed on a Linux client running Debian (jessie and stretch).

I saw a mixture of German and English or Spanish and English.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/mailxchange/kronolith/fb.php?u=m.gabriel%40das-netzwerkteam.de
[Message part 2 (application/pgp-signature, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1025; Package x2goclient. (Thu, 05 May 2016 19:50:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mihai Moldovan <ionic@ionic.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Thu, 05 May 2016 19:50:02 GMT) Full text and rfc822 format available.

Message #20 received at 1025@bugs.x2go.org (full text, mbox):

From: Mihai Moldovan <ionic@ionic.de>
To: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>, 1025@bugs.x2go.org
Subject: Re: [X2Go-Dev] Still various unstranslated GUI elements
Date: Thu, 5 May 2016 21:49:01 +0200
[Message part 1 (text/plain, inline)]
On 04.05.2016 01:56 PM, Mike Gabriel wrote:
> The issue was observed on a Linux client running Debian (jessie and stretch).
> 
> I saw a mixture of German and English or Spanish and English.

I tried reproducing that issue again on a Jessie VM provided by Stefan. The
stable version of X2Go Client was installed via our repository.

Again, I was unable to reproduce the issue. For both "export LANG=de_DE.UTF-8;
x2goclient" and "export LANG=es_ES.UTF-8; x2goclient" the mentioned messages
showed up in the requested language.

Prior to executing x2goclient, what does locale -a output? Maybe you have a
mixture of locales defined and this is triggering some problem within Qt or
x2goclient.



Mihai

[signature.asc (application/pgp-signature, attachment)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Dec 11 00:03:20 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.