X2Go Bug report logs - #511
Cannot resume session, automatically suspends after connecting

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Wim De Smet <kromagg@gmail.com>

Date: Thu, 5 Jun 2014 06:35:02 UTC

Severity: normal

Tags: pending

Found in version

Fixed in version

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log

Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 5 Jun 2014 06:33:27 +0000
From kromagg@gmail.com  Thu Jun  5 08:33:25 2014
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00,FREEMAIL_FROM,
	HTML_MESSAGE,T_DKIM_INVALID,URIBL_BLOCKED autolearn=ham version=3.3.2
Received: from mail-wi0-f172.google.com (mail-wi0-f172.google.com [])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id BC76A5DB0A
	for <submit@bugs.x2go.org>; Thu,  5 Jun 2014 08:33:25 +0200 (CEST)
Received: by mail-wi0-f172.google.com with SMTP id hi2so9674462wib.17
        for <submit@bugs.x2go.org>; Wed, 04 Jun 2014 23:33:25 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;
MIME-Version: 1.0
X-Received: by with SMTP id s12mr12368858wiv.61.1401950005283;
 Wed, 04 Jun 2014 23:33:25 -0700 (PDT)
Received: by with HTTP; Wed, 4 Jun 2014 23:33:25 -0700 (PDT)
Date: Thu, 5 Jun 2014 08:33:25 +0200
Message-ID: <CA+4c1mnB98=HUp=XHaroZf_2wY2f9ts+qjgTXciBjt5-HTg_ww@mail.gmail.com>
Subject: Cannot resume session, automatically suspends after connecting
From: Wim De Smet <kromagg@gmail.com>
To: submit@bugs.x2go.org
Content-Type: multipart/mixed; boundary=f46d043c81e60f462604fb10ec5a
[Message part 1 (text/plain, inline)]
Package: x2goserver

(Release: 0.0x2go1.1.git20140403.847.main.el6)

I am running x2goserver on Centos 6.x and x2goclient on the latest Ubuntu,
both completely up to date. Today I tried starting a connection from Ubuntu
while having the xinerama extension enabled. This fails with:

$ x2goclient
x2go-INFO-1> "Starting x2goclient..."
x2go-WARNING-1> "Can't load translator: :/x2goclient_nl_be"
x2go-WARNING-2> "Can't load translator: :/qt_nl_BE"
x2go-INFO-3> "Started  x2goclient."
x2go-INFO-8> "Starting connection to server: [redacted]:22"
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 14 (X_GetGeometry)
  Resource id:  0x520001b
x2go-WARNING-7> "Error getting window geometry (window closed)?"

I disabled the xinerama extension and tried again. Now I can open the
session, but almost as soon as it opens, the session shuts down again. No
errors are reported. The only thing that appears client side is:

x2go-INFO-8> "Starting connection to server: [redacted]:22"

In the server log (attached) nothing appears, except a few warnings about
fonts not being found and that the session is being suspended. Strangely,
sometimes I can use the session long enough to move a few windows or type
something in, but it always quietly suspends.

The version of x2goclient is
[Message part 2 (text/html, inline)]
[x2goserver.log (text/x-log, attachment)]

Send a report that this bug log contains spam.

X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Mar 5 04:05:53 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.