Package: x2goserver

(Release: 0.0x2go1.1.git20140403.847.main.el6)

I am running x2goserver on Centos 6.x and x2goclient on the latest Ubuntu, both completely up to date. Today I tried starting a connection from Ubuntu while having the xinerama extension enabled. This fails with:

$ x2goclient 
x2go-INFO-1> "Starting x2goclient..."
x2go-WARNING-1> "Can't load translator: :/x2goclient_nl_be"
x2go-WARNING-2> "Can't load translator: :/qt_nl_BE"
x2go-INFO-3> "Started  x2goclient."
x2go-INFO-8> "Starting connection to server: [redacted]:22"
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 14 (X_GetGeometry)
  Resource id:  0x520001b
x2go-WARNING-7> "Error getting window geometry (window closed)?"

I disabled the xinerama extension and tried again. Now I can open the session, but almost as soon as it opens, the session shuts down again. No errors are reported. The only thing that appears client side is:

x2go-INFO-8> "Starting connection to server: [redacted]:22"

In the server log (attached) nothing appears, except a few warnings about fonts not being found and that the session is being suspended. Strangely, sometimes I can use the session long enough to move a few windows or type something in, but it always quietly suspends.

The version of x2goclient is