X2Go Bug report logs - #475
x2goclient v4.0.2.0 running on OSX, causes remote UI breakage and high CPU load on server

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Eugene San <eugenesan@gmail.com>

Date: Fri, 11 Apr 2014 16:40:01 UTC

Severity: normal

Full log


Message #75 received at 475@bugs.x2go.org (full text, mbox, reply):

Received: (at 475) by bugs.x2go.org; 28 Jul 2014 20:09:02 +0000
From kirill.petrov@gmail.com  Mon Jul 28 22:09:01 2014
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.8 required=5.0 tests=BAYES_50,FREEMAIL_FROM,
	HTML_MESSAGE,T_DKIM_INVALID autolearn=ham version=3.3.2
Received: from mail-vc0-f172.google.com (mail-vc0-f172.google.com [209.85.220.172])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id CE1955DB52
	for <475@bugs.x2go.org>; Mon, 28 Jul 2014 22:09:00 +0200 (CEST)
Received: by mail-vc0-f172.google.com with SMTP id im17so12160579vcb.17
        for <475@bugs.x2go.org>; Mon, 28 Jul 2014 13:08:59 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;
        h=mime-version:date:message-id:subject:from:to:content-type;
        bh=ZyqrEjO2L1ONdCZB5jORw4ddFFE53PIJGnudgmqKgeA=;
        b=rH03itxdedYGL798i8nJ5K1+u46P3BiNji7YMw3lndBDzEAvNYlhq8KKCCJ5hNOtXn
         EXeW5ej4MZF+o4gZPdpj40HCOphrAuYg7oPtio1No1HJRGs8W8lvt1txjdTCWbxQLIMy
         Ee0pLuiZGB3RSjp0USwGt6rq8qWrc1iQU1GxOmuEF+l00cdjjZrpHMBKZZiwYSFChYdM
         y7pb2qK5tLl2hF78jB2ImbZ1lnuqslIjbTjyTgPDQfbH5Nm39Q2mdL3U2PwP0zr5VdpV
         +8Tl6CvJcd6cWWpi9LS7usrSXZuCj2WTh+VW74GvNYi2bzAHvLa784mwYxFbfqV8uYOg
         s2Cw==
MIME-Version: 1.0
X-Received: by 10.220.172.8 with SMTP id j8mr3300615vcz.32.1406578139687; Mon,
 28 Jul 2014 13:08:59 -0700 (PDT)
Received: by 10.220.130.133 with HTTP; Mon, 28 Jul 2014 13:08:59 -0700 (PDT)
Date: Mon, 28 Jul 2014 13:08:59 -0700
Message-ID: <CAEdZmRPQcn103DZ69k-A_kazVHxdisOKYehF76w6A9EAZj5M9Q@mail.gmail.com>
Subject: Mavericks 10.9.4/ X2Go Client V.4.0.2.0 (Qt - 4.8.5) high CPU usage
From: Kirill Petrov <kirill.petrov@gmail.com>
To: 475@bugs.x2go.org
Content-Type: multipart/alternative; boundary=001a11c3678c5d717a04ff467eb8
[Message part 1 (text/plain, inline)]
Experience the same problem with:
OS X 19.9.4, Mac client  X2Go Client V.4.0.2.0 (Qt - 4.8.5)

On the remote server I see one CPU completely killed:
PID USER PR  NI  VIRT  RES  SHR S  %CPU %MEM    TIME+  COMMAND
21002 filer     20   0 63148  41m 5528 S  66.5  1.7   3:51.08 x2goagent
21323 filer     20   0 20936 4956 2516 S  15.3  0.2   0:53.50
xfce4-settings-
21303 filer     20   0 20336 8688 7120 S   0.7  0.4   0:02.84 xfwm4
21305 filer     20   0 35364  10m 8976 S   0.3  0.5   0:00.72 xfce4-panel

At the same time, as soon as I disconnect. CPU usage of x2goagent goes to 0.

Is it the case that Linux clients don't have this problem?

thank you,

Kirill
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Mon Jun 24 22:08:18 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.