X2Go Bug report logs - #475
x2goclient v4.0.2.0 running on OSX, causes remote UI breakage and high CPU load on server

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Eugene San <eugenesan@gmail.com>

Date: Fri, 11 Apr 2014 16:40:01 UTC

Severity: normal

Full log


Message #60 received at 475@bugs.x2go.org (full text, mbox, reply):

Received: (at 475) by bugs.x2go.org; 26 Jul 2014 13:53:28 +0000
From apfitch@ieee.org  Sat Jul 26 15:53:27 2014
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00 autolearn=ham
	version=3.3.2
Received: from avasout03.plus.net (avasout03.plus.net [84.93.230.244])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 092405DB51
	for <475@bugs.x2go.org>; Sat, 26 Jul 2014 15:53:26 +0200 (CEST)
Received: from [192.168.1.65] ([87.114.176.107])
	by avasout03 with smtp
	id X1tR1o0062KQUFK011tSuw; Sat, 26 Jul 2014 14:53:26 +0100
X-CM-Score: 0.00
X-CNFS-Analysis: v=2.1 cv=ZOBZmBLb c=1 sm=1 tr=0
 a=qFqsu0gU7mGQxIYh4+Py4A==:117 a=qFqsu0gU7mGQxIYh4+Py4A==:17 a=0Bzu9jTXAAAA:8
 a=ekOJvlQLSnQA:10 a=p7PgN5Y1ueAA:10 a=ONEJXaA8-E4A:10 a=d03zc-rxdw0A:10
 a=8nJEP1OIZ-IA:10 a=o83nqyVRAAAA:8 a=VfjX26hiuWCGO9S_aeQA:9 a=wPNLvfGTeEIA:10
X-AUTH: apfitch:2500
Message-ID: <53D3B2D5.5070901@ieee.org>
Date: Sat, 26 Jul 2014 14:53:25 +0100
From: Alan Fitch <apfitch@ieee.org>
Reply-To: apfitch@ieee.org
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0
MIME-Version: 1.0
To: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>, 475@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#475: Also seen on Centos 6.5 with Windows 7 client
References: <20140725193832.Horde.Om8C1ZmTUn-EbkeqV6E6gQ1@mail.das-netzwerkteam.de>
In-Reply-To: <20140725193832.Horde.Om8C1ZmTUn-EbkeqV6E6gQ1@mail.das-netzwerkteam.de>
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
On 25/07/14 20:38, Mike Gabriel wrote:
> Hi Alan,
>
> On  Fr 25 Jul 2014 00:44:29 CEST, Alan Peter Fitch wrote:
>
>> I've seen this on Centos 6.5 with the Windows 7 x2go client, both 4.0.2.0.
>>
>> I tried downgrading the client all the way back to 3.11 with no effect.
>>
>> One interesting point - a colleague running x2goclient on Ubuntu 12 LTS
>> (client version was 3.99) did *not* experience the problem.
>>
>> In my environment it makes x2go unusable, so I'm now investigating xpra
>> to get the resume/suspend functionality.
> Can you detect where exactly the sesion startup hangs?
Hi Mike,

  I'll have to try some tests at work on Monday (I'm trying to use it
where I work).

There are a couple other of other factors. We run various Electronic
Design Automation (EDA) tools.
The access is as follows

1. use x2goclient to access a server running Centos 6.5 and Open Grid
Scheduler (OGS).
2. Launch a terminal on the OGS, e.g.
   qrsh -q name.q xterm
The cluster machines are also running Centos 6.5. qrsh is forwarding X
from the cluster machines using ssh X forwarding (it's not actually
launching rsh, it's using ssh).

3. Launch the tool.

For some tools (e.g. Altera Quartus, Xilinx Vivado) the x2goagent usage
climbs to about 10% CPU as the graphics update.
For Mentor Questasim, the CPU usage climbs to between 70 and 90%, and it
takes ages (5 minutes?)  for the graphics to refresh and stabilise.
During that period, all the windows (the xterm and the EDA tool) are
greyed out and don't refresh.

I've tried running strace and there were millions of calls to a system
file call. I will send you an excerpt of the log on Monday. I think I
attached strace to the process ID of the x2goagent, but I will check
that on Monday.

I will also trying running directly on the server, just to check if the
ssh -X forwarding to the cluster is significant or not.

The thing that really surprised me was that if you use x2goclient from
Ubuntu 12 LTS, everything is fine. It was only access from a Windows 7
x2goclient that was affected.

regards
Alan

>
> My guess is that you have an everlasting x2gostartagent process on the  
> X2Go Server machine that loops endlessly while detecting a free TCP/IP  
> port for binding its forwarding tunnel endpoints to.
>
> We have to rely on a little testing here. Thanks.
>
> Mike


-- 
Alan Fitch


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Mon Jun 24 22:25:17 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.