X2Go Bug report logs - #16
Fwd: [X2Go-Dev] Broken glyphs and icons after suspending a session

version graph

Package: x2goagent; Maintainer for x2goagent is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goagent is src:nx-libs.

Reported by: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Date: Mon, 10 Sep 2012 11:51:21 UTC

Severity: normal

Tags: fixed, pending

Found in version 3.5.0.14

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox):

Received: (at submit) by bugs.x2go.org; 10 Sep 2012 11:50:11 +0000
From mike.gabriel@das-netzwerkteam.de  Mon Sep 10 13:50:11 2012
Received: from freya.das-netzwerkteam.de (freya.das-netzwerkteam.de [88.198.48.199])
	by ymir (Postfix) with ESMTPS id 0F2595DA21
	for <submit@bugs.x2go.org>; Mon, 10 Sep 2012 13:50:11 +0200 (CEST)
Received: from grimnir.das-netzwerkteam.de (grimnir.das-netzwerkteam.de [78.46.204.98])
	by freya.das-netzwerkteam.de (Postfix) with ESMTPS id 55A442E2
	for <submit@bugs.x2go.org>; Mon, 10 Sep 2012 13:50:10 +0200 (CEST)
Received: from localhost (localhost [127.0.0.1])
	by grimnir.das-netzwerkteam.de (Postfix) with ESMTP id 1867C3BF0C
	for <submit@bugs.x2go.org>; Mon, 10 Sep 2012 13:50:10 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at grimnir.das-netzwerkteam.de
Received: from grimnir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (grimnir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id hLMGsSiFxiHr for <submit@bugs.x2go.org>;
	Mon, 10 Sep 2012 13:50:10 +0200 (CEST)
Received: from localhost (localhost [127.0.0.1])
	by grimnir.das-netzwerkteam.de (Postfix) with ESMTP id ED4883C10A
	for <submit@bugs.x2go.org>; Mon, 10 Sep 2012 13:50:09 +0200 (CEST)
Received: from localhost (localhost [127.0.0.1])
	by grimnir.das-netzwerkteam.de (Postfix) with ESMTP id C615F3BF0C
	for <submit@bugs.x2go.org>; Mon, 10 Sep 2012 13:50:09 +0200 (CEST)
X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on
	grimnir.das-netzwerkteam.de
X-Spam-Flag: NO
X-Spam-Status: No, hits=-2.9 required=5.0 tests=ALL_TRUSTED,BAYES_00
	autolearn=ham version=3.3.1 running as userid=
X-Spam-Level: 
X-Spam-Bayes-Score: 0.0000
Received: by grimnir.das-netzwerkteam.de (Postfix, from userid 33)
	id 5F69D3C10A; Mon, 10 Sep 2012 13:50:09 +0200 (CEST)
Received: from m-110.informatik.uni-kiel.de (m-110.informatik.uni-kiel.de
 [134.245.254.110]) by mail.das-netzwerkteam.de (Horde Framework) with HTTP;
 Mon, 10 Sep 2012 13:50:09 +0200
Message-ID: <20120910135009.88042lik9rfr6e41@mail.das-netzwerkteam.de>
X-Priority: 3 (Normal)
Date: Mon, 10 Sep 2012 13:50:09 +0200
From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: submit@bugs.x2go.org
Subject: Fwd: [X2Go-Dev] Broken glyphs and icons after suspending a session
MIME-Version: 1.0
Content-Type: multipart/signed;
 boundary="=_2ajn66lp1skx";
 protocol="application/pgp-signature";
 micalg="pgp-sha1"
Content-Transfer-Encoding: 7bit
User-Agent: Internet Messaging Program (IMP) H3 (4.3.4)
[Message part 1 (text/plain, inline)]
Package: x2goagent
Severity: important
Version: 3.5.0.14

Hi all,

putting this mail from x2go-dev mailing list into our new BTS to  
follow the progress on this issue.

Mike

----- Weitergeleitete Nachricht von x2go-dev@computerfreak.de -----
     Datum: Sat, 12 May 2012 00:10:11 +0200
       Von: Holger Hahn <x2go-dev@computerfreak.de>
Antwort an: x2go-dev@lists.berlios.de
   Betreff: [X2Go-Dev] Broken glyphs and icons after suspending a session
        An: x2go-dev@lists.berlios.de

Hello x2go dev team,

as I was looking for an alternative on NX nomachine, because it was
broken with the last Cairo 1.12 update, I found your x2go solution,
which is great.

So as it bases on the same libraries than the original nomachine, you
had the same issues - with rendering to undrawable objects, the whole
nxagent crashes because of SEGV.

With the patch of Jan (thanks to) you committed to the master branch
today, I compiled another nxagent. Actually it worked fine, but after
suspending and reconnecting to a session, some graphical objects get
broken...

All characters/fonts that has been rendered on the screen prior the
suspension, are gone. (See Screenshots the link below).
Creating new text by starting applications is ok, as long as the
characters has not been rendered in the session before.

I thought it might be problem with a kind of glyph cache of the X
session (ubuntu/x86 x2goclient). But I found one case, where
additionally to the text, all icons are gone also, which was with an
debian/x64 x2goclient... (Difference can be seen on screenshots)

Might it have to do something with the patch from today, that could
filter out to much rendering? Or is this issue known from somewhere else?

Here are some screenshots: http://www.computerfreak.de/sonic/x2shots/

Thanks for your help,
Holger
_______________________________________________
X2Go-Dev mailing list
X2Go-Dev@lists.berlios.de
https://lists.berlios.de/mailman/listinfo/x2go-dev


----- Ende der weitergeleiteten Nachricht -----


-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb
[Message part 2 (application/pgp-signature, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun May 19 11:07:03 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.