X2Go Bug report logs - #1594
X2Go Windows Client fails to connect to hostname resolving to both IPv4 and IPv6

version graph

Packages: x2go, windows, client; Maintainer for x2go is (unknown); Maintainer for windows is (unknown); Maintainer for client is (unknown);

Reported by: me@jcn50.com

Date: Thu, 24 Nov 2022 16:35:02 UTC

Severity: normal

Found in version 4.1.2.2

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1594; Package x2go windows client. (Thu, 24 Nov 2022 16:35:02 GMT) (full text, mbox, link).


Acknowledgement sent to me@jcn50.com:
New Bug report received and forwarded. Copy sent to owner@bugs.x2go.org. (Thu, 24 Nov 2022 16:35:02 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

From: me@jcn50.com
To: submit@bugs.x2go.org
Subject: X2Go Windows Client fails to connect to hostname resolving to both IPv4 and IPv6
Date: Thu, 24 Nov 2022 16:30:18 +0000
Package: X2Go Windows Client
Version: 4.1.2.2

I have a hostname that has both 1x IPv4 address (A records) and 1x IPv6 
address (AAAA records). The client fails to connect (connection timeout 
error exact message: "Timeout connecting to $HOSTNAME") if I use the 
hostname. However if I enter the IPv4 or the IPv6 instead of the 
hostname: it works!

Proposed solution: it should try to connect/resolve to the IPv6 first, 
then the IPv4.

Regards,
Chris.


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Dec 7 00:27:17 2022; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.