X2Go Bug report logs - #155
25 user logon problem

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Thomas Hanschke <th.han@arcor.de>

Date: Thu, 28 Mar 2013 15:33:02 UTC

Severity: normal

Tags: moreinfo, patch, pending

Fixed in version 4.0.0.3

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 28 Mar 2013 15:31:25 +0000
From th.han@arcor.de  Thu Mar 28 16:31:24 2013
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.0 required=5.0 tests=FREEMAIL_FROM,
	RCVD_IN_DNSWL_NONE,T_DKIM_INVALID,URIBL_BLOCKED autolearn=ham version=3.3.2
Received: from mail-in-06.arcor-online.net (mail-in-06.arcor-online.net [151.189.21.46])
	by ymir (Postfix) with ESMTPS id B97AA5DA79
	for <submit@bugs.x2go.org>; Thu, 28 Mar 2013 16:31:24 +0100 (CET)
Received: from mail-in-15-z2.arcor-online.net (mail-in-15-z2.arcor-online.net [151.189.8.32])
	by mx.arcor.de (Postfix) with ESMTP id 0A06910BA2D;
	Thu, 28 Mar 2013 16:31:24 +0100 (CET)
Received: from mail-in-17.arcor-online.net (mail-in-17.arcor-online.net [151.189.21.57])
	by mail-in-15-z2.arcor-online.net (Postfix) with ESMTP id 01BC8112010;
	Thu, 28 Mar 2013 16:31:24 +0100 (CET)
X-Greylist: Passed host: 178.12.67.84
X-DKIM: Sendmail DKIM Filter v2.8.2 mail-in-17.arcor-online.net C3450CBC56
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=arcor.de; s=mail-in;
	t=1364484683; bh=yzC2RRyHZEqlE2/I5vkqTcGwIcvMO0rW7CTTSzlKv7I=;
	h=Message-ID:Subject:From:To:Cc:Date:Content-Type:
	 Content-Transfer-Encoding:Mime-Version;
	b=ehMwrW461HjV0dTBg0OHDNR1eIPdlTV/2BziW2jKUaKugrzp0vDdeVtrDLna8fyPa
	 WJS+54SfjlxnL9sSGpE0L/FNm8Pimk5ZmaNUiR6cQpwZtty03NBy7/NXlIIv+Ks88M
	 SFdtMg2T0zqa7xUPzlkj/Br7kU1fA9O4+hZHKvGM=
X-Greylist: Passed host: 178.12.67.84
Received: from [192.168.178.28] (dslb-178-012-067-084.pools.arcor-ip.net [178.12.67.84])
	(Authenticated sender: th.han@arcor.de)
	by mail-in-17.arcor-online.net (Postfix) with ESMTPSA id C3450CBC56;
	Thu, 28 Mar 2013 16:31:23 +0100 (CET)
Message-ID: <1364484683.17230.2.camel@thh-imedia-S1300>
Subject: 25 user logon problem
From: Thomas Hanschke <th.han@arcor.de>
To: submit@bugs.x2go.org
Cc: mike.gabriel@das-netzwerkteam.de
Date: Thu, 28 Mar 2013 16:31:23 +0100
Content-Type: text/plain; charset="UTF-8"
X-Mailer: Evolution 3.2.3-0ubuntu6 
Content-Transfer-Encoding: 7bit
Mime-Version: 1.0
Package: x2goagent
Version: 2:3.5.0.17-0~320~precise1
        
I have 25 thinclients (wyse with windows7 embedded) in a classroom.
If more than 2 or 3 clients log on at exactly the same time, some of
them stop at the black screen before the gray X2Go Logo appears.
There is no error message. With a little timeshift of 2 or 3 seconds
between the logons, there are no problems.
          
I suggest a while-loop in x2gostartagent that looped through the
displays until it had a valid display and free ports.
        
        
I am using Ubuntu Version 12.04 (precise) (32-Bit),
Kernel Linux 3.2.0-39-generic-pae.
         
        Thanks for your help!
        Thomas


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Fri Feb 23 09:47:01 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.