X2Go Bug report logs - #155
25 user logon problem

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Thomas Hanschke <th.han@arcor.de>

Date: Thu, 28 Mar 2013 15:33:02 UTC

Severity: normal

Tags: moreinfo, patch, pending

Fixed in version 4.0.0.3

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log


Message #14 received at 155@bugs.x2go.org (full text, mbox, reply):

Received: (at 155) by bugs.x2go.org; 15 Apr 2013 21:08:51 +0000
From mike.gabriel@das-netzwerkteam.de  Mon Apr 15 23:08:42 2013
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.0 required=5.0 tests=URIBL_BLOCKED
	autolearn=unavailable version=3.3.2
Received: from freya.das-netzwerkteam.de (freya.das-netzwerkteam.de [88.198.48.199])
	by ymir (Postfix) with ESMTPS id AB1155DB11;
	Mon, 15 Apr 2013 23:08:42 +0200 (CEST)
Received: from grimnir.das-netzwerkteam.de (grimnir.das-netzwerkteam.de [78.46.204.98])
	by freya.das-netzwerkteam.de (Postfix) with ESMTPS id 735781837;
	Mon, 15 Apr 2013 23:08:42 +0200 (CEST)
Received: from localhost (localhost [127.0.0.1])
	by grimnir.das-netzwerkteam.de (Postfix) with ESMTP id 4713E3BAE7;
	Mon, 15 Apr 2013 23:08:42 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at grimnir.das-netzwerkteam.de
Received: from grimnir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (grimnir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id 60czUAMA7sQR; Mon, 15 Apr 2013 23:08:41 +0200 (CEST)
Received: from localhost (localhost [127.0.0.1])
	by grimnir.das-netzwerkteam.de (Postfix) with ESMTP id D4D6F3BB9B;
	Mon, 15 Apr 2013 23:08:41 +0200 (CEST)
Received: from localhost (localhost [127.0.0.1])
	by grimnir.das-netzwerkteam.de (Postfix) with ESMTP id B44173B9E5;
	Mon, 15 Apr 2013 23:08:41 +0200 (CEST)
Received: by grimnir.das-netzwerkteam.de (Postfix, from userid 33)
	id ABD1E3BB8B; Mon, 15 Apr 2013 23:08:40 +0200 (CEST)
Received: from 77-2-142-46.pool.kielnet.net (77-2-142-46.pool.kielnet.net
 [46.142.2.77]) by mail.das-netzwerkteam.de (Horde Framework) with HTTP;
 Mon, 15 Apr 2013 23:08:40 +0200
Message-ID: <20130415230840.103249kxioog6tso@mail.das-netzwerkteam.de>
X-Priority: 3 (Normal)
Date: Mon, 15 Apr 2013 23:08:40 +0200
From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Thomas Hanschke <th.han@arcor.de>, 155@bugs.x2go.org
Cc: control@bugs.x2go.org
Subject: Re: 25 user logon problem
References: <1364484683.17230.2.camel@thh-imedia-S1300>
In-Reply-To: <1364484683.17230.2.camel@thh-imedia-S1300>
MIME-Version: 1.0
Content-Type: multipart/signed;
 boundary="=_413g2ofty994";
 protocol="application/pgp-signature";
 micalg="pgp-sha1"
Content-Transfer-Encoding: 7bit
User-Agent: Internet Messaging Program (IMP) H3 (4.3.4)
[Message part 1 (text/plain, inline)]
tag #155 moreinfo
thanks

Hi Thomas,

thanks for reporting the below issue.

On Do 28 Mär 2013 16:31:23 CET Thomas Hanschke wrote:

> I have 25 thinclients (wyse with windows7 embedded) in a classroom.
> If more than 2 or 3 clients log on at exactly the same time, some of
> them stop at the black screen before the gray X2Go Logo appears.
> There is no error message. With a little timeshift of 2 or 3 seconds
> between the logons, there are no problems.
>
> I suggest a while-loop in x2gostartagent that looped through the
> displays until it had a valid display and free ports.

I have attached a slightly modified x2gostartagent script and patch  
file that document the changes to this mail.

Please copy the x2gostartagent script to /usr/bin/x2gostartagent on  
the server and report back if the performed modification fixes your  
25-user-issue.

@Devs: I suspect we have to query x2gogetport 3x times during one run  
of x2gostartagent to make sure that more-than-one instances of  
x2gostartagent (run by different users at the very same time, a  
typical class room situation) do not interfere with each other. This  
probably has to happen in x2goresume-session, as well.

I am not 100% sure if the modified x2gostartagent reduces the reported  
issue to zero, but my guess is that the reported issue should go down  
in occurrence tremendously.

Please test with your setup and give feedback.

Greets+thanks,
Mike


-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb
[x2gostartagent (application/x-sh, attachment)]
[25-user-x2goserver.patch (text/x-patch, attachment)]
[Message part 4 (application/pgp-signature, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Fri Feb 23 11:02:10 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.