X2Go Bug report logs - #1435
xfce4-screenshooter resulting in blank screen while selecting area

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Stanimir Stoyanov <ss@stansoft.bg>

Date: Tue, 28 Jan 2020 16:00:03 UTC

Severity: normal

Found in version 4.1.0.3

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 28 Jan 2020 15:55:09 +0000
From ss@stansoft.bg  Tue Jan 28 16:55:05 2020
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-2.0 required=3.0 tests=BAYES_00,DKIM_SIGNED,
	DKIM_VALID,DKIM_VALID_AU,HTML_MESSAGE,SPF_HELO_NONE,URIBL_BLOCKED
	autolearn=ham autolearn_force=no version=3.4.2
Received: from eumembers.stansoft.bg (eumembers.stansoft.bg [IPv6:2001:470:1f15:661::10:1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 9772B5DAE5
	for <submit@bugs.x2go.org>; Tue, 28 Jan 2020 16:55:01 +0100 (CET)
Received: from eumembers.stansoft.bg (localhost [127.0.0.1])
	by eumembers.stansoft.bg (Postfix) with ESMTP id 39FFF62421
	for <submit@bugs.x2go.org>; Tue, 28 Jan 2020 15:55:00 +0000 (UTC)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=stansoft.bg; s=mail;
	t=1580226900; bh=w9a+DcTe07PhaIksj2Hgn7ZH+npAUmZ7Lv0WXcpVYE4=;
	h=To:From:Subject:Date:From;
	b=l1d59jDH5J+1WO4xWcQp2MVoFncgnFosljafGXwC6Ora8Cnv0nZFvnfSHlsKN3FSn
	 bReazIWoBLIfbliqWlnXt/dOqFVX415otr7aEO+4ZypJbpJ0kMNYG8ejX2xhCco6JY
	 sMZ0ipGxz1x59ENrL2IqRrA18nA1HK33+sNo114E=
Received: from [192.168.168.98] (haskovo.stansoft.bg [93.183.131.108])
	(using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits))
	(No client certificate requested)
	by eumembers.stansoft.bg (Postfix) with ESMTPSA id E765861BA8
	for <submit@bugs.x2go.org>; Tue, 28 Jan 2020 15:54:59 +0000 (UTC)
Authentication-Results: eumembers.stansoft.bg; dmarc=fail (p=none dis=none) header.from=stansoft.bg
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=stansoft.bg; s=mail;
	t=1580226900; bh=w9a+DcTe07PhaIksj2Hgn7ZH+npAUmZ7Lv0WXcpVYE4=;
	h=To:From:Subject:Date:From;
	b=l1d59jDH5J+1WO4xWcQp2MVoFncgnFosljafGXwC6Ora8Cnv0nZFvnfSHlsKN3FSn
	 bReazIWoBLIfbliqWlnXt/dOqFVX415otr7aEO+4ZypJbpJ0kMNYG8ejX2xhCco6JY
	 sMZ0ipGxz1x59ENrL2IqRrA18nA1HK33+sNo114E=
To: submit@bugs.x2go.org
From: Stanimir Stoyanov <ss@stansoft.bg>
Subject: xfce4-screenshooter resulting in blank screen while selecting area
Message-ID: <1961cc6c-50dc-d8b8-1197-9c9269266941@stansoft.bg>
Date: Tue, 28 Jan 2020 17:54:56 +0200
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101
 Thunderbird/68.4.1
MIME-Version: 1.0
Content-Type: multipart/alternative;
 boundary="------------7BFE03A86B5C0A40892144AD"
Content-Language: en-US
X-AV-Checked: yes
[Message part 1 (text/plain, inline)]
Package: x2goserver
Version: 4.1.0.3

When I try to select an area to be screenshot'ed using 
xfce4-screenshooter on the server I see only a black screen.

Client OS: Debian 10 buster
Client X2GoClient: 4.1.2.1
Server OS: Debian 10 buster
x2goserver: 4.1.0.3-4
x2goserver-xsession: 4.1.0.3-4
nxagent: 3.5.99.22
xfce: 4.12
xfce4-screenshooter: 1.9.3


[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu Jul 9 18:55:45 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.