X2Go Bug report logs - #1422
Clipboard copy-paste not reliable in Windows 10 (x2goclient) to Linux CentOs (x2goserver)

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Antoine Tran <antoine.tran@thales-services.fr>

Date: Tue, 10 Dec 2019 10:10:03 UTC

Severity: normal

Full log


Message #10 received at 1422@bugs.x2go.org (full text, mbox, reply):

Received: (at 1422) by bugs.x2go.org; 10 Dec 2019 10:39:44 +0000
From ulrich.sibiller@gmail.com  Tue Dec 10 11:39:36 2019
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on
	ymir.das-netzwerkteam.de
X-Spam-Level: *
X-Spam-Status: No, score=2.0 required=3.0 tests=BAYES_50,DKIM_SIGNED,
	DKIM_VALID,DKIM_VALID_AU,FREEMAIL_FROM,FREEMAIL_REPLYTO,
	FREEMAIL_REPLYTO_END_DIGIT,SPF_HELO_NONE,URIBL_BLOCKED autolearn=no
	autolearn_force=no version=3.4.2
Received: from mail-vs1-xe33.google.com (mail-vs1-xe33.google.com [IPv6:2607:f8b0:4864:20::e33])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 96A185DAF2;
	Tue, 10 Dec 2019 11:39:35 +0100 (CET)
Received: by mail-vs1-xe33.google.com with SMTP id b79so7563692vsd.9;
        Tue, 10 Dec 2019 02:39:35 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20161025;
        h=mime-version:references:in-reply-to:reply-to:from:date:message-id
         :subject:to:cc:content-transfer-encoding;
        bh=tPqxVwkpI1eOUgYDkK0Y1OzvBEFD/eccDAiwytnxiyc=;
        b=KEWgWNdijBtD1R++i5gAWVAfqxJT4FPQXzu2YUAxNun1r519Lb2Tqc9ngqRqxWQXm6
         leHJiL7LYsdciLM6nAc427aOzbKK8WTHlrJHa63XJ0Jl/GNKga0RRjZH+i4tFWn14ADG
         rafBsw3hLj66f7C4/TAbEwEfErud64LR5XWUhJjiuBcTrUcGtRxPgauxb+bauVqjt6LX
         xecsDnsehjw3S6xHdJ2nXovuOnlLWvg1Hh4CLMNwGA5niQYFoMQ9fOm269Ir2BSVE81D
         ZQlPbyTKhT5uAK+USwTaQjMPVgzaa4WqaebMZhXx1530UQtEzlm8mzT2rXelAg6qB/TF
         tfIw==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20161025;
        h=x-gm-message-state:mime-version:references:in-reply-to:reply-to
         :from:date:message-id:subject:to:cc:content-transfer-encoding;
        bh=tPqxVwkpI1eOUgYDkK0Y1OzvBEFD/eccDAiwytnxiyc=;
        b=jV4eLOAJOj9/h2G33PoPkA0MzAXuTVHiU652Pnro5aJ5r71y08SmluKGlFpo2CZpt1
         OHs/XKRROOqMwmcTqATMQvpRAaq8R1c3vJrhjkn+HGPZmXVHGhjRVj0MkGAs9Sdsf6i5
         H32dWCU33Vxd0/2jytq8jg2kLpBWX4mhyXOa0TI+yCgSuzQhFAcZIXskioirXT6OEfkM
         O718rHIUPB1f/wV0Wx2anIXnO+noq7qPiDoICZxGhIEi6cZCoZdk+Jhy+ztI61KAmvPG
         9GV/Lj9DWhKMFAKHLukZB3Px4k7vNhkdqQDgPcwsvFwEJ6wX1z3cVxuioUTc4d+6Mjwn
         SBOQ==
X-Gm-Message-State: APjAAAWbrg6oeYclDByLB6dg63TjrFawYEnlNSMHF6XYkYh8mKuR4vfg
	Hv23MH7J7no/b2mrXLclM6181aOHFANFAfE2IcA=
X-Google-Smtp-Source: APXvYqzk0ylHnIHsczCKkDYId8c/fDwz2PFfDRgqjxcAyS69rRpwOjdZj3rebE1AakVNIgGOS2mruTsiaoK0hy5nG24=
X-Received: by 2002:a67:680c:: with SMTP id d12mr10344620vsc.234.1575974374320;
 Tue, 10 Dec 2019 02:39:34 -0800 (PST)
MIME-Version: 1.0
References: <507f93a8-238a-1f5f-9313-b32800963fbf@thales-services.fr>
In-Reply-To: <507f93a8-238a-1f5f-9313-b32800963fbf@thales-services.fr>
Reply-To: uli42@gmx.de
From: Ulrich Sibiller <ulrich.sibiller@gmail.com>
Date: Tue, 10 Dec 2019 11:39:08 +0100
Message-ID: <CANVnVYJPAh6dHbNOFLcWbGiXO2_O48WEN1gdQqcyWt6_dh970w@mail.gmail.com>
Subject: Re: [X2Go-Dev] Bug#1422: Clipboard copy-paste not reliable in Windows
 10 (x2goclient) to Linux CentOs (x2goserver)
To: Antoine Tran <antoine.tran@thales-services.fr>, 1422@bugs.x2go.org
Cc: submit@bugs.x2go.org
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
On Tue, Dec 10, 2019 at 11:10 AM Antoine Tran
<antoine.tran@thales-services.fr> wrote:
> The clipboard in the past versions until now are not really reliable. Many times I have to close the x2goclient window, and reconnect to make it work again. I have some issue to find a reproduce way, but it is occurs oftenly. When it is broken, I can copy paste in CentOs, but not from it to Windows. But then in Windows I can copy paste too, but only from it, as if there were two clipboard. Sometime, it symptom is different: there is a freeze of 3s when in CentOs it tries to copy or to paste from Windows. Sometime, the paste in Windows simply paste nothing, or just a space, but it still work in CentOs.
>
> Clipboard is very handy when it works, so this issue is very inconvenient, sometime I have to close/open the x2goclient many times a day because of this issue. Also, changing clipboard mode from client to server only does not seems to work better. Thank you.

I have done some work on the clipboard code (again), so hopefully the
next nx version (3.5.99.23) will improve the situation. I am not
really sure why the situation has become worse in recent times (as I
conclude from various reports). Please ensure you do _not_ have a
clipboard manager running in CentOS. This it not supported an will
cause unexpected problems.

Uli


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Jul 14 20:44:14 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.