X2Go Bug report logs - #1422
Clipboard copy-paste not reliable in Windows 10 (x2goclient) to Linux CentOs (x2goserver)

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Antoine Tran <antoine.tran@thales-services.fr>

Date: Tue, 10 Dec 2019 10:10:03 UTC

Severity: normal

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1422; Package x2goserver. (Tue, 10 Dec 2019 10:10:03 GMT) (full text, mbox, link).


Acknowledgement sent to Antoine Tran <antoine.tran@thales-services.fr>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>.

Your message had a Version: pseudo-header with an invalid package version:

=4.1.0.3

please either use found or fixed to the control server with a correct version, or reply to this report indicating the correct version so the maintainer (or someone else) can correct it for you.

(Tue, 10 Dec 2019 10:10:03 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

From: Antoine Tran <antoine.tran@thales-services.fr>
To: submit@bugs.x2go.org
Subject: Clipboard copy-paste not reliable in Windows 10 (x2goclient) to Linux CentOs (x2goserver)
Date: Tue, 10 Dec 2019 11:08:43 +0100
[Message part 1 (text/plain, inline)]
Package: x2goserver
Version: =4.1.0.3
Tags: clipboard copy paste

Environment x2goclient: Windows 10 17763, x2goclient 
x2goclient-4.1.2.0-2018.06.22-setup.exe 
<https://code.x2go.org/releases/binary-win32/x2goclient/releases/4.1.2.0-2018.06.22/x2goclient-4.1.2.0-2018.06.22-setup.exe>

Environement x2goserver: Linux CentOs 7.7, 
x2goserver-4.1.0.3-3.el7.x86_64.rpm
<https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/x/x2goserver-4.1.0.3-3.el7.x86_64.rpm>

Dear all,

The clipboard in the past versions until now are not really reliable. 
Many times I have to close the x2goclient window, and reconnect to make 
it work again. I have some issue to find a reproduce way, but it is 
occurs oftenly. When it is broken, I can copy paste in CentOs, but not 
from it to Windows. But then in Windows I can copy paste too, but only 
from it, as if there were two clipboard. Sometime, it symptom is 
different: there is a freeze of 3s when in CentOs it tries to copy or to 
paste from Windows. Sometime, the paste in Windows simply paste nothing, 
or just a space, but it still work in CentOs.

Clipboard is very handy when it works, so this issue is very 
inconvenient, sometime I have to close/open the x2goclient many times a 
day because of this issue. Also, changing clipboard mode from client to 
server only does not seems to work better. Thank you.

Yours sincerely,

Antoine

[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1422; Package x2goserver. (Tue, 10 Dec 2019 10:40:02 GMT) (full text, mbox, link).


Acknowledgement sent to uli42@gmx.de:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 10 Dec 2019 10:40:03 GMT) (full text, mbox, link).


Message #10 received at 1422@bugs.x2go.org (full text, mbox, reply):

From: Ulrich Sibiller <ulrich.sibiller@gmail.com>
To: Antoine Tran <antoine.tran@thales-services.fr>, 1422@bugs.x2go.org
Cc: submit@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1422: Clipboard copy-paste not reliable in Windows 10 (x2goclient) to Linux CentOs (x2goserver)
Date: Tue, 10 Dec 2019 11:39:08 +0100
On Tue, Dec 10, 2019 at 11:10 AM Antoine Tran
<antoine.tran@thales-services.fr> wrote:
> The clipboard in the past versions until now are not really reliable. Many times I have to close the x2goclient window, and reconnect to make it work again. I have some issue to find a reproduce way, but it is occurs oftenly. When it is broken, I can copy paste in CentOs, but not from it to Windows. But then in Windows I can copy paste too, but only from it, as if there were two clipboard. Sometime, it symptom is different: there is a freeze of 3s when in CentOs it tries to copy or to paste from Windows. Sometime, the paste in Windows simply paste nothing, or just a space, but it still work in CentOs.
>
> Clipboard is very handy when it works, so this issue is very inconvenient, sometime I have to close/open the x2goclient many times a day because of this issue. Also, changing clipboard mode from client to server only does not seems to work better. Thank you.

I have done some work on the clipboard code (again), so hopefully the
next nx version (3.5.99.23) will improve the situation. I am not
really sure why the situation has become worse in recent times (as I
conclude from various reports). Please ensure you do _not_ have a
clipboard manager running in CentOS. This it not supported an will
cause unexpected problems.

Uli


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1422; Package x2goserver. (Tue, 10 Dec 2019 12:15:02 GMT) (full text, mbox, link).


Acknowledgement sent to Antoine Tran <antoine.tran@thales-services.fr>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 10 Dec 2019 12:15:03 GMT) (full text, mbox, link).


Message #15 received at 1422@bugs.x2go.org (full text, mbox, reply):

From: Antoine Tran <antoine.tran@thales-services.fr>
To: uli42@gmx.de, 1422@bugs.x2go.org
Cc: submit@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1422: Clipboard copy-paste not reliable in Windows 10 (x2goclient) to Linux CentOs (x2goserver)
Date: Tue, 10 Dec 2019 13:14:26 +0100
Thank you!

On 10/12/2019 11:39, Ulrich Sibiller wrote:
> I have done some work on the clipboard code (again), so hopefully the
> next nx version (3.5.99.23) will improve the situation. I am not
> really sure why the situation has become worse in recent times (as I
> conclude from various reports).
When it will be available, can you tell me in which version of 
x2go(client/server) it will be fixed, thank you.
> Please ensure you do _not_ have a
> clipboard manager running in CentOS. This it not supported an will
> cause unexpected problems.

I didn't know about clipboard manager. This should be written in 
https://wiki.x2go.org/doku.php/doc:de-compat I guess. Anyway, I use 
Kde4, and it turns out that Klipper is enabled by default. But even when 
I disable it, I reproduce the issue.


>
> Uli


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Aug 5 13:44:09 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.