X2Go Bug report logs - #1359
Tooltips, pull-down menus, and context menus too far away

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Tristan Miller <psychonaut@nothingisreal.com>

Date: Wed, 9 Jan 2019 12:45:01 UTC

Severity: normal

Found in version 4.1.1.1

Done: Tristan Miller <psychonaut@nothingisreal.com>

Bug is archived. No further changes may be made.

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1359: Tooltips, pull-down menus,  and context menus too far away
Reply-To: Tristan Miller <psychonaut@nothingisreal.com>, 1359@bugs.x2go.org
Resent-From: Tristan Miller <psychonaut@nothingisreal.com>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Wed, 09 Jan 2019 12:45:01 +0000
Resent-Message-ID: <handler.1359.B.154703775811770@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: report 1359
X-X2Go-PR-Package: x2goclient
X-X2Go-PR-Keywords: 
Received: via spool by submit@bugs.x2go.org id=B.154703775811770
          (code B); Wed, 09 Jan 2019 12:45:01 +0000
Received: (at submit) by bugs.x2go.org; 9 Jan 2019 12:42:38 +0000
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.8 required=3.0 tests=BAYES_50,SPF_HELO_PASS
	autolearn=ham autolearn_force=no version=3.4.2
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id F40D15DAF2
	for <submit@bugs.x2go.org>; Wed,  9 Jan 2019 13:42:34 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id XovcKhiw4t8i for <submit@bugs.x2go.org>;
	Wed,  9 Jan 2019 13:42:28 +0100 (CET)
X-Greylist: delayed 441 seconds by postgrey-1.35 at ymir.das-netzwerkteam.de; Wed, 09 Jan 2019 13:42:27 CET
Received: from balrog.mythic-beasts.com (balrog.mythic-beasts.com [IPv6:2a00:1098:0:82:1000:0:2:1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id E21AE5DACE
	for <submit@bugs.x2go.org>; Wed,  9 Jan 2019 13:42:27 +0100 (CET)
Received: from [88.153.49.225] (port=55368 helo=butterfield.nothingisreal.com)
	by balrog.mythic-beasts.com with esmtpa (Exim 4.90_1)
	(envelope-from <psychonaut@nothingisreal.com>)
	id 1ghDBf-0000rx-Ff
	for submit@bugs.x2go.org; Wed, 09 Jan 2019 12:42:27 +0000
Received: from pi.nothingisreal.com (localhost [IPv6:::1])
	by butterfield.nothingisreal.com (Postfix) with ESMTP id E11AFC7E1
	for <submit@bugs.x2go.org>; Wed,  9 Jan 2019 13:42:22 +0100 (CET)
Date: Wed, 9 Jan 2019 13:42:22 +0100
From: Tristan Miller <psychonaut@nothingisreal.com>
To: submit@bugs.x2go.org
Message-ID: <20190109134222.08c257f3.psychonaut@nothingisreal.com>
X-Mailer: Claws Mail 3.17.1 (GTK+ 2.24.32; x86_64-suse-linux-gnu)
MIME-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha512;
 boundary="Sig_/0td_ITQ301zSv0PNOaRz5Vo"; protocol="application/pgp-signature"
X-BlackCat-Spam-Score: -10
[Message part 1 (text/plain, inline)]
Package: x2goclient
Version: 4.1.1.1

I've recently started experiencing a problem when running single
applications over X2Go.  Quite often small windows such as tooltips,
pull-down menus, and context menus get positioned far, far away from
where they are supposed to be.  For example, I'm currently writing this
message in Claws Mail; when I activate the "Edit" pull-down menu, the
menu doesn't appear under the menu bar but rather way over on my second
screen.  (I use a dual-monitor setup.)

The problem happens with a lot of different applications, but not
always consistently.  For instance, sometimes I might hover my pointer
over a widget that causes a tooltip to display halfway across the
screen, and a minute or two later I'll do the same thing but this time
the tooltip will display right over the widget like it's supposed to.

I'm not sure if this is a bug in X2Go or in my window manager, and if
it is in X2Go, whether its the client or server that's at fault.  I'm
running the X2Go Server 4.1.0.4 on openSUSE Tumbleweed, and connecting
from X2Go Client 4.1.1.1 on openSUSE Leap 15.0, using KDE Plasma
5.12.6.  (I can't upgrade the client due to Bug #1358.)
[Message part 2 (application/pgp-signature, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Mon May 27 08:51:21 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.