X2Go Bug report logs - #1359
Tooltips, pull-down menus, and context menus too far away

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Tristan Miller <psychonaut@nothingisreal.com>

Date: Wed, 9 Jan 2019 12:45:01 UTC

Severity: normal

Found in version 4.1.1.1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1359; Package x2goclient. (Wed, 09 Jan 2019 12:45:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Tristan Miller <psychonaut@nothingisreal.com>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 09 Jan 2019 12:45:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Tristan Miller <psychonaut@nothingisreal.com>
To: submit@bugs.x2go.org
Subject: Tooltips, pull-down menus, and context menus too far away
Date: Wed, 9 Jan 2019 13:42:22 +0100
[Message part 1 (text/plain, inline)]
Package: x2goclient
Version: 4.1.1.1

I've recently started experiencing a problem when running single
applications over X2Go.  Quite often small windows such as tooltips,
pull-down menus, and context menus get positioned far, far away from
where they are supposed to be.  For example, I'm currently writing this
message in Claws Mail; when I activate the "Edit" pull-down menu, the
menu doesn't appear under the menu bar but rather way over on my second
screen.  (I use a dual-monitor setup.)

The problem happens with a lot of different applications, but not
always consistently.  For instance, sometimes I might hover my pointer
over a widget that causes a tooltip to display halfway across the
screen, and a minute or two later I'll do the same thing but this time
the tooltip will display right over the widget like it's supposed to.

I'm not sure if this is a bug in X2Go or in my window manager, and if
it is in X2Go, whether its the client or server that's at fault.  I'm
running the X2Go Server 4.1.0.4 on openSUSE Tumbleweed, and connecting
from X2Go Client 4.1.1.1 on openSUSE Leap 15.0, using KDE Plasma
5.12.6.  (I can't upgrade the client due to Bug #1358.)
[Message part 2 (application/pgp-signature, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1359; Package x2goclient. (Wed, 09 Jan 2019 13:35:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to uli42@gmx.de:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 09 Jan 2019 13:35:03 GMT) Full text and rfc822 format available.

Message #10 received at 1359@bugs.x2go.org (full text, mbox):

From: Ulrich Sibiller <ulrich.sibiller@gmail.com>
To: Tristan Miller <psychonaut@nothingisreal.com>, 1359@bugs.x2go.org
Cc: submit@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1359: Tooltips, pull-down menus, and context menus too far away
Date: Wed, 9 Jan 2019 14:32:23 +0100
Cloned that into an nx-libs issue:
https://github.com/ArcticaProject/nx-libs/issues/757

On Wed, Jan 9, 2019 at 1:51 PM Tristan Miller
<psychonaut@nothingisreal.com> wrote:
>
> Package: x2goclient
> Version: 4.1.1.1
>
> I've recently started experiencing a problem when running single
> applications over X2Go.  Quite often small windows such as tooltips,
> pull-down menus, and context menus get positioned far, far away from
> where they are supposed to be.  For example, I'm currently writing this
> message in Claws Mail; when I activate the "Edit" pull-down menu, the
> menu doesn't appear under the menu bar but rather way over on my second
> screen.  (I use a dual-monitor setup.)
>
> The problem happens with a lot of different applications, but not
> always consistently.  For instance, sometimes I might hover my pointer
> over a widget that causes a tooltip to display halfway across the
> screen, and a minute or two later I'll do the same thing but this time
> the tooltip will display right over the widget like it's supposed to.
>
> I'm not sure if this is a bug in X2Go or in my window manager, and if
> it is in X2Go, whether its the client or server that's at fault.  I'm
> running the X2Go Server 4.1.0.4 on openSUSE Tumbleweed, and connecting
> from X2Go Client 4.1.1.1 on openSUSE Leap 15.0, using KDE Plasma
> 5.12.6.  (I can't upgrade the client due to Bug #1358.)
> _______________________________________________
> x2go-dev mailing list
> x2go-dev@lists.x2go.org
> https://lists.x2go.org/listinfo/x2go-dev


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu Jan 17 10:59:19 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.