X2Go Bug report logs - #1240
broker bug with accentuated characters in password

version graph

Package: x2gobroker; Maintainer for x2gobroker is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2gobroker is src:x2gobroker.

Reported by: Walid MOGHRABI <w.moghrabi@servicemagic.eu>

Date: Wed, 13 Dec 2017 18:30:02 UTC

Severity: normal

Tags: pending

Fixed in versions 0.4.0.0, 0.0.4.0

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1240; Package x2gobroker. (Wed, 13 Dec 2017 18:30:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Walid MOGHRABI <w.moghrabi@servicemagic.eu>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>.

Your message specified a Severity: in the pseudo-header, but the severity value bug was not recognised. The default severity normal is being used instead. The recognised values are: critical, grave, important, normal, minor, wishlist.

(Wed, 13 Dec 2017 18:30:02 GMT) Full text and rfc822 format available.


Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Walid MOGHRABI <w.moghrabi@servicemagic.eu>
To: submit@bugs.x2go.org
Subject: broker bug with accentuated characters in password
Date: Wed, 13 Dec 2017 19:29:07 +0100 (CET)
package: x2gobroker
priority: bug

Context : I'm using PAM auth with the X2Gobroker which relies on Samba/Winbind to use ActiveDirectory based authentication.
It works pretty well but some users couldn't auth even though we triple checked their username/password combination.
It appears these users had some accentuated characters in their password so I suppose there is a charset issue there, not sure if the broker uses iso/latin encoding or UTF8.


Regards,
Walid Moghrabi

TRAVAUX.COM
BAT I - PARC CEZANNE 2 290 AVENUE GALILEE - CS 80403
13591 AIX EN PROVENCE CEDEX 3
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1240; Package x2gobroker. (Mon, 18 Dec 2017 11:30:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 18 Dec 2017 11:30:02 GMT) Full text and rfc822 format available.

Message #10 received at 1240@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Walid MOGHRABI <w.moghrabi@servicemagic.eu>, 1240@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1240: broker bug with accentuated characters in password
Date: Mon, 18 Dec 2017 11:27:54 +0000
[Message part 1 (text/plain, inline)]
Hi Walid, hi all,

On  Mi 13 Dez 2017 19:29:07 CET, Walid MOGHRABI wrote:

> package: x2gobroker
> priority: bug
>
> Context : I'm using PAM auth with the X2Gobroker which relies on  
> Samba/Winbind to use ActiveDirectory based authentication.
> It works pretty well but some users couldn't auth even though we  
> triple checked their username/password combination.
> It appears these users had some accentuated characters in their  
> password so I suppose there is a charset issue there, not sure if  
> the broker uses iso/latin encoding or UTF8.
>
>
> Regards,
> Walid Moghrabi

I will work on this in the second week of January on a contracted basis.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

[Message part 2 (application/pgp-signature, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1240; Package x2gobroker. (Mon, 12 Feb 2018 15:55:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 12 Feb 2018 15:55:03 GMT) Full text and rfc822 format available.

Message #15 received at 1240@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Walid MOGHRABI <w.moghrabi@servicemagic.eu>, 1240@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1240: broker bug with accentuated characters in password
Date: Mon, 12 Feb 2018 15:52:16 +0000
[Message part 1 (text/plain, inline)]
Hi Walid,

On  Mi 13 Dez 2017 19:29:07 CET, Walid MOGHRABI wrote:

> package: x2gobroker
> priority: bug
>
> Context : I'm using PAM auth with the X2Gobroker which relies on  
> Samba/Winbind to use ActiveDirectory based authentication.
> It works pretty well but some users couldn't auth even though we  
> triple checked their username/password combination.
> It appears these users had some accentuated characters in their  
> password so I suppose there is a charset issue there, not sure if  
> the broker uses iso/latin encoding or UTF8.
>
>
> Regards,
> Walid Moghrabi

Regarding the above issue, can you please test, if an authentication  
via the test tool works?

Steps:

1) Make sure the x2gobroker-authservice is running

2) x2gobroker-testauth --user=<user>

(Password is queried then after having hit <ENTER>.

Does that work? Or does this also fail? (Here it works).

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

[Message part 2 (application/pgp-signature, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1240; Package x2gobroker. (Mon, 12 Feb 2018 17:50:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Walid MOGHRABI <w.moghrabi@servicemagic.eu>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 12 Feb 2018 17:50:01 GMT) Full text and rfc822 format available.

Message #20 received at 1240@bugs.x2go.org (full text, mbox):

From: Walid MOGHRABI <w.moghrabi@servicemagic.eu>
To: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Cc: 1240@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1240: broker bug with accentuated characters in password
Date: Mon, 12 Feb 2018 18:38:21 +0100 (CET)
Hi,

Just re-tried and now it works.
Dunno if something has been fixed since when I declared the bug ... maybe the upgrade to Python3.


Regards,
Walid Moghrabi

TRAVAUX.COM
BAT I - PARC CEZANNE 2 290 AVENUE GALILEE - CS 80403
13591 AIX EN PROVENCE CEDEX 3

----- Mail original ----- 

De: "Mike Gabriel" <mike.gabriel@das-netzwerkteam.de> 
À: "Walid MOGHRABI" <w.moghrabi@servicemagic.eu>, 1240@bugs.x2go.org 
Envoyé: Lundi 12 Février 2018 16:52:16 
Objet: Re: [X2Go-Dev] Bug#1240: broker bug with accentuated characters in password 

Hi Walid, 

On Mi 13 Dez 2017 19:29:07 CET, Walid MOGHRABI wrote: 

> package: x2gobroker 
> priority: bug 
> 
> Context : I'm using PAM auth with the X2Gobroker which relies on 
> Samba/Winbind to use ActiveDirectory based authentication. 
> It works pretty well but some users couldn't auth even though we 
> triple checked their username/password combination. 
> It appears these users had some accentuated characters in their 
> password so I suppose there is a charset issue there, not sure if 
> the broker uses iso/latin encoding or UTF8. 
> 
> 
> Regards, 
> Walid Moghrabi 

Regarding the above issue, can you please test, if an authentication 
via the test tool works? 

Steps: 

1) Make sure the x2gobroker-authservice is running 

2) x2gobroker-testauth --user=<user> 

(Password is queried then after having hit <ENTER>. 

Does that work? Or does this also fail? (Here it works). 

Mike 
-- 

DAS-NETZWERKTEAM 
mike gabriel, herweg 7, 24357 fleckeby 
mobile: +49 (1520) 1976 148 
landline: +49 (4354) 8390 139 

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22 0782 9AF4 6B30 2577 1B31 
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1240; Package x2gobroker. (Mon, 12 Feb 2018 20:20:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 12 Feb 2018 20:20:02 GMT) Full text and rfc822 format available.

Message #25 received at 1240@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Walid MOGHRABI <w.moghrabi@servicemagic.eu>
Cc: 1240@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1240: broker bug with accentuated characters in password
Date: Mon, 12 Feb 2018 20:18:17 +0000
[Message part 1 (text/plain, inline)]
Control: tags -1 pending
Control: fixed -1 0.4.0.0

Hi Walid

On  Mo 12 Feb 2018 18:38:21 CET, Walid MOGHRABI wrote:

> Just re-tried and now it works.
> Dunno if something has been fixed since when I declared the bug ...  
> maybe the upgrade to Python3.

Ok. Let's consider this issues resolved by the Python3 switch (which  
makes strings Unicode strings -- always).

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

[Message part 2 (application/pgp-signature, inline)]

Added tag(s) pending. Request was from Mike Gabriel <mike.gabriel@das-netzwerkteam.de> to 1240-submit@bugs.x2go.org. (Mon, 12 Feb 2018 20:20:03 GMT) Full text and rfc822 format available.

Marked as fixed in versions 0.4.0.0. Request was from Mike Gabriel <mike.gabriel@das-netzwerkteam.de> to 1240-submit@bugs.x2go.org. (Mon, 12 Feb 2018 20:20:03 GMT) Full text and rfc822 format available.

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1240; Package x2gobroker. (Mon, 12 Feb 2018 20:25:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 12 Feb 2018 20:25:01 GMT) Full text and rfc822 format available.

Message #34 received at 1240@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: 1240-submitter@bugs.x2go.org
Cc: control@bugs.x2go.org, 1240@bugs.x2go.org
Subject: X2Go issue (in src:x2gobroker) has been marked as pending for release
Date: Mon, 12 Feb 2018 21:21:04 +0100 (CET)
tag #1240 pending
fixed #1240 0.0.4.0
thanks

Hello,

X2Go issue #1240 (src:x2gobroker) reported by you has been
fixed in X2Go Git. You can see the changelog below, and you can
check the diff of the fix at:

    http://code.x2go.org/gitweb?p=x2gobroker.git;a=commitdiff;h=52b542f

The issue will most likely be fixed in src:x2gobroker (0.0.4.0).

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
commit 52b542f9735485fa5a0f912281e3d44d714ef9a9
Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Date:   Mon Feb 12 21:20:54 2018 +0100

    debian/changelog: add closure for #1240

diff --git a/debian/changelog b/debian/changelog
index 46cf7ec..3db7744 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,7 +2,7 @@ x2gobroker (0.0.4.0-0x2go1) UNRELEASED; urgency=medium
 
   * New upstream version (0.0.4.0):
     - Bump upstream version to 0.0.4.0.
-    - Port to Python 3.
+    - Port to Python 3. (Fixes: #1240).
     - Drop left-over debug print() call.
     - Makefile: Assure that setup.py is run under Python3.
     - Improve debugging messages during authentication phase.


Marked as fixed in versions 0.0.4.0. Request was from Mike Gabriel <mike.gabriel@das-netzwerkteam.de> to control@bugs.x2go.org. (Mon, 12 Feb 2018 20:25:02 GMT) Full text and rfc822 format available.

Message sent on to Walid MOGHRABI <w.moghrabi@servicemagic.eu>:
Bug#1240. (Mon, 12 Feb 2018 20:25:02 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Dec 11 06:51:09 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.