X2Go Bug report logs - #1240
broker bug with accentuated characters in password

version graph

Package: x2gobroker; Maintainer for x2gobroker is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2gobroker is src:x2gobroker.

Reported by: Walid MOGHRABI <w.moghrabi@servicemagic.eu>

Date: Wed, 13 Dec 2017 18:30:02 UTC

Severity: normal

Tags: pending

Fixed in versions 0.4.0.0, 0.0.4.0

Done: X2Go Release Manager X2Go Release Manager <git-admin@x2go.org>

Bug is archived. No further changes may be made.

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1240: [X2Go-Dev] Bug#1240: broker bug with accentuated characters in password
Reply-To: Walid MOGHRABI <w.moghrabi@servicemagic.eu>, 1240@bugs.x2go.org
Resent-From: Walid MOGHRABI <w.moghrabi@servicemagic.eu>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Mon, 12 Feb 2018 17:50:01 +0000
Resent-Message-ID: <handler.1240.B1240.151845765812752@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 1240
X-X2Go-PR-Package: x2gobroker
X-X2Go-PR-Keywords: 
Received: via spool by 1240-submit@bugs.x2go.org id=B1240.151845765812752
          (code B ref 1240); Mon, 12 Feb 2018 17:50:01 +0000
Received: (at 1240) by bugs.x2go.org; 12 Feb 2018 17:47:38 +0000
X-Spam-Checker-Version: SpamAssassin 3.4.1 (2015-04-28) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-2.0 required=3.0 tests=BAYES_00,DKIM_SIGNED,
	DKIM_VALID,DKIM_VALID_AU,MIME_QP_LONG_LINE,URIBL_BLOCKED autolearn=ham
	autolearn_force=no version=3.4.1
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 916325DACF
	for <1240@bugs.x2go.org>; Mon, 12 Feb 2018 18:47:36 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id IGBjLrOzXn8x for <1240@bugs.x2go.org>;
	Mon, 12 Feb 2018 18:47:31 +0100 (CET)
X-Greylist: delayed 549 seconds by postgrey-1.35 at ymir.das-netzwerkteam.de; Mon, 12 Feb 2018 18:47:31 CET
Received: from zm-01.servicemagic.eu (zm-01.servicemagic.eu [176.31.236.17])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 902825DACE
	for <1240@bugs.x2go.org>; Mon, 12 Feb 2018 18:47:31 +0100 (CET)
Received: from localhost (localhost.localdomain [127.0.0.1])
	by zm-01.servicemagic.eu (Postfix) with ESMTP id 0F89E806B0FBE;
	Mon, 12 Feb 2018 18:38:22 +0100 (CET)
DKIM-Filter: OpenDKIM Filter v2.11.0 zm-01.servicemagic.eu 0F89E806B0FBE
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=servicemagic.eu;
	s=frmailing; t=1518457102;
	bh=efCF1aCtUpurJkbS1pa1QWVTafifVq4z4F84gOVHR0g=;
	h=Date:From:To:Cc:In-Reply-To:Subject:From;
	b=DAsDJ32z0D6UUX1tiA1KKCIH+brwkDee4bYfu5a8yM6rFQ2G4mczIxGtINgJlZBy5
	 JUT21RKunsmZno0q17ylGEsqs2DwrwtQ9trl3dnG1mcmL5IurNFASM/4TOGVBktUN8
	 lAW6Y6rPh0j4zPgkL5+C2FeRrHGWFaIwvJ9JldFs=
X-Amavis-Modified: Mail body modified (using disclaimer) -
	zm-01.servicemagic.eu
X-Virus-Scanned: amavisd-new at servicemagic.eu
Received: from zm-01.servicemagic.eu ([127.0.0.1])
	by localhost (zm-01.servicemagic.eu [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id FYq+8oqqtoUJ; Mon, 12 Feb 2018 18:38:21 +0100 (CET)
Received: from zm-01.servicemagic.eu (localhost.localdomain [127.0.0.1])
	by zm-01.servicemagic.eu (Postfix) with ESMTP id A37D9806C10EF;
	Mon, 12 Feb 2018 18:38:21 +0100 (CET)
Date: Mon, 12 Feb 2018 18:38:21 +0100 (CET)
From: Walid MOGHRABI <w.moghrabi@servicemagic.eu>
To: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Cc: 1240@bugs.x2go.org
Message-ID: <941693121.4341361.1518457101590.JavaMail.root@servicemagic.eu>
In-Reply-To: <20180212155216.Horde.TYZq5YvWEm3Az7NJXWpupFI@mail.das-netzwerkteam.de>
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable
X-Originating-IP: [195.200.167.70]
X-Mailer: Zimbra 7.2.0_GA_2669 (ZimbraWebClient - GC64 (Linux)/7.2.0_GA_2669)
Hi,

Just re-tried and now it works.
Dunno if something has been fixed since when I declared the bug ... maybe the upgrade to Python3.


Regards,
Walid Moghrabi

TRAVAUX.COM
BAT I - PARC CEZANNE 2 290 AVENUE GALILEE - CS 80403
13591 AIX EN PROVENCE CEDEX 3

----- Mail original ----- 

De: "Mike Gabriel" <mike.gabriel@das-netzwerkteam.de> 
À: "Walid MOGHRABI" <w.moghrabi@servicemagic.eu>, 1240@bugs.x2go.org 
Envoyé: Lundi 12 Février 2018 16:52:16 
Objet: Re: [X2Go-Dev] Bug#1240: broker bug with accentuated characters in password 

Hi Walid, 

On Mi 13 Dez 2017 19:29:07 CET, Walid MOGHRABI wrote: 

> package: x2gobroker 
> priority: bug 
> 
> Context : I'm using PAM auth with the X2Gobroker which relies on 
> Samba/Winbind to use ActiveDirectory based authentication. 
> It works pretty well but some users couldn't auth even though we 
> triple checked their username/password combination. 
> It appears these users had some accentuated characters in their 
> password so I suppose there is a charset issue there, not sure if 
> the broker uses iso/latin encoding or UTF8. 
> 
> 
> Regards, 
> Walid Moghrabi 

Regarding the above issue, can you please test, if an authentication 
via the test tool works? 

Steps: 

1) Make sure the x2gobroker-authservice is running 

2) x2gobroker-testauth --user=<user> 

(Password is queried then after having hit <ENTER>. 

Does that work? Or does this also fail? (Here it works). 

Mike 
-- 

DAS-NETZWERKTEAM 
mike gabriel, herweg 7, 24357 fleckeby 
mobile: +49 (1520) 1976 148 
landline: +49 (4354) 8390 139 

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22 0782 9AF4 6B30 2577 1B31 
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Jun 15 15:46:49 2021; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.