X2Go Bug report logs - #1240
broker bug with accentuated characters in password

version graph

Package: x2gobroker; Maintainer for x2gobroker is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2gobroker is src:x2gobroker.

Reported by: Walid MOGHRABI <w.moghrabi@servicemagic.eu>

Date: Wed, 13 Dec 2017 18:30:02 UTC

Severity: normal

Tags: pending

Fixed in versions 0.4.0.0, 0.0.4.0

Done: X2Go Release Manager X2Go Release Manager <git-admin@x2go.org>

Bug is archived. No further changes may be made.

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1240: broker bug with accentuated characters in  password
Reply-To: Walid MOGHRABI <w.moghrabi@servicemagic.eu>, 1240@bugs.x2go.org
Resent-From: Walid MOGHRABI <w.moghrabi@servicemagic.eu>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Wed, 13 Dec 2017 18:30:02 +0000
Resent-Message-ID: <handler.1240.B.151318975514557@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: report 1240
X-X2Go-PR-Package: x2gobroker
X-X2Go-PR-Keywords: 
Received: via spool by submit@bugs.x2go.org id=B.151318975514557
          (code B); Wed, 13 Dec 2017 18:30:02 +0000
Received: (at submit) by bugs.x2go.org; 13 Dec 2017 18:29:15 +0000
X-Spam-Checker-Version: SpamAssassin 3.4.1 (2015-04-28) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.7 required=3.0 tests=BAYES_50,DKIM_SIGNED,
	DKIM_VALID,DKIM_VALID_AU,URIBL_BLOCKED autolearn=ham autolearn_force=no
	version=3.4.1
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id DB2F35DAD0
	for <submit@bugs.x2go.org>; Wed, 13 Dec 2017 19:29:13 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id Jck6XGBhqT8E for <submit@bugs.x2go.org>;
	Wed, 13 Dec 2017 19:29:09 +0100 (CET)
Received: from zm-01.servicemagic.eu (zm-01.servicemagic.eu [176.31.236.17])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 2DC7B5DA96
	for <submit@bugs.x2go.org>; Wed, 13 Dec 2017 19:29:08 +0100 (CET)
Received: from localhost (localhost.localdomain [127.0.0.1])
	by zm-01.servicemagic.eu (Postfix) with ESMTP id 2F7A4813AFAF7
	for <submit@bugs.x2go.org>; Wed, 13 Dec 2017 19:29:08 +0100 (CET)
DKIM-Filter: OpenDKIM Filter v2.11.0 zm-01.servicemagic.eu 2F7A4813AFAF7
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=servicemagic.eu;
	s=frmailing; t=1513189748;
	bh=navoq1GkOWsNOMpiEIMIJbb/p8Bhe3Jj3Ra15ZLkix8=;
	h=Date:From:To:In-Reply-To:Subject:From;
	b=Pa0Y4yRHnu0pjnJMnYqZbC5V6/AhdtwpuqQk9LoB6mGLRMb0jYr8fpsFq1g9QQtgg
	 MEtEG5J3uHzUwEgPMfzCwkVpMX7+dDVdTojIppeFpeI0wHKt0OVSZNMGm2lozeKQbr
	 wIjakdwQkv1yOREW9NlGxIJzUt5Zo+ACtzOky/Ls=
X-Amavis-Modified: Mail body modified (using disclaimer) -
	zm-01.servicemagic.eu
X-Virus-Scanned: amavisd-new at servicemagic.eu
Received: from zm-01.servicemagic.eu ([127.0.0.1])
	by localhost (zm-01.servicemagic.eu [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id k0PTs8MQEZ3u for <submit@bugs.x2go.org>;
	Wed, 13 Dec 2017 19:29:07 +0100 (CET)
Received: from zm-01.servicemagic.eu (localhost.localdomain [127.0.0.1])
	by zm-01.servicemagic.eu (Postfix) with ESMTP id D042380AA75D1
	for <submit@bugs.x2go.org>; Wed, 13 Dec 2017 19:29:07 +0100 (CET)
Date: Wed, 13 Dec 2017 19:29:07 +0100 (CET)
From: Walid MOGHRABI <w.moghrabi@servicemagic.eu>
To: submit@bugs.x2go.org
Message-ID: <1883440267.36719898.1513189747788.JavaMail.root@servicemagic.eu>
In-Reply-To: <1612311080.36717200.1513188839607.JavaMail.root@servicemagic.eu>
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 7bit
X-Originating-IP: [10.33.100.47]
X-Mailer: Zimbra 7.2.0_GA_2669 (ZimbraWebClient - GC63 (Linux)/7.2.0_GA_2669)
package: x2gobroker
priority: bug

Context : I'm using PAM auth with the X2Gobroker which relies on Samba/Winbind to use ActiveDirectory based authentication.
It works pretty well but some users couldn't auth even though we triple checked their username/password combination.
It appears these users had some accentuated characters in their password so I suppose there is a charset issue there, not sure if the broker uses iso/latin encoding or UTF8.


Regards,
Walid Moghrabi

TRAVAUX.COM
BAT I - PARC CEZANNE 2 290 AVENUE GALILEE - CS 80403
13591 AIX EN PROVENCE CEDEX 3
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Jun 15 15:47:35 2021; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.