X2Go Bug report logs - #1132
Color issue with x2go not present in NX with certain applications

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: "Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc]" <brian.a.town@nasa.gov>

Date: Mon, 9 Jan 2017 14:30:01 UTC

Severity: normal

Found in version 4.0.5.2

Full log


Message #20 received at 1132@bugs.x2go.org (full text, mbox, reply):

Received: (at 1132) by bugs.x2go.org; 10 Jan 2017 14:34:50 +0000
From ulrich.sibiller@gmail.com  Tue Jan 10 15:34:49 2017
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: **
X-Spam-Status: No, score=2.5 required=3.0 tests=BAYES_50,DKIM_SIGNED,
	DKIM_VALID,DKIM_VALID_AU,FREEMAIL_FROM,FREEMAIL_REPLYTO,
	FREEMAIL_REPLYTO_END_DIGIT,RCVD_IN_SORBS_SPAM,URIBL_BLOCKED autolearn=no
	version=3.3.2
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 7E9AB3CC60
	for <1132@bugs.x2go.org>; Tue, 10 Jan 2017 15:34:49 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id 3W7omyozydii for <1132@bugs.x2go.org>;
	Tue, 10 Jan 2017 15:34:42 +0100 (CET)
Received: from mail-vk0-f44.google.com (mail-vk0-f44.google.com [209.85.213.44])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 711C93CC5F
	for <1132@bugs.x2go.org>; Tue, 10 Jan 2017 15:34:42 +0100 (CET)
Received: by mail-vk0-f44.google.com with SMTP id t8so27748056vke.3
        for <1132@bugs.x2go.org>; Tue, 10 Jan 2017 06:34:42 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20161025;
        h=mime-version:reply-to:in-reply-to:references:from:date:message-id
         :subject:to:content-transfer-encoding;
        bh=N2u9vnb5F4hBdFov1fmZ1BP/rr1UPrg8Uv/2BPZDST8=;
        b=euTqyYw9p5yCUwSu6XAUrcANgSHpDGRTVx/I8SMwpvbV9P8/HLRneTn2tGug08zzKq
         hMsVHduAYTSu7Z0CuBXAEeHJeFObGVPfUcLl1CJdrBZn/jaaAIn75j+gjDvgOirL8pmX
         IHTMGa7R8E+jJm9OXfoHq1VrvcA5MC9632QlwwsLY8rnBVJr7vtWvewxGO5+kBrJx5kq
         L/NNtd/xQii/J2oUx62+SnMaaLRbyobEKmuRTgIgLw5iVNDTv/AxuHLtUUGaPbw8TnW9
         4AH4b7CJoEkQTdHhycc+elsEyOFwECsQVZdup16rg8jLrC/xEK5SUK1OcO+WCtl86k29
         M+Tw==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20161025;
        h=x-gm-message-state:mime-version:reply-to:in-reply-to:references
         :from:date:message-id:subject:to:content-transfer-encoding;
        bh=N2u9vnb5F4hBdFov1fmZ1BP/rr1UPrg8Uv/2BPZDST8=;
        b=nqQNyjEh0cHb0RQ6NX8e6fmUIYxxoXnta9mvj+iCCVQoCCdRg9EwnHkAVdYTCDRqeF
         BY6dVcc+v7EpK0P4NOX++x86oWZfkwgL62ClIpBomKmghG3FSc6l3cQ0OiNYh9o2dudo
         m0JmSoiSg7Z5UHe8I05XgiJdFFvLRAirCZIFdvrnNgq8KU3/uTXGOrVVqilhVnXP3U1J
         zo/a+qEkKQfH+ht0nldot2sVuBsCZpgsXDSZrUCw2lw50+xPibM9mhP4AASxZA7X/38z
         lbH1qreGn8azSYPwVdAGFeYRkN5Fwxw0jAHZO0CZpe2MqCcXBaF9WBXpOP7VEDoAQMIP
         XT1A==
X-Gm-Message-State: AIkVDXIqKLUhhctxCrzQzQ5o8b0EvTcCrJm54dwlgDKS6EFazldjbGF32RoID7sbc/6IEM7mZyq3a1OOPStqFA==
X-Received: by 10.31.12.84 with SMTP id 81mr1321018vkm.113.1484058881278; Tue,
 10 Jan 2017 06:34:41 -0800 (PST)
MIME-Version: 1.0
Received: by 10.103.48.21 with HTTP; Tue, 10 Jan 2017 06:34:20 -0800 (PST)
Reply-To: uli42@gmx.de
In-Reply-To: <2565EDE93CACC9478E32CA6681CC015E0AB82811@NDMSMBX301.ndc.nasa.gov>
References: <2565EDE93CACC9478E32CA6681CC015E0AB82718@NDMSMBX301.ndc.nasa.gov>
 <00aced92-99b4-ce71-b6ff-25ed36e89bba@baur-itcs.de> <2565EDE93CACC9478E32CA6681CC015E0AB82811@NDMSMBX301.ndc.nasa.gov>
From: Ulrich Sibiller <ulrich.sibiller@gmail.com>
Date: Tue, 10 Jan 2017 15:34:20 +0100
Message-ID: <CANVnVYLU0PdS0FS72vFt1Aa2m8zmARinnTN7xX4Zx89ff=BtiQ@mail.gmail.com>
Subject: Re: [X2Go-Dev] Bug#1132: Bug#1132: Color issue with x2go not present
 in NX with certain applications
To: "Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc]" <brian.a.town@nasa.gov>, 1132@bugs.x2go.org
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable
On Mon, Jan 9, 2017 at 5:58 PM, Town, Brian A. (GSFC-428.0)[Embedded
Flight Systems, Inc] <brian.a.town@nasa.gov> wrote:
> Darn was hoping to have won the prize! Haha
>
> I have tested a few different compression/slider options but still going through and see what each option gives me in. The software being used is open source for NASA missions I believe but closed outside of that, so not sure what all I can share on that just yet, I'll have to check.
>
> I did notice that selecting the "local desktop" option via the client on x2go provides me with the correct color, however it also produces a great deal of lag. Is the local desktop option doing basic VNC connection or Xforwarding? I couldn't find any information on that.
>
> I'm utilizing x2go in conjunction with a LTSP set up. If I use basic Xforwarding through the terminal I get the colors I need displayed properly. I'm not sure exactly where it's hanging up through the x2go client window.
>
> For the unix_kde_depth option, is there a setting to have it exceed 24? Some blogs I've noticed people their session.log files showing unix_kde_depth32 however mine is always at 24 and unsure where that setting would be located at.


Color issues might have to do with the rgb file not being found (or
being incomplete). IIRC we have fixed something in the coming 3.6.x
release in this regard. Please test if the problem persists with
current nx beta,
http://wiki.x2go.org/doku.php/doc:howto:nx-libs-betatesting.

You could also check if one of these rgb files exist (add .txt
extension). They are searched in this order:

static char* nxAltRgbPaths[] = {"/etc/x2go/rgb", \
                                "/usr/share/x2go/rgb", \
                                "/usr/local/share/x2go/rgb", \
                                "/etc/nxagent/rgb", \
                                "/usr/share/nx/rgb", \
                                "/usr/local/share/nx/rgb", \
                                "/usr/NX/share/rgb", \
                                "/usr/share/X11/rgb", \
                                "/etc/X11/rgb"};


So if you find one compare it to the one you real X server is using
(should be visible in /var/log/Xorg.0.log).

Or maybe, instead of checking all this: simply copy the rgb.txt from
your X server to /etc/x2go/rgb.txt and retry.


Uli


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu May 30 22:19:03 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.