X2Go Bug report logs - #1082
vcxsrv.exe has stopped working

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: "Olivier Delrieu" <olivier.delrieu@c4xdiscovery.com>

Date: Thu, 1 Sep 2016 09:10:02 UTC

Severity: normal

Found in version

Full log

Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 1 Sep 2016 09:05:36 +0000
From olivier.delrieu@c4xdiscovery.com  Thu Sep  1 11:05:35 2016
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
X-Spam-Level: *
X-Spam-Status: No, score=1.8 required=3.0 tests=BAYES_50,DKIM_SIGNED,
Received: from localhost (localhost [])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 946B65DEFC
	for <submit@bugs.x2go.org>; Thu,  1 Sep 2016 11:05:35 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([])
	by localhost (ymir.das-netzwerkteam.de []) (amavisd-new, port 10024)
	with ESMTP id uTyLXHQW6khi for <submit@bugs.x2go.org>;
	Thu,  1 Sep 2016 11:05:28 +0200 (CEST)
Received: from mail-wm0-f43.google.com (mail-wm0-f43.google.com [])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id E74715DA97
	for <submit@bugs.x2go.org>; Thu,  1 Sep 2016 11:05:27 +0200 (CEST)
Received: by mail-wm0-f43.google.com with SMTP id c133so67321794wmd.1
        for <submit@bugs.x2go.org>; Thu, 01 Sep 2016 02:05:27 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=c4xdiscovery-com.20150623.gappssmtp.com; s=20150623;
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20130820;
X-Gm-Message-State: AE9vXwPe4wwNe71dA3bB63SHIYrfC/U6kcdnqLQQ6GHQssmE1RiIrfnJaUYDgrP4huRqcw6rCprr2ttDa9ecRtic9xGSttj4DHu8Hrnn6rB51kzhspzHKminE7Y+1Gw=
X-Received: by with SMTP id f190mr26278919wmd.30.1472720726155;
        Thu, 01 Sep 2016 02:05:26 -0700 (PDT)
Received: from Cinsault ([2a01:e34:ef91:9ca0:b513:1f97:1931:f6cf])
        by smtp.gmail.com with ESMTPSA id d64sm13229221wmc.22.2016.
        for <submit@bugs.x2go.org>
        (version=TLS1 cipher=ECDHE-RSA-AES128-SHA bits=128/128);
        Thu, 01 Sep 2016 02:05:24 -0700 (PDT)
From: "Olivier Delrieu" <olivier.delrieu@c4xdiscovery.com>
To: <submit@bugs.x2go.org>
Subject: vcxsrv.exe has stopped working
Date: Thu, 1 Sep 2016 11:05:21 +0200
Message-ID: <001101d2042f$f873d340$e95b79c0$@c4xdiscovery.com>
MIME-Version: 1.0
X-Mailer: Microsoft Outlook 14.0
Thread-Index: AdIELXpjqWQg7kHeT1mkoP/+lBpRyw==
Content-Type: multipart/mixed;
Content-Language: en-gb
[Message part 1 (text/plain, inline)]
Package: x2goclient

Everytime I start a session, it fails after a couple of seconds and this
error appear "vcxsrv.exe has stopped working". I cannot use the x2go client
anymore. This is a severe blocker for me.

I have been using x2go client for a while. I've upgraded to the
latest It worked well initially. Then I changed the
display settings to "use whole display" (I now have 2 screens.) which
triggered this error and I can't get rid of it !

I've tried several things unsuccessfully :
- changing back display settings
- uninstalling (including deleting user folder .x2go and deleting registry
key) and downgrading to

When launching vcxsrv.exe in debug mode ("vcxsrv.exe -logverbose 3") it
works and I gives the attached log.

I'm running x2goclient on win7 64bits pro. The remote machine is on my LAN,
it's a linux box running latest CentOS 7 and XFCE.

Please advise.




Confidentiality Notice: 
This email and any attachments may be confidential and protected by legal 
privilege. If you are not the intended recipient, be aware that any 
disclosure, copying, distribution or use of the e-mail or any attachment is 
prohibited. If you have received this email in error, please notify us 
immediately by replying to the sender and then delete this copy and the 
reply from your system. Thank you for your cooperation.

C4X Discovery Ltd Registered Office: Manchester One, 53 Portland Street, 
Manchester M1 3LD, UK.
[VCXSrv.0.log (application/octet-stream, attachment)]

Send a report that this bug log contains spam.

X2Go Developers <owner@bugs.x2go.org>. Last modified: Mon Apr 15 12:57:29 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.