X2Go Bug report logs - #971
Unable to restore session with AD login

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Dario Pilori <dario.pilori@polito.it>

Date: Fri, 4 Dec 2015 15:40:01 UTC

Severity: normal

Found in version 4.0.1.19

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 4 Dec 2015 15:38:06 +0000
From dario.pilori@polito.it  Fri Dec  4 16:38:04 2015
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.8 required=5.0 tests=BAYES_50 autolearn=ham
	version=3.3.2
X-Greylist: delayed 1621 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Fri, 04 Dec 2015 16:38:04 CET
Received: from fm1nodo5.polito.it (fm1nodo5.polito.it [130.192.180.13])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 703CE3C4D3
	for <submit@bugs.x2go.org>; Fri,  4 Dec 2015 16:38:04 +0100 (CET)
Received: from polito.it (frontmail1.polito.it [130.192.180.41])
	by fm1nodo5.polito.it  with ESMTP id tB4FB298018831-tB4FB29A018831
	(version=TLSv1.0 cipher=AES128-SHA bits=128 verify=CAFAIL)
	for <submit@bugs.x2go.org>; Fri, 4 Dec 2015 16:11:02 +0100
X-ExtScanner: Niversoft's FindAttachments (free)
Received: from [192.168.10.134] (account d039498@polito.it [192.168.10.134] verified)
  by polito.it (CommuniGate Pro SMTP 6.1.5)
  with ESMTPSA id 99655334 for submit@bugs.x2go.org; Fri, 04 Dec 2015 16:11:02 +0100
To: submit@bugs.x2go.org
From: Dario Pilori <dario.pilori@polito.it>
Subject: Unable to restore session with AD login
Message-ID: <5661AD06.7050905@polito.it>
Date: Fri, 4 Dec 2015 16:11:02 +0100
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101
 Thunderbird/38.4.0
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 7bit
X-FEAS-SYSTEM-WL: 130.192.180.41
Package: x2goserver
Version: 4.0.1.19

Hello

We are using x2goserver on a Ubuntu 14.04 server, which is member of an 
AD domain. Users have usernames like "DOMAIN\user". After closing bug 
#664, users can successfully connect to x2goserver, but they cannot 
resume a suspended session. Every time the same user connects, x2go 
opens a new session.

Logging in as a regular user via SSH, typing x2golistsessions does not 
return any output, even if the user has several sessions open. If root 
runs x2golistsessions_root, it displays all sessions, but in the 
username field of the table it is displayed the user as "DOMAINuser", 
without the backslash \.

Using PostgreSQL database as a backend instead of SQLite3 fixes the problem.

Best regards,
Dario


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Jan 31 15:49:14 2023; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.