X2Go Bug report logs - #965
Xlib: extension "MIT-SCREEN-SAVER" missing on display [Debian Jessie/KDE4]

version graph

Package: x2goagent; Maintainer for x2goagent is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goagent is src:nx-libs.

Reported by: James T Brown <brownja@msu.edu>

Date: Wed, 18 Nov 2015 22:20:01 UTC

Severity: normal

Found in version 2:3.5.0.32-0x2go1+git20150704.734+jessie.main.1

Forwarded to https://github.com/ArcticaProject/nx-libs/issues/80

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 18 Nov 2015 22:17:15 +0000
From brownja@msu.edu  Wed Nov 18 23:17:13 2015
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.8 required=5.0 tests=BAYES_50,T_DKIM_INVALID,
	URIBL_BLOCKED autolearn=ham version=3.3.2
X-Greylist: delayed 3109 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Wed, 18 Nov 2015 23:17:13 CET
Received: from sys18.mail.msu.edu (sys18.mail.msu.edu [35.9.75.118])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 894D95DA51
	for <submit@bugs.x2go.org>; Wed, 18 Nov 2015 23:17:13 +0100 (CET)
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=msu.edu; s=mail;
	h=Content-Transfer-Encoding:Content-Type:Subject:To:MIME-Version:From:Date:Message-ID; bh=cdDCzJp9fD4W58QubBZYZaCF4pRPsEBCtEm2lg0VnUk=;
	b=aLCBcTt5/Hrs7LXufu1vrgp/f3ASTmJFbSsEDzIS5sK0aC21G044xO4NaAMgHWgGUc2xGolYK+MCKkOSvJDofYHOfz2v1fbQBfP405t71BqbOmxehfO7VD4RI5c/FVaguE/jR2CRuuyC8bsMgUvOXFULL5Bk9GsFaVsobuB/bpg=;
Received: from lyons.geo.msu.edu ([35.8.15.31]) Authenticated ID: brownja
 	by sys18.mail.msu.edu with esmtpsa (Exim 4.82 #3)
	(TLSv1.2:DHE-RSA-AES128-SHA:128)
	id 1ZzAEF-0007QF-Eu
	for submit@bugs.x2go.org; Wed, 18 Nov 2015 16:25:23 -0500
Message-ID: <564CECC3.3080006@msu.edu>
Date: Wed, 18 Nov 2015 16:25:23 -0500
From: James T Brown <brownja@msu.edu>
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Icedove/31.8.0
MIME-Version: 1.0
To: submit@bugs.x2go.org
Subject: Xlib: extension "MIT-SCREEN-SAVER" missing on display [Debian Jessie/KDE4]
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 7bit
X-Virus: None found by Clam AV
Package: x2goagent
Version: 2:3.5.0.32-0x2go1+git20150704.734+jessie.main.1

Operating System: Debian Jessie 8.2
Kernel: #1 SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09)
Desktop Environment: KDE4

The KDE Screen Locker does not launch automatically
when my session is controlled by x2goagent.  I am able
to lock the screen manually using "Lock" within the
KDE Menu and I can also lock the screen manually with
the use of either of the following commands:

/usr/lib/kde4/libexec/kscreenlocker_greet --immediateLock
/usr/bin/qbdus org.freedesktop.ScreenSaver /ScreenSaver Lock

However, if the screen lock is set to activate automatically,
it never does.  For example, if the KDE Screen Locker is
set to "Start Automatically After 1 minute", the screen lock
never activates even after the screen stays completely idle
for several minutes.

If I login to a KDE session directly on the system console,
the screen lock will activate after one minute.  If I login
to a KDE session using "xrdp", the screen lock will activate
after one minute.  If I login to a KDE session using X2GO,
screen lock never activates.

Within the ~/.xsession-x2go-errors file, several of the
following messages are logged:

Xlib:  extension "MIT-SCREEN-SAVER" missing on display ":50".

Someone from a KDE Forum suggests that the missing "MIT-SCREEN-SAVER"
extension would cause the issue of not having the screen lock
automatically.

Maybe I am missing a package or system library?  Is there a
modification that I can apply to the "/etc/x2go/x2goagent.options"
file that will correct the missing "MIT-SCREEN-SAVER" extension
issue?  Is there some other way that I can correct this problem
without having to try to build/compile from source?

There has been reference to similar problems in the past, but I have
not been able to locate a proper fix:

http://lists.x2go.org/pipermail/x2go-dev/2010-June/000579.html

I am able to duplicate this on two separate X2GO Servers (running
on Debian Jessie).  I know there has to be other Debian/X2GO/KDE4
users - do they not have this problem as well?

NOTE: I am able to set automatic screen lock if I switch to xscreensaver,
but if this is an bug with X2GO and KDE4, I am hoping that there is
a fix.  If needed, I can file a bug report with the KDE developers.
I am looking here first since this issue has only occurred within
my X2GO sessions.

Any help would be most appreciated.

Thank you.

Jim Brown


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sat Dec 14 15:08:08 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.