X2Go Bug report logs - #955
x2gosid sanitizer check in x2gosqlitewrapper.pl / x2goserver-4.0.1.19-1.1.x86_64 rpm for opensuse 13.2

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Frank Knoben <admin@igpm.rwth-aachen.de>

Date: Wed, 7 Oct 2015 08:20:02 UTC

Severity: normal

Found in version 4.0.1.19-1.1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#955; Package x2goserver. (Wed, 07 Oct 2015 08:20:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Frank Knoben <admin@igpm.rwth-aachen.de>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 07 Oct 2015 08:20:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Frank Knoben <admin@igpm.rwth-aachen.de>
To: submit@bugs.x2go.org
Subject: x2gosid sanitizer check in x2gosqlitewrapper.pl / x2goserver-4.0.1.19-1.1.x86_64 rpm for opensuse 13.2
Date: Wed, 7 Oct 2015 10:17:07 +0200
Package: x2goserver
Version: 4.0.1.19-1.1

File: x2gosqlitewrapper.pl

Subroutine: sanitizer

Operating System: openSuSE 13.2 64bit

Hello,

on my system, there are a lot of users, whose username consists of only 
numbers.

In the latest x2goserver rpm for my opensuse 13.2 system 
(x2goserver-4.0.1.19-1.1.x86_64)
there seem's to be something wrong with the sanitzer check function in 
x2gosqlitewrapper.pl.
For the users, whose username contains only numbers, I get the error 
message of a malformed session id.
When I don't do a sanitzer check on the x2gosid, everything is fine.
Unfortunately, I have not learned the perl programming language and I'm 
not so good with regular expression,
that I do know how to fix the problem correctly.
For me, I just put a

return $string;

after the

elsif ($type eq "x2gosid") {

and everything works fine for me again.

Sincerly

Frank Knoben



Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Dec 12 17:04:24 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.