X2Go Bug report logs - #898
Weird colors and image issues on ppc64le Ubuntu 14.04

version graph

Package: nx-libs; Maintainer for nx-libs is X2Go Developers <x2go-dev@lists.x2go.org>;

Reported by: Mihai Moldovan <ionic@ionic.de>

Date: Tue, 30 Jun 2015 15:00:01 UTC

Severity: normal

Found in version 3.5.0.29

Done: Juri Grabowski <x2go@jugra.de>

Bug is archived. No further changes may be made.

Forwarded to https://github.com/ArcticaProject/nx-libs/issues/83

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 30 Jun 2015 14:59:52 +0000
From ionic@ionic.de  Tue Jun 30 16:59:50 2015
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.8 required=5.0 tests=BAYES_50,T_DKIM_INVALID,
	URIBL_BLOCKED autolearn=ham version=3.3.2
Received: from Root24.de (powered.by.root24.eu [5.135.3.88])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id A494F5DA85
	for <submit@bugs.x2go.org>; Tue, 30 Jun 2015 16:59:50 +0200 (CEST)
Received: from nopileos.local (home.ionic.de [217.92.117.31])
	by mail.ionic.de (Postfix) with ESMTPSA id 0FBA04F0503C
	for <submit@bugs.x2go.org>; Tue, 30 Jun 2015 16:59:50 +0200 (CEST)
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=ionic.de; s=default;
	t=1435676390; bh=a866ZgKOY0wAzIsI8M0fP3cPWKU8hOBt/+PKKCwDLkY=;
	h=To:From:Subject:Date:From;
	b=R1H1LdEdkDdTOD5B/LQ+by5oyP/3XVAldAlLKJs29siZcw42/GvavZVXiepwMoVAb
	 c/NbNePcleEpT+xsUSoVFfCZ7oQtNXvT/ZASqQvGXeDYcGKNwvH/b3RqbnCSx8BB9k
	 5BoC9vICdUvhHn21ROJKSOjXplT/9XqqPIOx8/fY=
To: submit@bugs.x2go.org
From: Mihai Moldovan <ionic@ionic.de>
X-Enigmail-Draft-Status: N1110
Subject: Weird colors and image issues on ppc64le Ubuntu 14.04
Message-ID: <5592AEDA.7010903@ionic.de>
Date: Tue, 30 Jun 2015 16:59:38 +0200
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:38.0)
 Gecko/20100101 Thunderbird/38.0.1
MIME-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha512;
 protocol="application/pgp-signature";
 boundary="ggiDBpNaGD9DeAWbbBDcjHjTS5tt6kI84"
[Message part 1 (text/plain, inline)]
Package: nx-libs
Version: 3.5.0.29

After building and installing X2Go packages on Ubuntu 12.04 ppc64le some months
ago, I experienced the following strange behavior(s):

  - image colors were distorted sometimes (but sometimes not) - instead of
    brown, pink was shown
  - images (PNG? SVG?) didn't load or show correctly. Colors were way off (see
    above) and mostly only contours drawn, if even that.
  - scrolling in a scrollview (e.g., XFCE's settings manager(?)) sometimes
    forced a correct redraw of images, but mostly only partitially
  - hovering over an image broke it visually again
  - mouse cursor either disappeared completely or was replaced with a block
    (what seemed to be random data converted to an image)


I have not done any debugging on these issues yet.



Mihai

[signature.asc (application/pgp-signature, attachment)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sat Jul 20 16:48:13 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.