X2Go Bug report logs - #656
Fwd: Windows X2GoClient hangs when launching x2gostartagent

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Kyle Cottongim <cottonke@gmail.com>

Date: Sat, 25 Oct 2014 22:05:02 UTC

Severity: normal

Tags: moreinfo

Found in version 4.0.3.0

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#656; Package x2goclient. (Sat, 25 Oct 2014 22:05:02 GMT) (full text, mbox, link).


Acknowledgement sent to Kyle Cottongim <cottonke@gmail.com>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sat, 25 Oct 2014 22:05:02 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

From: Kyle Cottongim <cottonke@gmail.com>
To: submit@bugs.x2go.org
Subject: Fwd: Windows X2GoClient hangs when launching x2gostartagent
Date: Sat, 25 Oct 2014 17:04:16 -0500
[Message part 1 (text/plain, inline)]
Package: X2GoClient
Version: 4.0.3.0

When launching a session from within the X2GoClient, the process will hang
after the following call:

x2go-DEBUG-onmainwindow.cpp:3900> Executing remote command: "x2gostartagent
1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME both"

This does not happen all the time, but generally happens after loss of
network connection or after logging out instead of just closing the
X2GoClient window. A complete restart of the client machine will solve the
issue.


Client Information:
Windows 7 SP 1
X2GoClient v4.0.3.0

Server Information:
$ uname -a
Linux oddjob 3.11.0-26-generic #45~precise1-Ubuntu SMP Tue Jul 15 04:02:35
UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ x2goversion
x2goagent: 3.5.0.27
x2goserver: 4.0.1.18
x2goserver-extensions: 4.0.1.16
x2goserver-xsession: 4.0.1.16

Debug Output:
x2go-INFO-1> "Starting x2goclient..."
x2go-WARNING-1> "Can't load translator: :/x2goclient_en_us"
x2go-WARNING-2> "Can't load translator: :/qt_en_US"
x2go-DEBUG-onmainwindow.cpp:9746> Getting Xorg settings.
x2go-INFO-3> "Started  x2goclient."
x2go-DEBUG-onmainwindow.cpp:490> "$HOME=C:/Users/kecotton"
x2go-DEBUG-onmainwindow.cpp:2104> Reading 2 sessions from config file.
x2go-DEBUG-onmainwindow.cpp:9488> Starting win servers...
x2go-DEBUG-onmainwindow.cpp:9824> "C:/Users/kecotton/.x2go/etc/sshd_config
created."
x2go-DExBU2G-goon-maDEBinUGwi-ndoown.cppma:9inwi25ndo7>w go.ct pploc:9257>
gotal lohocalhost
st
x2gx2go-DEBUG-onmainwindow.cpp:9279> Port is free: 6000
ox2go-DEBUG-onmainwindow.cpp:9345> using internal X: false
-x2go-DEBUG-onmainwindow.cpp:9410> Running "C:/Program Files
(x86)/x2goclient/VcXsrv/vcxsrv.exe" "-keyhook -multiwindow -notrayicon
-clipboard :0"
DEBUG-onmainwindow.cpp:9279> Port is free: 7022
x2go-DEBUG-onmainwindow.cpp:9880> Creating desktop: x2go_kecotton
x2go-DEBUG-onmainwindow.cpp:9257> got localhost
x2go-DEBUG-onmainwindow.cpp:9285> Port already used: 6000
x2go-DEBUG-onmainwindow.cpp:9439> X is started.
x2go-DEBUG-onmainwindow.cpp:9790> All winservers are started.
x2go-DEBUG-onmainwindow.cpp:2104> Reading 2 sessions from config file.
Object::connect: No such slot SessionWidget::slot_emitSettings()
Object::connect: No such slot SessionWidget::slot_emitSettings()
Object::connect: No such signal SessionWidget::directRDP(bool)
Object::connect: No such signal
SessionWidget::settingsChanged(QString,QString,QString)
x2go-INFO-8> "Starting connection to server: oddjob:22"
x2go-DEBUG-onmainwindow.cpp:2683> Start new ssh connection to
server:"oddjob":"22" krbLogin: false
x2go-DEBUG-onmainwindow.cpp:2778> SSH connection established.
x2go-DEBUG-onmainwindow.cpp:3038> Continue normal x2go session
x2go-DEBUG-onmainwindow.cpp:3382> ""
x2go-DEBUG-onmainwindow.cpp:3769> Fullscreen: false
x2go-DEBUG-onmainwindow.cpp:3900> Executing remote command: "x2gostartagent
1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME both"


Kyle
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#656; Package x2goclient. (Wed, 29 Oct 2014 09:40:02 GMT) (full text, mbox, link).


Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 29 Oct 2014 09:40:02 GMT) (full text, mbox, link).


Message #10 received at 656@bugs.x2go.org (full text, mbox, reply):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Kyle Cottongim <cottonke@gmail.com>, 656@bugs.x2go.org, submit@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#656: Fwd: Windows X2GoClient hangs when launching x2gostartagent
Date: Wed, 29 Oct 2014 09:39:32 +0000
[Message part 1 (text/plain, inline)]
Hi Kyle,

On  So 26 Okt 2014 00:04:16 CEST, Kyle Cottongim wrote:

> Package: X2GoClient
> Version: 4.0.3.0
>
> When launching a session from within the X2GoClient, the process will hang
> after the following call:
>
> x2go-DEBUG-onmainwindow.cpp:3900> Executing remote command: "x2gostartagent
> 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME both"
>
> This does not happen all the time, but generally happens after loss of
> network connection or after logging out instead of just closing the
> X2GoClient window. A complete restart of the client machine will solve the
> issue.

Could you cross-check the debug output of X2Go Server, possibly add  
some more log message to /usr/bin/x2gostartagent, so that we can  
narrow down, where the "hang" actually occurs?

Does x2gostartagent get executed at all, or is X2Go Client aready  
stalling before executing that command.

Or is x2gostartagent hanging somewhere on the way? (Extra log messages  
placed in x2gostartagent will be helpful then).

Regards,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb
[Message part 2 (application/pgp-signature, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#656; Package x2goclient. (Wed, 29 Oct 2014 10:25:02 GMT) (full text, mbox, link).


Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 29 Oct 2014 10:25:02 GMT) (full text, mbox, link).


Message #15 received at 656@bugs.x2go.org (full text, mbox, reply):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: 656@bugs.x2go.org, Kyle Cottongim <cottonke@gmail.com>
Subject: Re: [X2Go-Dev] Bug#656: Bug#656: Fwd: Windows X2GoClient hangs when launching x2gostartagent
Date: Wed, 29 Oct 2014 10:20:38 +0000
[Message part 1 (text/plain, inline)]
Control: reassign -1 x2goclient
Control: found -1 4.0.3.0

On  Mi 29 Okt 2014 10:39:32 CET, Mike Gabriel wrote:

> Hi Kyle,
>
> On  So 26 Okt 2014 00:04:16 CEST, Kyle Cottongim wrote:
>
>> Package: X2GoClient
>> Version: 4.0.3.0
>>
>> When launching a session from within the X2GoClient, the process will hang
>> after the following call:
>>
>> x2go-DEBUG-onmainwindow.cpp:3900> Executing remote command: "x2gostartagent
>> 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME both"
>>
>> This does not happen all the time, but generally happens after loss of
>> network connection or after logging out instead of just closing the
>> X2GoClient window. A complete restart of the client machine will solve the
>> issue.
>
> Could you cross-check the debug output of X2Go Server, possibly add  
> some more log message to /usr/bin/x2gostartagent, so that we can  
> narrow down, where the "hang" actually occurs?
>
> Does x2gostartagent get executed at all, or is X2Go Client aready  
> stalling before executing that command.
>
> Or is x2gostartagent hanging somewhere on the way? (Extra log  
> messages placed in x2gostartagent will be helpful then).
>
> Regards,
> Mike

Reassging this bug to package "x2goclient" (not X2GoClient).

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb
[Message part 2 (application/pgp-signature, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#656; Package x2goclient. (Wed, 29 Oct 2014 13:35:02 GMT) (full text, mbox, link).


Acknowledgement sent to Kyle Cottongim <cottonke@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 29 Oct 2014 13:35:02 GMT) (full text, mbox, link).


Message #20 received at 656@bugs.x2go.org (full text, mbox, reply):

From: Kyle Cottongim <cottonke@gmail.com>
To: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Cc: 656@bugs.x2go.org, submit@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#656: Fwd: Windows X2GoClient hangs when launching x2gostartagent
Date: Wed, 29 Oct 2014 08:30:54 -0500
[Message part 1 (text/plain, inline)]
Hello Mike,

On Wed, Oct 29, 2014 at 4:39 AM, Mike Gabriel <
mike.gabriel@das-netzwerkteam.de> wrote:

> Hi Kyle,
>
> On  So 26 Okt 2014 00:04:16 CEST, Kyle Cottongim wrote:
>
>  Package: X2GoClient
>> Version: 4.0.3.0
>>
>> When launching a session from within the X2GoClient, the process will hang
>> after the following call:
>>
>> x2go-DEBUG-onmainwindow.cpp:3900> Executing remote command:
>> "x2gostartagent
>> 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME both"
>>
>> This does not happen all the time, but generally happens after loss of
>> network connection or after logging out instead of just closing the
>> X2GoClient window. A complete restart of the client machine will solve the
>> issue.
>>
>
> Could you cross-check the debug output of X2Go Server, possibly add some
> more log message to /usr/bin/x2gostartagent, so that we can narrow down,
> where the "hang" actually occurs?
>
> Does x2gostartagent get executed at all, or is X2Go Client aready stalling
> before executing that command.
>
> Or is x2gostartagent hanging somewhere on the way? (Extra log messages
> placed in x2gostartagent will be helpful then).
>
> Regards,
> Mike


​During this launch attempt, it seems the client is getting a bit further
along than before, but still not to the point of launching something​. Here
is how far things are getting now:

x2go-DEBUG-onmainwindow.cpp:2778> SSH connection established.
x2go-DEBUG-onmainwindow.cpp:3038> Continue normal x2go session
x2go-DEBUG-onmainwindow.cpp:3382> ""
x2go-DEBUG-onmainwindow.cpp:3769> Fullscreen: false
x2go-DEBUG-onmainwindow.cpp:9257> got localhost
x2go-DEBUG-onmainwindow.cpp:9279> Port is free: 6000
x2go-DEBUG-onmainwindow.cpp:9345> using internal X: true
x2go-DEBUG-onmainwindow.cpp:9368> WxH:"1440"x"900"
x2go-DEBUG-onmainwindow.cpp:9373> "-multiwindow -notrayicon -clipboard"
x2go-DEBUG-onmainwindow.cpp:9410> Running "C:/Program Files
(x86)/x2goclient\vcxsrv\vcxsrv.exe" "-multiwindow -notrayicon -clipboard :0"
x2go-DEBUG-onmainwindow.cpp:3900> Executing remote command: "x2gostartagent
1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME both"
x2go-DEBUG-onmainwindow.cpp:9257> got localhost
x2go-DEBUG-onmainwindow.cpp:9285> Port already used: 6000
x2go-DEBUG-onmainwindow.cpp:9439> X is started.
x2go-DEBUG-onmainwindow.cpp:9790> All winservers are started.

With some debug within the x2gostartagent I can tell that it is executing
this script and now seems to be getting past this point. I have turned the
logging level of the server to debug and here is the output I am seeing
during a connection attempt:

Oct 29 08:02:33 oddjob /usr/bin/x2golistsessions[12799]: x2golistsessions
has been called with no option
Oct 29 08:02:34 oddjob /usr/bin/x2gostartagent: x2gostartagent called with
options: 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME
both
Oct 29 08:02:34 oddjob /usr/bin/x2gostartagent: client announced itself as
,,131.199.103.76''
Oct 29 08:02:34 oddjob /usr/bin/x2gosessionlimit[12835]: x2gosessionlimit
has been called
Oct 29 08:02:34 oddjob /usr/bin/x2golistsessions[12838]: x2golistsessions
has been called with options: --all-servers

I added some more debug messages to x2golistsessions and am seeing that
this script seems to finish execution (I reach deubg statements just before
closing syslog).

Another note is that even after restart of the client and server PCs, this
is not working. Also, If I keep my client open for a long time after it
"hangs", it will sometimes eventually bring up the remote session. The time
it takes for it to do this is on the order of magnitude of many hours.

Thanks,
Kyle
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#656; Package x2goclient. (Wed, 29 Oct 2014 14:20:01 GMT) (full text, mbox, link).


Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 29 Oct 2014 14:20:02 GMT) (full text, mbox, link).


Message #25 received at 656@bugs.x2go.org (full text, mbox, reply):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Kyle Cottongim <cottonke@gmail.com>
Cc: 656@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#656: Fwd: Windows X2GoClient hangs when launching x2gostartagent
Date: Wed, 29 Oct 2014 14:17:06 +0000
[Message part 1 (text/plain, inline)]
Hi Kyle,

On  Mi 29 Okt 2014 14:30:54 CET, Kyle Cottongim wrote:

> Hello Mike,
>
> On Wed, Oct 29, 2014 at 4:39 AM, Mike Gabriel <
> mike.gabriel@das-netzwerkteam.de> wrote:
>
>> Hi Kyle,
>>
>> On  So 26 Okt 2014 00:04:16 CEST, Kyle Cottongim wrote:
>>
>>  Package: X2GoClient
>>> Version: 4.0.3.0
>>>
>>> When launching a session from within the X2GoClient, the process will hang
>>> after the following call:
>>>
>>> x2go-DEBUG-onmainwindow.cpp:3900> Executing remote command:
>>> "x2gostartagent
>>> 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME both"
>>>
>>> This does not happen all the time, but generally happens after loss of
>>> network connection or after logging out instead of just closing the
>>> X2GoClient window. A complete restart of the client machine will solve the
>>> issue.
>>>
>>
>> Could you cross-check the debug output of X2Go Server, possibly add some
>> more log message to /usr/bin/x2gostartagent, so that we can narrow down,
>> where the "hang" actually occurs?
>>
>> Does x2gostartagent get executed at all, or is X2Go Client aready stalling
>> before executing that command.
>>
>> Or is x2gostartagent hanging somewhere on the way? (Extra log messages
>> placed in x2gostartagent will be helpful then).
>>
>> Regards,
>> Mike
>
>
> ​During this launch attempt, it seems the client is getting a bit further
> along than before, but still not to the point of launching something​. Here
> is how far things are getting now:
>
> x2go-DEBUG-onmainwindow.cpp:2778> SSH connection established.
> x2go-DEBUG-onmainwindow.cpp:3038> Continue normal x2go session
> x2go-DEBUG-onmainwindow.cpp:3382> ""
> x2go-DEBUG-onmainwindow.cpp:3769> Fullscreen: false
> x2go-DEBUG-onmainwindow.cpp:9257> got localhost
> x2go-DEBUG-onmainwindow.cpp:9279> Port is free: 6000
> x2go-DEBUG-onmainwindow.cpp:9345> using internal X: true
> x2go-DEBUG-onmainwindow.cpp:9368> WxH:"1440"x"900"
> x2go-DEBUG-onmainwindow.cpp:9373> "-multiwindow -notrayicon -clipboard"
> x2go-DEBUG-onmainwindow.cpp:9410> Running "C:/Program Files
> (x86)/x2goclient\vcxsrv\vcxsrv.exe" "-multiwindow -notrayicon -clipboard :0"
> x2go-DEBUG-onmainwindow.cpp:3900> Executing remote command: "x2gostartagent
> 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME both"
> x2go-DEBUG-onmainwindow.cpp:9257> got localhost
> x2go-DEBUG-onmainwindow.cpp:9285> Port already used: 6000
> x2go-DEBUG-onmainwindow.cpp:9439> X is started.
> x2go-DEBUG-onmainwindow.cpp:9790> All winservers are started.
>
> With some debug within the x2gostartagent I can tell that it is executing
> this script and now seems to be getting past this point. I have turned the
> logging level of the server to debug and here is the output I am seeing
> during a connection attempt:
>
> Oct 29 08:02:33 oddjob /usr/bin/x2golistsessions[12799]: x2golistsessions
> has been called with no option
> Oct 29 08:02:34 oddjob /usr/bin/x2gostartagent: x2gostartagent called with
> options: 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME
> both
> Oct 29 08:02:34 oddjob /usr/bin/x2gostartagent: client announced itself as
> ,,131.199.103.76''
> Oct 29 08:02:34 oddjob /usr/bin/x2gosessionlimit[12835]: x2gosessionlimit
> has been called
> Oct 29 08:02:34 oddjob /usr/bin/x2golistsessions[12838]: x2golistsessions
> has been called with options: --all-servers
>
> I added some more debug messages to x2golistsessions and am seeing that
> this script seems to finish execution (I reach deubg statements just before
> closing syslog).
>
> Another note is that even after restart of the client and server PCs, this
> is not working. Also, If I keep my client open for a long time after it
> "hangs", it will sometimes eventually bring up the remote session. The time
> it takes for it to do this is on the order of magnitude of many hours.
>
> Thanks,
> Kyle

Can you provide the output of

  x2golistsessions --all-servers

while X2Go Client is trying to launch the session?

Make sure to obfuscate non-public data from listsession's output  
(username, host IPs, etc.).

Also, please tell me your X2Go Server version.

  $ x2goversion

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb
[Message part 2 (application/pgp-signature, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#656; Package x2goclient. (Wed, 29 Oct 2014 14:40:02 GMT) (full text, mbox, link).


Acknowledgement sent to Kyle Cottongim <cottonke@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 29 Oct 2014 14:40:02 GMT) (full text, mbox, link).


Message #30 received at 656@bugs.x2go.org (full text, mbox, reply):

From: Kyle Cottongim <cottonke@gmail.com>
To: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Cc: 656 <656@bugs.x2go.org>
Subject: Re: [X2Go-Dev] Bug#656: Fwd: Windows X2GoClient hangs when launching x2gostartagent
Date: Wed, 29 Oct 2014 09:36:41 -0500
[Message part 1 (text/plain, inline)]
Mike,

On Wed, Oct 29, 2014 at 9:17 AM, Mike Gabriel <
mike.gabriel@das-netzwerkteam.de> wrote:

> Hi Kyle,
>
>
> On  Mi 29 Okt 2014 14:30:54 CET, Kyle Cottongim wrote:
>
>  Hello Mike,
>>
>> On Wed, Oct 29, 2014 at 4:39 AM, Mike Gabriel <
>> mike.gabriel@das-netzwerkteam.de> wrote:
>>
>>  Hi Kyle,
>>>
>>> On  So 26 Okt 2014 00:04:16 CEST, Kyle Cottongim wrote:
>>>
>>>  Package: X2GoClient
>>>
>>>> Version: 4.0.3.0
>>>>
>>>> When launching a session from within the X2GoClient, the process will
>>>> hang
>>>> after the following call:
>>>>
>>>> x2go-DEBUG-onmainwindow.cpp:3900> Executing remote command:
>>>> "x2gostartagent
>>>> 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME both"
>>>>
>>>> This does not happen all the time, but generally happens after loss of
>>>> network connection or after logging out instead of just closing the
>>>> X2GoClient window. A complete restart of the client machine will solve
>>>> the
>>>> issue.
>>>>
>>>>
>>> Could you cross-check the debug output of X2Go Server, possibly add some
>>> more log message to /usr/bin/x2gostartagent, so that we can narrow down,
>>> where the "hang" actually occurs?
>>>
>>> Does x2gostartagent get executed at all, or is X2Go Client aready
>>> stalling
>>> before executing that command.
>>>
>>> Or is x2gostartagent hanging somewhere on the way? (Extra log messages
>>> placed in x2gostartagent will be helpful then).
>>>
>>> Regards,
>>> Mike
>>>
>>
>>
>> ​During this launch attempt, it seems the client is getting a bit further
>> along than before, but still not to the point of launching something​.
>> Here
>> is how far things are getting now:
>>
>> x2go-DEBUG-onmainwindow.cpp:2778> SSH connection established.
>> x2go-DEBUG-onmainwindow.cpp:3038> Continue normal x2go session
>> x2go-DEBUG-onmainwindow.cpp:3382> ""
>> x2go-DEBUG-onmainwindow.cpp:3769> Fullscreen: false
>> x2go-DEBUG-onmainwindow.cpp:9257> got localhost
>> x2go-DEBUG-onmainwindow.cpp:9279> Port is free: 6000
>> x2go-DEBUG-onmainwindow.cpp:9345> using internal X: true
>> x2go-DEBUG-onmainwindow.cpp:9368> WxH:"1440"x"900"
>> x2go-DEBUG-onmainwindow.cpp:9373> "-multiwindow -notrayicon -clipboard"
>> x2go-DEBUG-onmainwindow.cpp:9410> Running "C:/Program Files
>> (x86)/x2goclient\vcxsrv\vcxsrv.exe" "-multiwindow -notrayicon -clipboard
>> :0"
>> x2go-DEBUG-onmainwindow.cpp:3900> Executing remote command:
>> "x2gostartagent
>> 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME both"
>> x2go-DEBUG-onmainwindow.cpp:9257> got localhost
>> x2go-DEBUG-onmainwindow.cpp:9285> Port already used: 6000
>> x2go-DEBUG-onmainwindow.cpp:9439> X is started.
>> x2go-DEBUG-onmainwindow.cpp:9790> All winservers are started.
>>
>> With some debug within the x2gostartagent I can tell that it is executing
>> this script and now seems to be getting past this point. I have turned the
>> logging level of the server to debug and here is the output I am seeing
>> during a connection attempt:
>>
>> Oct 29 08:02:33 oddjob /usr/bin/x2golistsessions[12799]: x2golistsessions
>> has been called with no option
>> Oct 29 08:02:34 oddjob /usr/bin/x2gostartagent: x2gostartagent called with
>> options: 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME
>> both
>> Oct 29 08:02:34 oddjob /usr/bin/x2gostartagent: client announced itself as
>> ,,131.199.103.76''
>> Oct 29 08:02:34 oddjob /usr/bin/x2gosessionlimit[12835]: x2gosessionlimit
>> has been called
>> Oct 29 08:02:34 oddjob /usr/bin/x2golistsessions[12838]: x2golistsessions
>> has been called with options: --all-servers
>>
>> I added some more debug messages to x2golistsessions and am seeing that
>> this script seems to finish execution (I reach deubg statements just
>> before
>> closing syslog).
>>
>> Another note is that even after restart of the client and server PCs, this
>> is not working. Also, If I keep my client open for a long time after it
>> "hangs", it will sometimes eventually bring up the remote session. The
>> time
>> it takes for it to do this is on the order of magnitude of many hours.
>>
>> Thanks,
>> Kyle
>>
>
> Can you provide the output of
>
>   x2golistsessions --all-servers
>
> while X2Go Client is trying to launch the session?
>
> Make sure to obfuscate non-public data from listsession's output
> (username, host IPs, etc.).
>
> Also, please tell me your X2Go Server version.
>
>   $ x2goversion
>
> Mike
>
>
​The output of "
x2golistsessions --all-servers
​" is nothing ... there are no lines printed from this command.​
​


​The output of "x2goversion" is as follows:
$ x2goversion
x2goagent: 3.5.0.27
x2goserver: 4.0.1.18
x2goserver-extensions: 4.0.1.16
x2goserver-xsession: 4.0.1.16

Kyle​
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#656; Package x2goclient. (Wed, 29 Oct 2014 20:30:02 GMT) (full text, mbox, link).


Acknowledgement sent to Kyle Cottongim <cottonke@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 29 Oct 2014 20:30:02 GMT) (full text, mbox, link).


Message #35 received at 656@bugs.x2go.org (full text, mbox, reply):

From: Kyle Cottongim <cottonke@gmail.com>
To: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Cc: 656 <656@bugs.x2go.org>
Subject: Re: [X2Go-Dev] Bug#656: Fwd: Windows X2GoClient hangs when launching x2gostartagent
Date: Wed, 29 Oct 2014 15:25:05 -0500
[Message part 1 (text/plain, inline)]
Mike,

On Wed, Oct 29, 2014 at 9:36 AM, Kyle Cottongim <cottonke@gmail.com> wrote:

> Mike,
>
> On Wed, Oct 29, 2014 at 9:17 AM, Mike Gabriel <
> mike.gabriel@das-netzwerkteam.de> wrote:
>
>> Hi Kyle,
>>
>>
>> On  Mi 29 Okt 2014 14:30:54 CET, Kyle Cottongim wrote:
>>
>>  Hello Mike,
>>>
>>> On Wed, Oct 29, 2014 at 4:39 AM, Mike Gabriel <
>>> mike.gabriel@das-netzwerkteam.de> wrote:
>>>
>>>  Hi Kyle,
>>>>
>>>> On  So 26 Okt 2014 00:04:16 CEST, Kyle Cottongim wrote:
>>>>
>>>>  Package: X2GoClient
>>>>
>>>>> Version: 4.0.3.0
>>>>>
>>>>> When launching a session from within the X2GoClient, the process will
>>>>> hang
>>>>> after the following call:
>>>>>
>>>>> x2go-DEBUG-onmainwindow.cpp:3900> Executing remote command:
>>>>> "x2gostartagent
>>>>> 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME both"
>>>>>
>>>>> This does not happen all the time, but generally happens after loss of
>>>>> network connection or after logging out instead of just closing the
>>>>> X2GoClient window. A complete restart of the client machine will solve
>>>>> the
>>>>> issue.
>>>>>
>>>>>
>>>> Could you cross-check the debug output of X2Go Server, possibly add some
>>>> more log message to /usr/bin/x2gostartagent, so that we can narrow down,
>>>> where the "hang" actually occurs?
>>>>
>>>> Does x2gostartagent get executed at all, or is X2Go Client aready
>>>> stalling
>>>> before executing that command.
>>>>
>>>> Or is x2gostartagent hanging somewhere on the way? (Extra log messages
>>>> placed in x2gostartagent will be helpful then).
>>>>
>>>> Regards,
>>>> Mike
>>>>
>>>
>>>
>>> ​During this launch attempt, it seems the client is getting a bit further
>>> along than before, but still not to the point of launching something​.
>>> Here
>>> is how far things are getting now:
>>>
>>> x2go-DEBUG-onmainwindow.cpp:2778> SSH connection established.
>>> x2go-DEBUG-onmainwindow.cpp:3038> Continue normal x2go session
>>> x2go-DEBUG-onmainwindow.cpp:3382> ""
>>> x2go-DEBUG-onmainwindow.cpp:3769> Fullscreen: false
>>> x2go-DEBUG-onmainwindow.cpp:9257> got localhost
>>> x2go-DEBUG-onmainwindow.cpp:9279> Port is free: 6000
>>> x2go-DEBUG-onmainwindow.cpp:9345> using internal X: true
>>> x2go-DEBUG-onmainwindow.cpp:9368> WxH:"1440"x"900"
>>> x2go-DEBUG-onmainwindow.cpp:9373> "-multiwindow -notrayicon -clipboard"
>>> x2go-DEBUG-onmainwindow.cpp:9410> Running "C:/Program Files
>>> (x86)/x2goclient\vcxsrv\vcxsrv.exe" "-multiwindow -notrayicon
>>> -clipboard :0"
>>> x2go-DEBUG-onmainwindow.cpp:3900> Executing remote command:
>>> "x2gostartagent
>>> 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME both"
>>> x2go-DEBUG-onmainwindow.cpp:9257> got localhost
>>> x2go-DEBUG-onmainwindow.cpp:9285> Port already used: 6000
>>> x2go-DEBUG-onmainwindow.cpp:9439> X is started.
>>> x2go-DEBUG-onmainwindow.cpp:9790> All winservers are started.
>>>
>>> With some debug within the x2gostartagent I can tell that it is executing
>>> this script and now seems to be getting past this point. I have turned
>>> the
>>> logging level of the server to debug and here is the output I am seeing
>>> during a connection attempt:
>>>
>>> Oct 29 08:02:33 oddjob /usr/bin/x2golistsessions[12799]:
>>> x2golistsessions
>>> has been called with no option
>>> Oct 29 08:02:34 oddjob /usr/bin/x2gostartagent: x2gostartagent called
>>> with
>>> options: 1440x900 adsl 16m-jpeg-9 unix-kde-depth_32 us pc105/us 1 D GNOME
>>> both
>>> Oct 29 08:02:34 oddjob /usr/bin/x2gostartagent: client announced itself
>>> as
>>> ,,131.199.103.76''
>>> Oct 29 08:02:34 oddjob /usr/bin/x2gosessionlimit[12835]:
>>> x2gosessionlimit
>>> has been called
>>> Oct 29 08:02:34 oddjob /usr/bin/x2golistsessions[12838]:
>>> x2golistsessions
>>> has been called with options: --all-servers
>>>
>>> I added some more debug messages to x2golistsessions and am seeing that
>>> this script seems to finish execution (I reach deubg statements just
>>> before
>>> closing syslog).
>>>
>>> Another note is that even after restart of the client and server PCs,
>>> this
>>> is not working. Also, If I keep my client open for a long time after it
>>> "hangs", it will sometimes eventually bring up the remote session. The
>>> time
>>> it takes for it to do this is on the order of magnitude of many hours.
>>>
>>> Thanks,
>>> Kyle
>>>
>>
>> Can you provide the output of
>>
>>   x2golistsessions --all-servers
>>
>> while X2Go Client is trying to launch the session?
>>
>> Make sure to obfuscate non-public data from listsession's output
>> (username, host IPs, etc.).
>>
>> Also, please tell me your X2Go Server version.
>>
>>   $ x2goversion
>>
>> Mike
>>
>>
> ​The output of "
> x2golistsessions --all-servers
> ​" is nothing ... there are no lines printed from this command.​
> ​
>
>
> ​The output of "x2goversion" is as follows:
> $ x2goversion
> x2goagent: 3.5.0.27
> x2goserver: 4.0.1.18
> x2goserver-extensions: 4.0.1.16
> x2goserver-xsession: 4.0.1.16
>
> Kyle​
>
>
​One more data point ...​ it seems that on PCs with a slightly older
version of the server are working w/o problem. Here is the version
information for a working PC:

$ x2goversion
x2goagent: 3.5.0.24
x2goserver: 4.0.1.15
x2goserver-extensions: 4.0.1.15
x2goserver-xsession: 4.0.1.15

Kyle
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#656; Package x2goclient. (Wed, 15 Nov 2017 01:10:02 GMT) (full text, mbox, link).


Acknowledgement sent to Mihai Moldovan <ionic@ionic.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 15 Nov 2017 01:10:02 GMT) (full text, mbox, link).


Message #40 received at 656@bugs.x2go.org (full text, mbox, reply):

From: Mihai Moldovan <ionic@ionic.de>
To: Kyle Cottongim <cottonke@gmail.com>, 656@bugs.x2go.org, Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Subject: Re: [X2Go-Dev] Fwd: Windows X2GoClient hangs when launching x2gostartagent
Date: Wed, 15 Nov 2017 02:08:24 +0100
[Message part 1 (text/plain, inline)]
Control: tag -1 moreinfo

Is this still a problem with newer client and server versions?

Some time ago, I fixed a bug that sounds very similar to your problem - a perl
script (x2gosessionlimit) was iterating through all groups. In case of network
authentication and shared credentials for a full site (e.g., company), this lead
to abysmal delays.

I am hopeful that this also fixed the issue described here.



Mihai

[signature.asc (application/pgp-signature, attachment)]

Added tag(s) moreinfo. Request was from Mihai Moldovan <ionic@ionic.de> to 656-submit@bugs.x2go.org. (Wed, 15 Nov 2017 01:10:03 GMT) (full text, mbox, link).


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#656; Package x2goclient. (Thu, 04 Jun 2020 13:40:03 GMT) (full text, mbox, link).


Acknowledgement sent to familyconnolly@yahoo.com:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Thu, 04 Jun 2020 13:40:03 GMT) (full text, mbox, link).


Message #47 received at 656@bugs.x2go.org (full text, mbox, reply):

From: Connolly family <""@curatio.ge>
To: Recipients <>
Subject: Herzliche Glückwünsche
Date: Thu, 04 Jun 2020 05:59:40 -0700
Sie haben sich für Spenden- / humanitäre Mittel in Höhe von 5,7 Mio.
EUR entschieden, um den Ausbruch von COVID-19 in Ihrer Region zu
bekämpfen, der zu einer globalen Katastrophe geworden ist, bevor er
die Wirtschaft lähmt, und auch für philanthropische Arbeit. Weitere
Informationen erhalten Sie von Ihrem Spender unter:
familyconnolly@yahoo.com


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#656; Package x2goclient. (Tue, 01 Sep 2020 12:45:13 GMT) (full text, mbox, link).


Acknowledgement sent to "janetjacksonandersont@gmail.com" <janetjacksonandersont@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 01 Sep 2020 12:45:14 GMT) (full text, mbox, link).


Message #52 received at 656@bugs.x2go.org (full text, mbox, reply):

From: Janet Jackson Anderson <ci_eap@contraloriadf.gob.mx>
Subject: Hallo mein lieber Freund
Date: Tue, 1 Sep 2020 07:38:22 -0500 (CDT)
[Message part 1 (text/plain, inline)]

-- 
Hallo mein lieber FreundIch schreibe Ihnen diese Mail mit schweren Tr&auml;nen in meinen Augen und gro&szlig;er Trauer in meinem Herzen. Mein Name ist Janet Jackson Anderson, und ich kontaktiere Sie aus meinem Land Indien. Ich m&ouml;chte Ihnen dies sagen, weil ich keine habe Ich habe Herrn Jackson Anderson geheiratet, der neun Jahre lang mit der tunesischen Botschaft in Madrid, Spanien, zusammengearbeitet hat, bevor er im Jahr 2005 starb. Wir waren elf Jahre lang ohne Ehefrau verheiratet Kind.Er starb nach einer kurzen Krankheit, die nur f&uuml;nf Tage andauerte. Seit seinem Tod beschloss ich, nicht wieder zu heiraten, Als mein verstorbener Mann lebte, hinterlegte er die Summe von f&uuml;nfundvierzig Millionen, achthundert und f&uuml;nfzigtausend Dollar (45.850.000,00 USD) in einer Bank hier in Indien Neu-Delhi die Hauptstadt von Indien, Derzeit ist dieses Geld immer noch in der Bank.Er stellte dieses Geld f&uuml;r den Export von Gold aus Madrid Spanien Bergbau Fakten zur Verf&uuml;gung. K&uuml;rzlich sagte mir Mein Arzt, dass ich wegen eines Krebsproblems nicht f&uuml;r den Zeitraum von sieben Monaten durchhalten w&uuml;rde. Diejenige, die mich am meisten st&ouml;rt, ist meine Schlaganfallkrankheit. Nachdem ich meinen Zustand kannte, beschloss ich, Ihnen dieses Geld zu &uuml;bergeben, um sich um die weniger privilegierten Menschen zu k&uuml;mmern, werden Sie dieses Geld so nutzen, wie ich es hier inauftragen werde.Ich m&ouml;chte, dass Sie 30 Prozent des Gesamtgeldes f&uuml;r Ihren pers&ouml;nlichen Gebrauch verwenden, w&auml;hrend 70% des Geldes f&uuml;r wohlt&auml;tige Zwecke, Menschen auf der Stra&szlig;e und Hilfe f&uuml;r das Waisenhaus verwendet werden. Ich bin als Waisenkind aufgewachsen und habe keinen K&ouml;rper als mein Familienmitglied, nur um zu beenden, dass das Haus Gottes auch erhalten bleibt. Tue dies, damit Gott meine S&uuml;nden vergibt und meine Seele akzeptiert, weil diese Krankheiten mich so sehr gelitten haben. Sobald ich Ihre Antwort erhalten habe, werde ich Ihnen den Kontakt der Bank hier in Delhi, Indien, geben und den Bankmanager anweisen, Ihnen ein Vollmachtsschreiben auszustellen, das Ihnen den gegenw&auml;rtigen Beg&uuml;nstigten des Geldes bei der Bank nachweist, wenn dies der Fall ist Sie versichern mir, dass Sie entsprechend handeln werden, wie ich es hier angegeben habe.Ich hoffe, Ihre Antwort zu erhalten.Von Janet Jackson Anderson
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#656; Package x2goclient. (Tue, 01 Sep 2020 12:45:14 GMT) (full text, mbox, link).


Acknowledgement sent to "janetjacksonandersont@gmail.com" <janetjacksonandersont@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 01 Sep 2020 12:45:14 GMT) (full text, mbox, link).


Message #57 received at 656@bugs.x2go.org (full text, mbox, reply):

From: Janet Jackson Anderson <ci_eap@contraloriadf.gob.mx>
Date: Tue, 1 Sep 2020 07:38:47 -0500 (CDT)
[Message part 1 (text/plain, inline)]

-- 
Hallo mein lieber FreundIch schreibe Ihnen diese Mail mit schweren Tr&auml;nen in meinen Augen und gro&szlig;er Trauer in meinem Herzen. Mein Name ist Janet Jackson Anderson, und ich kontaktiere Sie aus meinem Land Indien. Ich m&ouml;chte Ihnen dies sagen, weil ich keine habe Ich habe Herrn Jackson Anderson geheiratet, der neun Jahre lang mit der tunesischen Botschaft in Madrid, Spanien, zusammengearbeitet hat, bevor er im Jahr 2005 starb. Wir waren elf Jahre lang ohne Ehefrau verheiratet Kind.Er starb nach einer kurzen Krankheit, die nur f&uuml;nf Tage andauerte. Seit seinem Tod beschloss ich, nicht wieder zu heiraten, Als mein verstorbener Mann lebte, hinterlegte er die Summe von f&uuml;nfundvierzig Millionen, achthundert und f&uuml;nfzigtausend Dollar (45.850.000,00 USD) in einer Bank hier in Indien Neu-Delhi die Hauptstadt von Indien, Derzeit ist dieses Geld immer noch in der Bank.Er stellte dieses Geld f&uuml;r den Export von Gold aus Madrid Spanien Bergbau Fakten zur Verf&uuml;gung. K&uuml;rzlich sagte mir Mein Arzt, dass ich wegen eines Krebsproblems nicht f&uuml;r den Zeitraum von sieben Monaten durchhalten w&uuml;rde. Diejenige, die mich am meisten st&ouml;rt, ist meine Schlaganfallkrankheit. Nachdem ich meinen Zustand kannte, beschloss ich, Ihnen dieses Geld zu &uuml;bergeben, um sich um die weniger privilegierten Menschen zu k&uuml;mmern, werden Sie dieses Geld so nutzen, wie ich es hier inauftragen werde.Ich m&ouml;chte, dass Sie 30 Prozent des Gesamtgeldes f&uuml;r Ihren pers&ouml;nlichen Gebrauch verwenden, w&auml;hrend 70% des Geldes f&uuml;r wohlt&auml;tige Zwecke, Menschen auf der Stra&szlig;e und Hilfe f&uuml;r das Waisenhaus verwendet werden. Ich bin als Waisenkind aufgewachsen und habe keinen K&ouml;rper als mein Familienmitglied, nur um zu beenden, dass das Haus Gottes auch erhalten bleibt. Tue dies, damit Gott meine S&uuml;nden vergibt und meine Seele akzeptiert, weil diese Krankheiten mich so sehr gelitten haben. Sobald ich Ihre Antwort erhalten habe, werde ich Ihnen den Kontakt der Bank hier in Delhi, Indien, geben und den Bankmanager anweisen, Ihnen ein Vollmachtsschreiben auszustellen, das Ihnen den gegenw&auml;rtigen Beg&uuml;nstigten des Geldes bei der Bank nachweist, wenn dies der Fall ist Sie versichern mir, dass Sie entsprechend handeln werden, wie ich es hier angegeben habe.Ich hoffe, Ihre Antwort zu erhalten.Von Janet Jackson Anderson
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Dec 4 15:27:15 2022; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.