X2Go Bug report logs - #629
Display port conflicts: Client access to multiple servers

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Jerry Rabe <jerry.rabe@gmail.com>

Date: Fri, 3 Oct 2014 21:50:01 UTC

Severity: normal

Found in version 4.0.1.15

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 3 Oct 2014 21:45:46 +0000
From jerry.rabe@gmail.com  Fri Oct  3 23:45:45 2014
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.8 required=5.0 tests=BAYES_50,FREEMAIL_FROM,
	T_DKIM_INVALID autolearn=ham version=3.3.2
Received: from mail-ig0-f169.google.com (mail-ig0-f169.google.com [209.85.213.169])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 8E6CE3D460
	for <submit@bugs.x2go.org>; Fri,  3 Oct 2014 23:45:45 +0200 (CEST)
Received: by mail-ig0-f169.google.com with SMTP id uq10so2615409igb.4
        for <submit@bugs.x2go.org>; Fri, 03 Oct 2014 14:45:43 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;
        h=mime-version:date:message-id:subject:from:to:content-type;
        bh=JBqi6SihZCGscqO8q7LMgWfKtoQhReJzqRtr/9cMmBQ=;
        b=lQ2JiGBOJK8bb4PDjSo6qqjYtvRLMHDWxToP2OVSPJttgNuUqhxRoZ37dDLXERkI7h
         rQNZ6ztfM+/fDm/FxHOyFHR1+9mlVb32kG9uLahB3AvzKB0Gp+lGJsJLsvlKc98paINm
         WYEUA7igccs7JTFY/D+wM4qHfUI7ci34XhQCy65k7gSDcsGjDd6XheICmuoGEs7RjtBf
         v+231ohiFBIh6smKP7VeXcEIOP6DLpmnyEWQeYV2ZIgzjH25HZ+nsJpqFjwUyx7UV9ON
         6VuTqfDb7KyMfGaIV1/17w7/xV7CxpFKjCd09vqcDWgiV4PGFOgffuseK21eNYrZD/94
         Uk1A==
MIME-Version: 1.0
X-Received: by 10.50.102.106 with SMTP id fn10mr1819513igb.14.1412372743753;
 Fri, 03 Oct 2014 14:45:43 -0700 (PDT)
Received: by 10.50.230.168 with HTTP; Fri, 3 Oct 2014 14:45:43 -0700 (PDT)
Date: Fri, 3 Oct 2014 16:45:43 -0500
Message-ID: <CAEL5mW8P1NeN37nJUHgybQ0Ra1GvfoihAqgUH6toCmh6n02uZQ@mail.gmail.com>
Subject: Display port conflicts: Client access to multiple servers
From: Jerry Rabe <jerry.rabe@gmail.com>
To: submit@bugs.x2go.org
Content-Type: text/plain; charset=UTF-8
Package: x2goserver
Version: 4.0.1.15

Server OS: Centos 6.5 x86_64
Server X2go Version: 4.0.1.15 (installed from source)

Client OS & version: Windows 7 Professional, Version 6.1 (Build 7601
Service Pack 1)
Client X2go Version:  x2goclient-4.0.2.1+hotfix1+build4-fullfonts

When using a single client machine to connect to two x2goserver
machines with two simultaneous x2goclient processes, the second client
session corrupts the first one because they both connect to the client
using Display port 50.  The first x2gosession is unresponsive and must
be killed manually.  Shouldn't x2goclient break with a warning about
conflicting ports?  Is there a way to configure each x2goserver to
connect with a different range of ports? (i.e. the same as when
configuring each Freenx server with a unique DISPLAY_BASE variable in
/etc/nxserver/node.conf)

In addition, once the x2gosession is corrupted on the first machine,
then even after reboots, any new x2gosessions start up OK, but if they
are resumed, both server & client log files say it resumes, but the
x2go window never appears on the client's screen.  Does something need
to be cleared in the server's database?


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Jan 31 16:51:45 2023; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.