X2Go Bug report logs - #530
Windows: PulseAudio severely slows down WinXP machines with

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Nable 80 <nable.maininbox@googlemail.com>

Date: Sun, 29 Jun 2014 14:05:01 UTC

Severity: normal

Tags: build-win32

Found in version 4.0.2.0

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 29 Jun 2014 14:04:44 +0000
From nable.maininbox@googlemail.com  Sun Jun 29 16:04:44 2014
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.8 required=5.0 tests=BAYES_50,FREEMAIL_FROM,
	T_DKIM_INVALID autolearn=ham version=3.3.2
Received: from mail-vc0-f181.google.com (mail-vc0-f181.google.com [209.85.220.181])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id B53DB5DB53
	for <submit@bugs.x2go.org>; Sun, 29 Jun 2014 16:04:43 +0200 (CEST)
Received: by mail-vc0-f181.google.com with SMTP id il7so6473439vcb.26
        for <submit@bugs.x2go.org>; Sun, 29 Jun 2014 07:04:42 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=googlemail.com; s=20120113;
        h=mime-version:date:message-id:subject:from:to:content-type;
        bh=l0Hptgjsl3Ra4ZhakjHAzC0qxELzrixIwmcgoDtsjWY=;
        b=DyZaipwkvSQp/mQx/lJt+5UeAjQVmPI5+hESwahm6pTGIjfPyC++yXLrdKEcbNVF7s
         vKHDqqn897DHqYuqcQxtewUsWQ9C2xDofG+no+DnRvWNSkA/gdmjUzDlhkgX0TyDBc6q
         k7VNbBROHF1xVhpmkhs8buwEvBjWxDPgAHAY+7wpSBN6nkVOrcZFNjxGNeUH9LEcIdnH
         XvNSXRNL26FKCoBPIg/hoa/KMDkI56cbbM4QXmgDIR6/hY+E6XkDDXkU29awbG0bZH//
         7s4CaORIJKdfu832xxjaCydSVt9So58V50QYrOGr39wn7CrM8sTwLyXHWOBzTf5SBgDz
         BvjA==
MIME-Version: 1.0
X-Received: by 10.52.241.76 with SMTP id wg12mr27116337vdc.5.1404050682267;
 Sun, 29 Jun 2014 07:04:42 -0700 (PDT)
Received: by 10.52.27.44 with HTTP; Sun, 29 Jun 2014 07:04:42 -0700 (PDT)
Date: Sun, 29 Jun 2014 18:04:42 +0400
Message-ID: <CALxOYEb=dwakiQOV7yzA_2_VbfOw2OxJ7+U6RUJgzE-aUE871A@mail.gmail.com>
Subject: Included PulseAudio consumes too much CPU when launched with high priority
From: Nable 80 <nable.maininbox@googlemail.com>
To: submit@bugs.x2go.org
Content-Type: text/plain; charset=ISO-8859-1
Package: x2goclient
Version: 4.0.2.0

When I use sound forwarding and launch inside X2Go session some application
with sound support, pulseaudio.exe at client side starts consuming ~100% CPU.
By default, X2Go Client starts pulseaudio.exe with high priority (13).
When I set priority to "Above Normal (10)" PA's CPU load drops to 10-20%.
With "Normal (8)" it drops to almost 0%, although sound is still played stable,
without any additional delays.

I'm using WinXP SP3 (32-bit) on my laptop with single core CPU.
This issue seems to be "PulseAudio 5.0 && WinXP"-specific.


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sat Jun 15 05:37:00 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.