X2Go Bug report logs - #522
X2Go Client fails to start if started with no cmdline arg

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Michael DePaulo <mikedep333@gmail.com>

Date: Thu, 26 Jun 2014 13:20:02 UTC

Severity: grave

Tags: pending

Found in version 4.0.2.1-preview

Fixed in version 4.0.2.1

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log


Message #12 received at 522@bugs.x2go.org (full text, mbox, reply):

Received: (at 522) by bugs.x2go.org; 26 Jun 2014 15:03:46 +0000
From newsgroups.mail2@stefanbaur.de  Thu Jun 26 17:03:41 2014
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-0.0 required=5.0 tests=BAYES_40 autolearn=ham
	version=3.3.2
X-Greylist: delayed 304 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Thu, 26 Jun 2014 17:03:41 CEST
Received: from mout.kundenserver.de (mout.kundenserver.de [212.227.17.24])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 9FDAF5DB1B
	for <522@bugs.x2go.org>; Thu, 26 Jun 2014 17:03:41 +0200 (CEST)
Received: from [192.168.0.3] (dslb-188-105-116-045.pools.arcor-ip.net [188.105.116.45])
	by mrelayeu.kundenserver.de (node=mreue102) with ESMTP (Nemesis)
	id 0MgwGe-1XMEFo2rMu-00M67p; Thu, 26 Jun 2014 16:58:36 +0200
Message-ID: <53AC3517.1060700@stefanbaur.de>
Date: Thu, 26 Jun 2014 16:58:31 +0200
From: Stefan Baur <newsgroups.mail2@stefanbaur.de>
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0
MIME-Version: 1.0
To: 522@bugs.x2go.org, Michael DePaulo <mikedep333@gmail.com>
Subject: Re: [X2Go-Dev] Bug#522: X2Go Client for Windows will not launch unless
 you pass --debug
References: <CAMKht8jLxomo-T7RCrsGd-9GWkAdsbBKoPeHkKrKiyLPYyxOHg@mail.gmail.com>
In-Reply-To: <CAMKht8jLxomo-T7RCrsGd-9GWkAdsbBKoPeHkKrKiyLPYyxOHg@mail.gmail.com>
X-Enigmail-Version: 1.6
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-Provags-ID: V02:K0:bIE1zZowLUQxLrWJCnBoPYCpKJ4HU89cPYtZ9OCoCzL
 uTbZIr162+AuRAxjiV409XZLRfCq61sQ1yvD+jhzXk9DdZMGSf
 Qi9IzdfiXqxgY5zwgNmV7hV3R7fRNgKh6qj1HnacZvk0G8tg+c
 NuI8OYLIGZr5qFS0fIqsdW4lWHwhBoOFhQ2kqXLgy8UH0l7wss
 OAdoLkJ0ibIPRJNNYEygNJey6U/HdzHzmCZ44XvLzIou2hJNak
 1zKzFjwjqDqEQBKs76a5Chhm1eA+TvnIHaMPxl5vYVtpCFQ2rl
 0OqoYopBXW3lo0H21qv+iSGbR81svXFbM5eygj3Bs5DPIeXk5l
 poux7U2n6G/6vZbJT2ZnAxZjgZQXXlLT09GKpzIPs
Am 26.06.2014 15:16, schrieb Michael DePaulo:

> This only affects current nightly builds on the master branch (4.0.2.1.)
> 
> Like the subject says, X2Go Client for Windows will not launch unless
> you pass --debug. If you do not pass --debug, no window ever opens,
> there is no error message, and the x2goclient.exe process terminates
> within a second.
> 
> Observed on Windows 8.1 (with update 1) 64-bit.

Observed on Windows 7 x64, too.

> This regression appears to have been introduced over the last few
> weeks or so, (possibly by me.)

To ease debugging:
2014-06-11 is the last working nightly build.
2014-06-12 is already broken.

-Stefan


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Fri Nov 22 17:19:42 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.