X2Go Bug report logs - #487
hardcoded /opt/X11/bin/xmodmap in onmainwindow.cpp

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: joerg@hydrops.han.de

Date: Mon, 5 May 2014 22:35:01 UTC

Severity: normal

Tags: pending

Merged with 977

Found in version 4.0.2.0

Fixed in version 4.0.5.1

Done: X2Go Release Manager <git-admin@x2go.org>

Bug is archived. No further changes may be made.

Full log


Message #36 received at 487@bugs.x2go.org (full text, mbox, reply):

Received: (at 487) by bugs.x2go.org; 5 Apr 2016 17:50:33 +0000
From njethwa@cirruscomputing.com  Tue Apr  5 19:50:30 2016
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.7 required=3.0 tests=BAYES_50,DKIM_SIGNED,
	DKIM_VALID,DKIM_VALID_AU,HTML_MESSAGE,SPF_HELO_PASS,URIBL_BLOCKED
	autolearn=ham version=3.3.2
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id B84A95DA9F
	for <487@bugs.x2go.org>; Tue,  5 Apr 2016 19:50:29 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id E+5gvjL1fxiz for <487@bugs.x2go.org>;
	Tue,  5 Apr 2016 19:50:23 +0200 (CEST)
X-Greylist: delayed 327 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Tue, 05 Apr 2016 19:50:17 CEST
Received: from smtp.a1107.virtualorgs.net (static-209-87-232-151.storm.ca [209.87.232.151])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id E97DC5DA9D
	for <487@bugs.x2go.org>; Tue,  5 Apr 2016 19:50:17 +0200 (CEST)
Received: from [10.101.74.50] (chaos.a1107.virtualorgs.net [10.101.74.50])
	by smtp.a1107.virtualorgs.net (Postfix) with ESMTPSA id E7DC470A43
	for <487@bugs.x2go.org>; Tue,  5 Apr 2016 13:44:48 -0400 (EDT)
DomainKey-Signature: a=rsa-sha1; s=mail; d=cirruscomputing.com; c=simple; q=dns;
	h=dkim-signature:subject:from:reply-to:to:content-type:
	organization:date:message-id:mime-version:x-mailer;
	b=uu7AwDI4ZGxpv81MCZiPCJYMtUKFmIahAATfLX2YPTndbGZ+REhYZsNHoL/gbyLDa
	/QjcGi1JSQ4cqnNf1weTmuMqS9OYfxt+Jn1jq8Ee2HU3ww9pHl5L5zspminIJBZvs85
	14FqEI4DxLo0h5fWE9B6zs56S9IFE5egEyurBy0=
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=cirruscomputing.com;
	s=mail; t=1459878289;
	bh=Fe/UKSxrNVBZ/ahw+jTW/AtLhXhE20Kui0a6gA42mkQ=;
	h=Subject:From:Reply-To:To:Content-Type:Date:Message-ID:
	 Mime-Version;
	b=cSc1lrnMZ8v3kz3XrJfKzKvP4906d6PpiT2xhwIHO4+dxaEs8Yv7d6enlu5uFmpXs
	 X0TBf9MGVX3wE4b72lI6zeFn1nH4hNJ63U3OTojPCit7iiMjkVIsUjyE6N9HJGCY9u
	 aP5zniOHHAuMdsLcHc8NYEsT/wJ0XcgkioUQtUsE=
Subject: "xmodmap failed to start" error
From: Nimesh Jethwa <njethwa@cirruscomputing.com>
Reply-To: njethwa@cirruscomputing.com
To: 487@bugs.x2go.org
Content-Type: multipart/mixed; boundary="=-ErVioRg2U5brqLjjKsq0"
Organization: a1107
Date: Tue, 05 Apr 2016 13:44:48 -0400
Message-ID: <1459878288.24076.38.camel@chaos.a1107.virtualorgs.net>
Mime-Version: 1.0
X-Mailer: Evolution 2.32.2 
[Message part 1 (text/plain, inline)]
When connecting to a X2Go session using the latest release (4.0.5.1) on
Mac OS 10.11, the client displays a dialog box with error message
"xmodmap failed to start". Attached is a picture of the error message.

It seems like the search path does not include '/usr/X11/bin' or
'/opt/X11/bin' which indeed does have the xmodmap binary.

Some debug -

1) Executing 'echo $PATH' in the terminal displays
'/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin'

2) Below is a snippet of 'launchctl procinfo <x2go_pid>' when opening
the app from Launchpad.
        inherited environment = {
                DISPLAY
=> /private/tmp/com.apple.launchd.jbbgc0SnWW/org.macosforge.xquartz:0
                SSH_AUTH_SOCK
=> /private/tmp/com.apple.launchd.iQM7MSzyBK/Listeners
                Apple_PubSub_Socket_Render
=> /private/tmp/com.apple.launchd.FBStbBeusm/Render
        }

        default environment = {
                PATH => /usr/bin:/bin:/usr/sbin:/sbin
        }

        environment = {
                USER => zc
                COMMAND_MODE => unix2003
                LOGNAME => zc
                PATH => /usr/bin:/bin:/usr/sbin:/sbin
                DISPLAY
=> /private/tmp/com.apple.launchd.jbbgc0SnWW/org.macosforge.xquartz:0
                Apple_PubSub_Socket_Render
=> /private/tmp/com.apple.launchd.FBStbBeusm/Render
                SSH_AUTH_SOCK
=> /private/tmp/com.apple.launchd.iQM7MSzyBK/Listeners
                SHELL => /bin/bash
                HOME => /Users/zc
                TMPDIR
=> /var/folders/dr/ylvdtkpd2rv2qkfclsw7y06r0000gn/T/
                __CF_USER_TEXT_ENCODING => 0x1F5:0x0:0x0
                XPC_SERVICE_NAME =>
com.apple.xpc.launchd.oneshot.0x10000006.x2goclient
        }

3) Executing 'launchctl setenv
PATH /usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin' in the
terminal, followed by opening the app from Launchpad, procinfo shows -
        inherited environment = {
                PATH
=> /usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin
                DISPLAY
=> /private/tmp/com.apple.launchd.jbbgc0SnWW/org.macosforge.xquartz:0
                SSH_AUTH_SOCK
=> /private/tmp/com.apple.launchd.iQM7MSzyBK/Listeners
                Apple_PubSub_Socket_Render
=> /private/tmp/com.apple.launchd.FBStbBeusm/Render
        }

        default environment = {
                PATH => /usr/bin:/bin:/usr/sbin:/sbin
        }

        environment = {
                USER => zc
                COMMAND_MODE => unix2003
                LOGNAME => zc
                PATH => /usr/bin:/bin:/usr/sbin:/sbin
                DISPLAY
=> /private/tmp/com.apple.launchd.jbbgc0SnWW/org.macosforge.xquartz:0
                Apple_PubSub_Socket_Render
=> /private/tmp/com.apple.launchd.FBStbBeusm/Render
                SSH_AUTH_SOCK
=> /private/tmp/com.apple.launchd.iQM7MSzyBK/Listeners
                SHELL => /bin/bash
                HOME => /Users/zc
                TMPDIR
=> /var/folders/dr/ylvdtkpd2rv2qkfclsw7y06r0000gn/T/
                __CF_USER_TEXT_ENCODING => 0x1F5:0x0:0x0
                XPC_SERVICE_NAME =>
com.apple.xpc.launchd.oneshot.0x10000007.x2goclient
        }

4) Opening the app using terminal by executing 'open
-n /Applications/x2goclient.app'
        inherited environment = {
                DISPLAY
=> /private/tmp/com.apple.launchd.8PPy9QYAsk/org.macosforge.xquartz:0
                SSH_AUTH_SOCK
=> /private/tmp/com.apple.launchd.WjqkY6s8Nu/Listeners
                Apple_PubSub_Socket_Render
=> /private/tmp/com.apple.launchd.foKIWVipU9/Render
        }

        default environment = {
                PATH => /usr/bin:/bin:/usr/sbin:/sbin
        }

        environment = {
                PWD => /Users/zc
                USER => zc
                SECURITYSESSIONID => 186a7
                LANG => en_CA.UTF-8
                COMMAND_MODE => unix2003
                TERM => xterm-256color
                PATH
=> /usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin
                LOGNAME => zc
                DISPLAY
=> /private/tmp/com.apple.launchd.8PPy9QYAsk/org.macosforge.xquartz:0
                Apple_PubSub_Socket_Render
=> /private/tmp/com.apple.launchd.foKIWVipU9/Render
                TERM_PROGRAM_VERSION => 361
                TERM_SESSION_ID => BAFCF5E5-BAA0-4415-AF96-FEBA6619784E
                SSH_AUTH_SOCK
=> /private/tmp/com.apple.launchd.WjqkY6s8Nu/Listeners
                SHLVL => 1
                SHELL => /bin/bash
                HOME => /Users/zc
                _ => /usr/bin/open
                TERM_PROGRAM => Apple_Terminal
                TMPDIR
=> /var/folders/dr/ylvdtkpd2rv2qkfclsw7y06r0000gn/T/
                __CF_USER_TEXT_ENCODING => 0x1F5:0x0:0x0
                XPC_SERVICE_NAME =>
com.apple.xpc.launchd.oneshot.0x10000006.x2goclient
        }

===

Basically, the correct path is set only when the app is opened via the
terminal. If the user decides to hit 'OK' to the dialog box, then the
x2go session is terminated, but if he decides to leave it unattended,
then the user can continue using his session.

I'm not sure what the fix would be here. Do we leave it on the user to
fix his default path settings even though 'echo $PATH' shows it is set
to the right path? Or, in the code, we hard code the path to 
"/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/sbin:/usr/X11R6/bin:/opt/X11/bin", regardless of what the env variable is set to?

Thanks,
Nimesh
[Message part 2 (text/html, inline)]
[xmodmap-error.jpg (image/jpeg, attachment)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Apr 17 02:47:29 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.