X2Go Bug report logs - #471
ATTENTION @Mike#1 - serious bug in x2goserver upgrade script (debian wheezy+squeeze)

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Stefan Baur <newsgroups.mail2@stefanbaur.de>

Date: Thu, 3 Apr 2014 06:55:02 UTC

Severity: grave

Tags: pending

Found in version 4.0.1.14

Fixed in version 4.0.1.15

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log


Message #10 received at 471@bugs.x2go.org (full text, mbox, reply):

Received: (at 471) by bugs.x2go.org; 3 Apr 2014 07:57:36 +0000
From newsgroups.mail2@stefanbaur.de  Thu Apr  3 09:57:35 2014
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00,SPF_HELO_PASS,
	URIBL_BLOCKED autolearn=ham version=3.3.2
X-Greylist: delayed 302 seconds by postgrey-1.34 at ymir; Thu, 03 Apr 2014 09:57:35 CEST
Received: from moutng.kundenserver.de (moutng.kundenserver.de [212.227.126.187])
	by ymir (Postfix) with ESMTP id 3CCBE5DB16
	for <471@bugs.x2go.org>; Thu,  3 Apr 2014 09:57:35 +0200 (CEST)
Received: from [192.168.0.3] (dslb-188-099-193-217.pools.arcor-ip.net [188.99.193.217])
	by mrelayeu.kundenserver.de (node=mreue005) with ESMTP (Nemesis)
	id 0MZQm9-1WjivN11Lx-00LCAI; Thu, 03 Apr 2014 09:52:32 +0200
Message-ID: <533D135A.9090902@stefanbaur.de>
Date: Thu, 03 Apr 2014 09:52:58 +0200
From: Stefan Baur <newsgroups.mail2@stefanbaur.de>
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.4.0
MIME-Version: 1.0
To: 471@bugs.x2go.org, 
 "x2go-dev@lists.berlios.de" <x2go-dev@lists.berlios.de>
Subject: Re: [X2Go-Dev] Bug#471: ATTENTION @Mike#1 - serious bug in x2goserver
 upgrade script (debian wheezy+squeeze)
References: <533D12B1.50501@stefanbaur.de>
In-Reply-To: <533D12B1.50501@stefanbaur.de>
X-Enigmail-Version: 1.6
X-Forwarded-Message-Id: <533D12B1.50501@stefanbaur.de>
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
X-Provags-ID: V02:K0:k9gFwwLidCgt/YFAeBgOgAow5HZXai93CuO5gmSsqf3
 +eU4BNVMOFkBfO1YQssF9WCKVqkSSQo3VA88Z2AAhFtap2QbPp
 YkK4YtZo3EMrGkf763vYaedp6Sdy3X25OWP96vtvFAiRUXhwQH
 cDh+by1dEAS4IEZC47fD6JVhKV/qXt0R+JI1+7hYiQpUbugAXJ
 Ipdr+JkSUwWZbc27xbFIGeZP8Oe2X4wZKoywHaBxNGhfZ+Y4SI
 RZGc7hYKZ8eEZePRe8wNCwzsm2/GKTesq7Yc9yQKvunyPGZ8Lm
 qX0v1Efbs9XZaYdrLBBiyJmpNqJecp3l4ArIn7vqT8CyOyACkP
 eq7hkmbhfOXsldyPSn0kH3CwJ9IJRutpOaXZqpJN5
Gah. E_NOTENOUGHCAFFEINE. This was supposed to go to the list and
bugtracker as well.


-------- Original-Nachricht --------
Betreff: Re: [X2Go-Dev] Bug#471: ATTENTION @Mike#1 - serious bug in
x2goserver upgrade script (debian wheezy+squeeze)
Datum: Thu, 03 Apr 2014 09:50:09 +0200
Von: Stefan Baur <newsgroups.mail2@stefanbaur.de>
Antwort an: Stefan Baur <newsgroups.mail2@stefanbaur.de>,
471@bugs.x2go.org, x2go-dev@lists.berlios.de
An: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Addendum:

This is part of the "ps ax" output on one of the affected machines:

 2563 pts/2    S+     0:00 apt-get upgrade -y
 4958 pts/1    S+     0:00 /usr/bin/perl -w /usr/share/debconf/frontend
/var/lib/dpkg/info/x2goserver.postinst configure 4.0.1.13-0x2go1+
 4962 pts/1    Z+     0:00 [x2goserver.post] <defunct>
 5004 pts/1    S+     0:00 /usr/bin/perl /usr/sbin/x2gocleansessions

manually killing x2gocleansessions (" kill $(pidof x2gocleansessions)")
seems to be a workaround, but still, we need a real fix in the form of
an updated package.

-Stefan

Am 03.04.2014 08:47, schrieb Stefan Baur:
> Package: x2goserver
> Severity: grave
> Version: 4.0.1.14
> 
> Hi Mike,
> 
> this is happening on
> 
> x2goserver (4.0.1.14-0x2go1+git20140402.842+squeeze.main.1)
> 
> as well.
> 
> Please help! All my machines are stuck in the upgrade process! This is
> not good!
> 
> -Stefan
> 
> 
> -------- Original-Nachricht --------
> Betreff: [X2Go-User] Unable to upgrade
> Datum: Wed, 2 Apr 2014 19:14:53 +0300
> Von: Panayotis Katsaloulis <panayotis@panayotis.com>
> An: x2go-user@lists.berlios.de
> 
> Hello all!
> 
> I have installed x2go, I can connect - everything is fine.
> In the past I think there was a problem when I tried to launch a client
> (as xterm session), and which I was unable to properly close, so I
> forced close it.
> 
> The problem is that I am unable to upgrade through apt-get upgrade though.
> 
> Now when I try to upgrade I get this message:
> 
> Processing triggers for menu (2.1.46) ...
> Setting up x2goserver (4.0.1.14-0x2go1+git20140402.842+wheezy.main.1) ...
> Group x2gouser already exists.
> User x2gouser already exists.
> [info] Cleaning up stale X2Go sessions..
> 
> … and the screen remains like this forever.
> 
> The uname -a command produces the following result:
> 
> Linux danube 3.13-1-amd64 #1 SMP Debian 3.13.7-1 (2014-03-25) x86_64
> GNU/Linux
> 
> Any help?
> 
> --
> Panayotis
> 
> 
> _______________________________________________
> X2Go-User mailing list
> X2Go-User@lists.berlios.de
> https://lists.berlios.de/mailman/listinfo/x2go-user
> _______________________________________________
> X2Go-Dev mailing list
> X2Go-Dev@lists.berlios.de
> https://lists.berlios.de/mailman/listinfo/x2go-dev
> 




Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu Aug 13 11:59:45 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.