X2Go Bug report logs - #263
X2Go Client fails to resume

version graph

Package: nxagent; Maintainer for nxagent is X2Go Developers <x2go-dev@lists.x2go.org>; Source for nxagent is src:nx-libs.

Reported by: Edouard Villeneuve <evilleneuve@pldagroup.com>

Date: Fri, 12 Jul 2013 06:33:02 UTC

Severity: normal

Tags: confirmed, patch, pending

Merged with 206, 302

Found in version 3.5.0.24

Fixed in version 3.5.0.25

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 12 Jul 2013 06:22:29 +0000
From evilleneuve@pldagroup.com  Fri Jul 12 08:22:28 2013
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.1 required=5.0 tests=HTML_IMAGE_RATIO_02,
	HTML_MESSAGE,RCVD_IN_DNSWL_LOW,URIBL_BLOCKED autolearn=no version=3.3.2
Received: from mail-wi0-f171.google.com (mail-wi0-f171.google.com [209.85.212.171])
	by ymir (Postfix) with ESMTPS id 7D77D5DB11
	for <submit@bugs.x2go.org>; Fri, 12 Jul 2013 08:22:28 +0200 (CEST)
Received: by mail-wi0-f171.google.com with SMTP id hj3so276845wib.16
        for <submit@bugs.x2go.org>; Thu, 11 Jul 2013 23:22:28 -0700 (PDT)
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=google.com; s=20120113;
        h=from:mime-version:x-mailer:thread-index:date:message-id:subject:to
         :content-type:x-gm-message-state;
        bh=MDITgNsoJn6+AwjQdKbOZq+BFAqCYvBhdl2H9SZL9SI=;
        b=R24EbRQPPvBIIUHxm9U3S9a0ddSxW+dj4EiryBLP0KH+kuq+bxmsHWFqllapRXMZX0
         thNwed765aGVcKhvITF17KDrZDbpdmOLQBH5PlKtOvWrHagtGxkQgkYIuIsfvscpMK4r
         ZmNIzbpJidXjvOO7ueKzjdRnntoAJgLP+XuZHwbgY4/DhkTlQhRZgOUnWd2CcKqA4X1A
         ZijCGWZG0+hWV/uiMS2lCJhAAHQNn0X2R2dTsMV2srpC9hpbKfeipOu8lAefuZUm8GGP
         TgPdN76O/JNRgDCOTffMfW8lsVD0GB52p833brQE8cU+FuqwOjLIDIutWKiG/Gk5caxQ
         JFqw==
X-Received: by 10.181.13.7 with SMTP id eu7mr688669wid.54.1373610148124; Thu,
 11 Jul 2013 23:22:28 -0700 (PDT)
From: Edouard Villeneuve <evilleneuve@pldagroup.com>
MIME-Version: 1.0
X-Mailer: Microsoft Outlook 14.0
Thread-Index: Ac5+wzmJ3kJ2i/3uS5uklrqWV3N7TA==
Date: Fri, 12 Jul 2013 08:22:26 +0200
Message-ID: <98a681b9536911f4775f1c8e280f18b9@mail.gmail.com>
Subject: X2Go Client fails to resume
To: submit@bugs.x2go.org
Content-Type: multipart/related; boundary=f46d043be030f0623504e14a88a7
X-Gm-Message-State: ALoCoQnpWpOlQ2Asf0/XY+6gXgh4fw4x4niYGKnsWYobJDVFvKTcJrSNLeBkXYJeyR+mZ7C1vpwa
[Message part 1 (text/plain, inline)]
Package: not_applicable



Hello,



About half of the time, when I run X2Go Client on Windows (4.0.0.3) in a
high-speed LAN environment, the session fails to resume:

·         Displaying details shows that it gets stuck after a few lines of
output (first screenshot)

·         I then typically exit and restart X2Go client and it often works
(but not always)

·         If it still doesn’t, I exit again and restart again… Eventually,
it ends up working (second screenshot)



[image: cid:image001.jpg@01CE7ED4.FD404FE0]



[image: cid:image006.jpg@01CE7ED4.FD404FE0]



Full logs on 2nd screen:



NXPROXY - Version 3.5.0



Copyright (C) 2001, 2010 NoMachine.

See http://www.nomachine.com/ for more information.



Info: Proxy running in client mode with pid '28296'.

Session: Starting session at 'Fri Jul 12 07:50:20 2013'.

Info: Connecting to remote host 'localhost:31051'.

Info: Connection to remote proxy 'localhost:31051' established.

Info: Connection with remote proxy completed.

Warning: Unrecognized session type 'unix-kde-depth_32'. Assuming agent
session.

Warning: Failed to read data from the X auth command.

Warning: Generated a fake cookie for X authentication.

Info: Using ADSL link parameters 512/24/1/0.

Info: Using cache parameters 4/4096KB/8192KB/8192KB.

Info: Using pack method '64k-jpeg-7' with session 'unix-kde-depth_32'.

Info: Using ZLIB data compression 1/1/32.

Info: Using ZLIB stream compression 4/4.

Info: Using cache file
'/cygdrive/C/Users/EVILLE~1.PLD/X2GO~1/cache-unix-kde-depth_32/S-3C19BBB98D4E5CCCADDDDF384B70B5E6'.

Info: Forwarding X11 connections to display 'localhost:0'.

Session: Session started at 'Fri Jul 12 07:50:21 2013'.

Info: Established X server connection.

Info: Using shared memory parameters 0/0K.



Thanks,

- Edouard



Edouard Villeneuve | IS Manager | PLDA Group | Cell : +33 (0) 670 409 549 |
http://www.plda.com/
[Message part 2 (text/html, inline)]
[image001.jpg (image/jpeg, inline)]
[image006.jpg (image/jpeg, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Jul 21 22:51:39 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.