X2Go Bug report logs - #1582
App rendering issue on MacOS

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Anonymous <git-admin@x2go.org>

Date: Sat, 19 Feb 2022 23:45:02 UTC

Severity: normal

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1582; Package x2go clientversion: 4.1.2.2. (Sat, 19 Feb 2022 23:45:03 GMT) (full text, mbox, link).


Acknowledgement sent to Anonymous <git-admin@x2go.org>:
New Bug report received and forwarded. Copy sent to owner@bugs.x2go.org. (Sat, 19 Feb 2022 23:45:09 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

From: Anonymous <git-admin@x2go.org>
To: "submit@bugs.x2go.org" <submit@bugs.x2go.org>
Subject: App rendering issue on MacOS
Date: Sat, 19 Feb 2022 23:43:15 +0000 (UTC)
[Message part 1 (text/plain, inline)]
Package: X2Go ClientVersion: 4.1.2.2

I have a rendering issue when opening the server's application Intellij IDEA. While I'm using a light theme, the background will turn black and the text will have a white background. The application looks fine when the mouse is inactive like when I'm typing. But if there's mouse movement, it will switch to black and white.
You cannot see the actual switch in the screen recording so I took a video to show the problem.
Additional info: It doesn't happen when I use connection ISDN but the machine is tool slow. It also tried it using the same session preferences in Windows 10 and it will work perfectly fine.

Client's Machine: Macbook Air M1 Client's OS: MacOS Monterey (Version 12.0.1)Session preferences:    Session type: XFCE
    Connection: ADSL
    Compression method: 16m-jpeg (it happens to any methods)
    Image quality: 9
[Message part 2 (text/html, inline)]
[bug - video recording.mov (video/quicktime, attachment)]
[Screen Shot 2022-02-20 at 7.32.34 AM.png (image/png, attachment)]

Bug reassigned from package 'x2go clientversion: 4.1.2.2' to 'x2goclient'. Request was from Juri Grabowski <x2go@jugra.de> to control@bugs.x2go.org. (Sat, 12 Mar 2022 17:20:02 GMT) (full text, mbox, link).


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1582; Package x2goclient. (Thu, 25 Aug 2022 20:05:07 GMT) (full text, mbox, link).


Acknowledgement sent to Nuno Barros <nuno.barros@icometrix.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Thu, 25 Aug 2022 20:05:08 GMT) (full text, mbox, link).


Message #12 received at 1582@bugs.x2go.org (full text, mbox, reply):

From: Nuno Barros <nuno.barros@icometrix.com>
To: 1582@bugs.x2go.org
Date: Thu, 25 Aug 2022 22:02:22 +0200
[Message part 1 (text/plain, inline)]
Any news regarding this bug? I have the exact same situation
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Nov 27 15:29:18 2022; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.