X2Go Bug report logs - #1498
Recent Firefox 68 and chromium crash in X2go

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Antoine Tran <antoine.tran@thales-services.fr>

Date: Fri, 9 Oct 2020 08:40:02 UTC

Severity: normal

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1498; Package x2goserver. (Fri, 09 Oct 2020 08:40:02 GMT) (full text, mbox, link).


Acknowledgement sent to Antoine Tran <antoine.tran@thales-services.fr>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>.

Your message had a Version: pseudo-header with an invalid package version:

x2goserver-4.1.0.3-3.el7.x86_64.rpm <https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/x/x2goserver-4.1.0.3-3.el7.x86_64.rpm>

please either use found or fixed to the control server with a correct version, or reply to this report indicating the correct version so the maintainer (or someone else) can correct it for you.

(Fri, 09 Oct 2020 08:40:02 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

From: Antoine Tran <antoine.tran@thales-services.fr>
To: "submit@bugs.x2go.org" <submit@bugs.x2go.org>
Subject: Recent Firefox 68 and chromium crash in X2go
Date: Fri, 9 Oct 2020 10:39:15 +0200
[Message part 1 (text/plain, inline)]
Package: x2goserver
Version:x2goserver-4.1.0.3-3.el7.x86_64.rpm  <https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/x/x2goserver-4.1.0.3-3.el7.x86_64.rpm>
Tag: firefox chromium glx

Dear all,

We use in our project X2go from Windows 10 with x2goclient latest 
4.1.2.2 and that connects to docker image containing CentOs 7.8, 
x2goserver latest 4.1.0.3. We used Firefox 60.9.0 and it works quite 
well if we disable the hardware acceleration via about:config

pref("browser.tabs.remote.autostart", false);
pref("browser.tabs.remote.autostart.2", false);

But we upgraded to Firefox 68 with package from CentOs. I also tried 
Firefox 68 ESR and 78 ESR directly from firefox website. All of that 
crashed after some time, with symptoms like "Gah. Your tab just 
crashed." and some "ipc_channel_posix.cc, line 358" in console. Or 
sometime it just disappear. It happens when we resize the windows  of 
Firefox or after browsing a few seconds.

I also tried disabling hardware acceleration and setting number of 
process for tab management CSP to 1.

What is the relationship between X2go and this error? If I launch 
chromium, it is a bit more stable but right at the beginning, it 
complains the minimal version for glx required is 1.3, while we have 1.2 
in x2go environment. And it crashes too after a few browsing.

I have a big suspicion Firefox behave badly for the same reason. I know 
x2go provides a workaround: 
https://wiki.x2go.org/doku.php/wiki:development:glx-xlib-workaround . 
Which I haven't time to test yet.

My questions:

1. Does anyone reproduce the same error? It is not normal to have two
   recent browser that crashes in an updated OS.
2. Is-there an already built RPM containing the glx lib, so that we
   just do yum install something to have glx set to 1.4? I did not find
   one.

Antoine

[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu Oct 29 10:24:55 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.