Package: x2goserver
Version: x2goserver-
Tag: firefox chromium glx

Dear all,

We use in our project X2go from Windows 10 with x2goclient latest and that connects to docker image containing CentOs 7.8, x2goserver latest We used Firefox 60.9.0 and it works quite well if we disable the hardware acceleration via about:config

pref("browser.tabs.remote.autostart", false);
pref("browser.tabs.remote.autostart.2", false);

But we upgraded to Firefox 68 with package from CentOs. I also tried Firefox 68 ESR and 78 ESR directly from firefox website. All of that crashed after some time, with symptoms like "Gah. Your tab just crashed." and some ", line 358" in console. Or sometime it just disappear. It happens when we resize the windows  of Firefox or after browsing a few seconds.

I also tried disabling hardware acceleration and setting number of process for tab management CSP to 1.

What is the relationship between X2go and this error? If I launch chromium, it is a bit more stable but right at the beginning, it complains the minimal version for glx required is 1.3, while we have 1.2 in x2go environment. And it crashes too after a few browsing.

I have a big suspicion Firefox behave badly for the same reason. I know x2go provides a workaround: . Which I haven't time to test yet.

My questions:

  1. Does anyone reproduce the same error? It is not normal to have two recent browser that crashes in an updated OS.
  2. Is-there an already built RPM containing the glx lib, so that we just do yum install something to have glx set to 1.4? I did not find one.