X2Go Bug report logs - #1450
Fwd: Arrow keys randomly stop working in x2go

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: "stivstivsti ." <stiv.yakovenko@gmail.com>

Date: Mon, 30 Mar 2020 12:50:01 UTC

Severity: normal

Found in version

Full log

🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1450: [X2Go-Dev] Bug#1450: Fwd: Arrow keys randomly stop working in x2go
Reply-To: uli42@gmx.de, 1450@bugs.x2go.org
Resent-From: Ulrich Sibiller <ulrich.sibiller@gmail.com>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Sun, 03 May 2020 18:50:03 +0000
Resent-Message-ID: <handler.1450.B1450.158853160529601@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 1450
X-X2Go-PR-Package: x2goclient
References: <CACkPNmhg5Rk54pt6PJPabH5PSQu0dRD2f_kWeFihDk4-xhktKw@mail.gmail.com> <CACkPNmjTE8PX8f0a8x+qqubTxToujdJcjfn3p4YBFZupzCX6ig@mail.gmail.com> <CACkPNmjTE8PX8f0a8x+qqubTxToujdJcjfn3p4YBFZupzCX6ig@mail.gmail.com>
Received: via spool by 1450-submit@bugs.x2go.org id=B1450.158853160529601
          (code B ref 1450); Sun, 03 May 2020 18:50:03 +0000
Received: (at 1450) by bugs.x2go.org; 3 May 2020 18:46:45 +0000
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on
X-Spam-Status: No, score=-0.7 required=3.0 tests=BAYES_00,DKIM_SIGNED,
	SPF_HELO_NONE,URIBL_BLOCKED autolearn=no autolearn_force=no
Received: from mail-yb1-xb31.google.com (mail-yb1-xb31.google.com [IPv6:2607:f8b0:4864:20::b31])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id A312B5DAC1;
	Sun,  3 May 2020 20:46:34 +0200 (CEST)
Received: by mail-yb1-xb31.google.com with SMTP id f5so1743042ybo.4;
        Sun, 03 May 2020 11:46:34 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20161025;
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20161025;
X-Gm-Message-State: AGi0PubOEjfyxyTnk6uGT1/KT0UxESlaTH5Ypu3HQovUzbsNPE02dNiZ
X-Google-Smtp-Source: APiQypIn4bTfKaK90Vw7MtjJjA98cPvPzNmQeaD+/X5RsAln86Akb6vqWWnSf9XpDGjyn55qZH0jwrQAUYhnn16ee+g=
X-Received: by 2002:a5b:ecd:: with SMTP id a13mr5811172ybs.306.1588531592075;
 Sun, 03 May 2020 11:46:32 -0700 (PDT)
MIME-Version: 1.0
In-Reply-To: <CACkPNmjTE8PX8f0a8x+qqubTxToujdJcjfn3p4YBFZupzCX6ig@mail.gmail.com>
From: Ulrich Sibiller <ulrich.sibiller@gmail.com>
Date: Sun, 3 May 2020 20:46:05 +0200
Message-ID: <CANVnVY+UoZFLasnnJfBw_uPo8N862bFy0G4PykNToZ0hfszLiw@mail.gmail.com>
To: "stivstivsti ." <stiv.yakovenko@gmail.com>, 1450@bugs.x2go.org
Cc: submit@bugs.x2go.org
Content-Type: multipart/related; boundary="0000000000004487ca05a4c2d5a2"
[Message part 1 (text/plain, inline)]
Well, this kind of problem should not happen nowadays. So I am very
interested how this could happen. I ask you to provide some more

1. please run setxkbmap -query both outside and inside the (broken) session
and report the output.

1b) If the output differs, you can try to run (inside the session)
setxkbmap -rules ... -model ... -layout ... -variant ... -option ...
with the values the _local_ setxkmap -query reports. Does that help?

2. what kind of session are you using? Are you accessing a running X
server? Is this happening for all kinds of sessions?

3. What desktop environment are you using locally?

4. What's the keyboard configuration in the x2goclient session

5. is this happening for new sessions, on reconnect or both?

6. what's the version of nxagent on the server (run 'xprop -root | grep NX'
inside the session)?

7. please post the content of /etc/x2go/x2goagent.options

8. on the server you have ~/.x2go/C-something, which is the session dir.
You'll find a file called "options" there. Please post that file. You can
also scan the session.log for hints what might be going wrong with the
keyboard configuration.

9. Has this worked before for you?


On Sun, May 3, 2020 at 2:13 PM stivstivsti . <stiv.yakovenko@gmail.com>

> Package: x2goclient
> Version:
> I am connecting from Ubuntu Linux 18 to another Ubuntu linux machine with
> x2go. Connection works, but some keys don't, especially arrow keys. When I
> press up arrow, it starts screen capture:
> [image: image.png]
> I tried some recipes from this question:
> https://serverfault.com/questions/582552/x2go-arrow-key-is-not-working-properly but
> they don't help. *setxkbmap us -print | xkbcomp - $DISPLAY* -- doesn't
> fix the problem. I tried to play with keyboard settings here:
> [image: image.png]
> but it doesn't help also. How can I fix it?
> I've followed instruction from wiki.x2go.org updating x2goclient to
> and x2goserver to
> The problem is still there.
> _______________________________________________
> x2go-dev mailing list
> x2go-dev@lists.x2go.org
> https://lists.x2go.org/listinfo/x2go-dev
[Message part 2 (text/html, inline)]
[image.png (image/png, inline)]
[image.png (image/png, inline)]

Send a report that this bug log contains spam.

X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Jun 16 21:08:16 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.