X2Go Bug report logs - #1450
Fwd: Arrow keys randomly stop working in x2go

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: "stivstivsti ." <stiv.yakovenko@gmail.com>

Date: Mon, 30 Mar 2020 12:50:01 UTC

Severity: normal

Found in version 4.1.2.2

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1450: Fwd: Arrow keys randomly stop working in x2go
Reply-To: "stivstivsti ." <stiv.yakovenko@gmail.com>, 1450@bugs.x2go.org
Resent-From: "stivstivsti ." <stiv.yakovenko@gmail.com>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Mon, 30 Mar 2020 12:50:01 +0000
Resent-Message-ID: <handler.1450.B.158557237415935@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: report 1450
X-X2Go-PR-Package: x2goclient
X-X2Go-PR-Keywords: 
Received: via spool by submit@bugs.x2go.org id=B.158557237415935
          (code B); Mon, 30 Mar 2020 12:50:01 +0000
Received: (at submit) by bugs.x2go.org; 30 Mar 2020 12:46:14 +0000
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-0.1 required=3.0 tests=BAYES_40,DKIM_SIGNED,
	DKIM_VALID,DKIM_VALID_AU,FREEMAIL_FROM,HTML_IMAGE_ONLY_32,
	HTML_IMAGE_RATIO_02,HTML_MESSAGE,SPF_HELO_NONE,URIBL_BLOCKED
	autolearn=ham autolearn_force=no version=3.4.2
Received: from mail-lj1-x22f.google.com (mail-lj1-x22f.google.com [IPv6:2a00:1450:4864:20::22f])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id D67845DA92
	for <submit@bugs.x2go.org>; Mon, 30 Mar 2020 14:46:11 +0200 (CEST)
Received: by mail-lj1-x22f.google.com with SMTP id g12so17939289ljj.3
        for <submit@bugs.x2go.org>; Mon, 30 Mar 2020 05:46:11 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20161025;
        h=mime-version:references:in-reply-to:from:date:message-id:subject:to;
        bh=X4eJfVp1W+kVmFCuVBvwGRGrQmVZp80jAfFcqtfLeH0=;
        b=ZWc9m3jgvGNMyauEb3cTkP47y2K4rKbHJjtej0o8cz/zezyJcAQYZF7cqWntLdGcnB
         RyHBH6K6xqOkiUc1IdrHoQeIw/DKBqAkoOY0dlzWIYUewM7MswMQcgQn/AdkTXneOD3N
         N/3nC9qqklXILQWKAKM89hNZxbfOas9rHUxeHUwmWeNZzC4ssNfxcAq4DPYFRqjZ487O
         9Whk3gm/mAZjWQSR0PuSjUTaYRXsEcX8qCUNwVbEhFrPRGM2jl0S6CGU1Puuc+KdkopF
         W7zihGgFLgWQYXJYbprlvAIzRHEUc/YN3R7iJX/UkxVXYQFHOKxD8buHj1W/AfR8Rtfo
         zsJA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20161025;
        h=x-gm-message-state:mime-version:references:in-reply-to:from:date
         :message-id:subject:to;
        bh=X4eJfVp1W+kVmFCuVBvwGRGrQmVZp80jAfFcqtfLeH0=;
        b=CkMn+xcTeAyvHnkH2s2dAellrFZeiN6MmW45ayfBt6qDHjU1u3LFV3EDmG7fah0HOn
         TENWhGyrZlybPtf76CpKAldEJjwYs2PGxVoBm1YMJsv2rEKTE2zsFq3zuovxsOXTeTNG
         Ps8i3+J1NZzCKdb5Gto7Ue+y5YUv6VDigtQn+ItbbUAKFZIhzr0GQitLJn6CcuXCGXDY
         7I1197la4xG9IRQlGZRNKiZUuaNPcr/3S2RTxSsWlhQ9cvBm9+1713Jf1CvW1kSbEF8w
         nfCLjpYBeis5Aitg1DYcOxOTl/S0FtLKZvLgYSbmWD57gXCQIp6AJi2RyqFQd4ROELM9
         Ye6g==
X-Gm-Message-State: AGi0PuYPhuuYYdviG0e/ysBj0fSamYQpbLv/oNwjxvtYnKiHGhgjCFEp
	YhQG48p3h6yHfOqy/YbctDiNJto3peLASZMVok5655EvvI5sbw==
X-Google-Smtp-Source: APiQypI7iv297t/5E5c3iq3ul7SkaozSvNRfMvZupbi1KdJy0b/CO4iQ8HXpSpNDH0N5lyWeUV1i78DcOmmZE20wDf0=
X-Received: by 2002:a2e:8e98:: with SMTP id z24mr6867851ljk.23.1585572370361;
 Mon, 30 Mar 2020 05:46:10 -0700 (PDT)
MIME-Version: 1.0
In-Reply-To: <CACkPNmhg5Rk54pt6PJPabH5PSQu0dRD2f_kWeFihDk4-xhktKw@mail.gmail.com>
From: "stivstivsti ." <stiv.yakovenko@gmail.com>
Date: Mon, 30 Mar 2020 19:45:59 +0700
Message-ID: <CACkPNmjTE8PX8f0a8x+qqubTxToujdJcjfn3p4YBFZupzCX6ig@mail.gmail.com>
To: submit@bugs.x2go.org
Content-Type: multipart/related; boundary="000000000000e7f51605a211d5f7"
[Message part 1 (text/plain, inline)]
Package: x2goclient
Version: 4.1.2.2


I am connecting from Ubuntu Linux 18 to another Ubuntu linux machine with
x2go. Connection works, but some keys don't, especially arrow keys. When I
press up arrow, it starts screen capture:

[image: image.png]

I tried some recipes from this question:
https://serverfault.com/questions/582552/x2go-arrow-key-is-not-working-properly
but
they don't help. *setxkbmap us -print | xkbcomp - $DISPLAY* -- doesn't fix
the problem. I tried to play with keyboard settings here:

[image: image.png]

but it doesn't help also. How can I fix it?

I've followed instruction from wiki.x2go.org updating x2goclient to
4.1.2.2-0~1913~ubuntu18.04.1 and x2goserver to
4.1.0.3-0~1708~ubuntu18.04.1. The problem is still there.
[Message part 2 (text/html, inline)]
[image.png (image/png, inline)]
[image.png (image/png, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Oct 24 22:22:46 2021; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.