X2Go Bug report logs - #1413
Matlab freezing when disconnecting x2go session

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: "Lattanzi, Riccardo" <Riccardo.Lattanzi@nyulangone.org>

Date: Mon, 28 Oct 2019 22:10:02 UTC

Severity: normal

Found in version 4.1.2.1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1413; Package x2goserver. (Mon, 28 Oct 2019 22:10:02 GMT) (full text, mbox, link).


Acknowledgement sent to "Lattanzi, Riccardo" <Riccardo.Lattanzi@nyulangone.org>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 28 Oct 2019 22:10:02 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

From: "Lattanzi, Riccardo" <Riccardo.Lattanzi@nyulangone.org>
To: "submit@bugs.x2go.org" <submit@bugs.x2go.org>
Subject: Matlab freezing when disconnecting x2go session
Date: Mon, 28 Oct 2019 22:05:07 +0000
[Message part 1 (text/plain, inline)]
Package: x2goserver
Version: 4.1.2.1
Server: Ubuntu 18.04.2
Client: Mac OS 10.13.6

I am using x2go to access a Linux server on which I run Matlab. I run simulations that can last over a week so I need to be able to continuously run Matlab.
When I disconnect the x2go session, after few minutes Matlab hibernates, meaning that it freezes, and then would starts again from where it left as soon as I reconnect the x2go session.
So nothing is lost and nothing crashes, but this behavior prevents me to run programs overnight, which is critical for my work.

Matlab normally hibernates when a computer goes to sleep mode, but should not when am x2go session is disconnected (my server is prevented from going into sleep mode, so it is truly a problem of the x2go connection). In fact, Matlab runs on the server, so it shouldn’t even care if I close x2go client. VPN does not have a similar problem, but I cannot use it on my server. I think this is a serious bug, unless there is a solution or workaround, which I currently do not see.

Please let me know, thanks!

Riccardo
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Nov 17 04:21:00 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.