X2Go Bug report logs - #1354
Auto-update on CentOS did not work for nx-libs.x86_64 0:3.5.99.16-1.el7

Package: nx-libs; Maintainer for nx-libs is X2Go Developers <x2go-dev@lists.x2go.org>;

Reported by: Franz Lückl <office@nextitlevel.de>

Date: Tue, 11 Dec 2018 11:20:02 UTC

Severity: normal

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 11 Dec 2018 11:16:03 +0000
From office@nextitlevel.de  Tue Dec 11 12:16:02 2018
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on
	ymir.das-netzwerkteam.de
X-Spam-Level: *
X-Spam-Status: No, score=1.8 required=3.0 tests=BAYES_50,FROM_EXCESS_BASE64,
	HTML_MESSAGE autolearn=no autolearn_force=no version=3.4.2
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id A35395DAEF
	for <submit@bugs.x2go.org>; Tue, 11 Dec 2018 12:16:02 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id 9YINv9lO1riK for <submit@bugs.x2go.org>;
	Tue, 11 Dec 2018 12:15:56 +0100 (CET)
X-Greylist: delayed 315 seconds by postgrey-1.35 at ymir.das-netzwerkteam.de; Tue, 11 Dec 2018 12:15:55 CET
Received: from mail.nextitlevel.com (mail.nextitlevel.com [78.142.141.165])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id DA2735DA96
	for <submit@bugs.x2go.org>; Tue, 11 Dec 2018 12:15:55 +0100 (CET)
Received: from VSRV05.nit.local (10.99.1.15) by vSRV05.nit.local (10.99.1.15)
 with Microsoft SMTP Server (TLS) id 15.0.1210.3; Tue, 11 Dec 2018 12:10:40
 +0100
Received: from VSRV05.nit.local ([fe80::c8f1:b017:e4f:5b78]) by
 vSRV05.nit.local ([fe80::c8f1:b017:e4f:5b78%15]) with mapi id 15.00.1210.000;
 Tue, 11 Dec 2018 12:10:40 +0100
From: Franz Lückl <office@nextitlevel.de>
To: "submit@bugs.x2go.org" <submit@bugs.x2go.org>
Subject: Auto-update on CentOS did not work for nx-libs.x86_64
 0:3.5.99.16-1.el7 
Thread-Topic: Auto-update on CentOS did not work for nx-libs.x86_64
 0:3.5.99.16-1.el7 
Thread-Index: AdSRQiXslPA2e+yFQnOLJflIs5SIfw==
Date: Tue, 11 Dec 2018 11:10:39 +0000
Message-ID: <1a67dfd3a4dc4529abb4897d7a42c1b2@vSRV05.nit.local>
Accept-Language: de-DE, en-US
Content-Language: de-DE
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-ms-exchange-transport-fromentityheader: Hosted
x-originating-ip: [194.230.159.182]
Content-Type: multipart/alternative;
	boundary="_000_1a67dfd3a4dc4529abb4897d7a42c1b2vSRV05nitlocal_"
MIME-Version: 1.0
[Message part 1 (text/plain, inline)]
Package: nx-libs
Version: 3.5.99.16-1.el7.x86_64

On this system auto-update for CentOS is enabled.  The system is CentOS Linux release 7.5.1804.
For some unknown reason auto-update did not work on this system.  It worked on other systems.

Here are the errors when updating with yum:
---> Package nx-libs.x86_64 0:3.5.99.16-1.el7 will be updated
--> Processing Dependency: nx-libs(x86-64) = 3.5.99.16-1.el7 for package: libNX_X11-3.5.99.16-1.el7.x86_64
--> Processing Dependency: nx-libs(x86-64) = 3.5.99.16-1.el7 for package: libXcomp-3.5.99.16-1.el7.x86_64
--> Processing Dependency: nx-libs(x86-64) = 3.5.99.16-1.el7 for package: libXcompshad-3.5.99.16-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: libXcompshad-3.5.99.16-1.el7.x86_64 (@epel)
           Requires: nx-libs(x86-64) = 3.5.99.16-1.el7
           Removing: nx-libs-3.5.99.16-1.el7.x86_64 (@epel)
               nx-libs(x86-64) = 3.5.99.16-1.el7
           Updated By: nx-libs-3.5.99.17-0.0build1.1.git20181127.3188.main.el7.x86_64 (x2go-release-epel)
               nx-libs(x86-64) = 3.5.99.17-0.0build1.1.git20181127.3188.main.el7
Error: Package: libXcomp-3.5.99.16-1.el7.x86_64 (@epel)
           Requires: nx-libs(x86-64) = 3.5.99.16-1.el7
           Removing: nx-libs-3.5.99.16-1.el7.x86_64 (@epel)
               nx-libs(x86-64) = 3.5.99.16-1.el7
           Updated By: nx-libs-3.5.99.17-0.0build1.1.git20181127.3188.main.el7.x86_64 (x2go-release-epel)
               nx-libs(x86-64) = 3.5.99.17-0.0build1.1.git20181127.3188.main.el7
Error: Package: libNX_X11-3.5.99.16-1.el7.x86_64 (@epel)
           Requires: nx-libs(x86-64) = 3.5.99.16-1.el7
           Removing: nx-libs-3.5.99.16-1.el7.x86_64 (@epel)
               nx-libs(x86-64) = 3.5.99.16-1.el7
           Updated By: nx-libs-3.5.99.17-0.0build1.1.git20181127.3188.main.el7.x86_64 (x2go-release-epel)
               nx-libs(x86-64) = 3.5.99.17-0.0build1.1.git20181127.3188.main.el7

The solution to this is to uninstall all of x2go and then reinstalling the x2go-server.

Have a nice day,
Franz Lückl
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Apr 21 06:08:00 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.