X2Go Bug report logs - #1354
Auto-update on CentOS did not work for nx-libs.x86_64 0:3.5.99.16-1.el7

Package: nx-libs; Maintainer for nx-libs is X2Go Developers <x2go-dev@lists.x2go.org>;

Reported by: Franz Lückl <office@nextitlevel.de>

Date: Tue, 11 Dec 2018 11:20:02 UTC

Severity: normal

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1354; Package nx-libs. (Tue, 11 Dec 2018 11:20:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Franz Lückl <office@nextitlevel.de>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>.

Your message had a Version: pseudo-header with an invalid package version:

3.5.99.16-1.el7.x86_64

please either use found or fixed to the control server with a correct version, or reply to this report indicating the correct version so the maintainer (or someone else) can correct it for you.

(Tue, 11 Dec 2018 11:20:03 GMT) Full text and rfc822 format available.


Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Franz Lückl <office@nextitlevel.de>
To: "submit@bugs.x2go.org" <submit@bugs.x2go.org>
Subject: Auto-update on CentOS did not work for nx-libs.x86_64 0:3.5.99.16-1.el7
Date: Tue, 11 Dec 2018 11:10:39 +0000
[Message part 1 (text/plain, inline)]
Package: nx-libs
Version: 3.5.99.16-1.el7.x86_64

On this system auto-update for CentOS is enabled.  The system is CentOS Linux release 7.5.1804.
For some unknown reason auto-update did not work on this system.  It worked on other systems.

Here are the errors when updating with yum:
---> Package nx-libs.x86_64 0:3.5.99.16-1.el7 will be updated
--> Processing Dependency: nx-libs(x86-64) = 3.5.99.16-1.el7 for package: libNX_X11-3.5.99.16-1.el7.x86_64
--> Processing Dependency: nx-libs(x86-64) = 3.5.99.16-1.el7 for package: libXcomp-3.5.99.16-1.el7.x86_64
--> Processing Dependency: nx-libs(x86-64) = 3.5.99.16-1.el7 for package: libXcompshad-3.5.99.16-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: libXcompshad-3.5.99.16-1.el7.x86_64 (@epel)
           Requires: nx-libs(x86-64) = 3.5.99.16-1.el7
           Removing: nx-libs-3.5.99.16-1.el7.x86_64 (@epel)
               nx-libs(x86-64) = 3.5.99.16-1.el7
           Updated By: nx-libs-3.5.99.17-0.0build1.1.git20181127.3188.main.el7.x86_64 (x2go-release-epel)
               nx-libs(x86-64) = 3.5.99.17-0.0build1.1.git20181127.3188.main.el7
Error: Package: libXcomp-3.5.99.16-1.el7.x86_64 (@epel)
           Requires: nx-libs(x86-64) = 3.5.99.16-1.el7
           Removing: nx-libs-3.5.99.16-1.el7.x86_64 (@epel)
               nx-libs(x86-64) = 3.5.99.16-1.el7
           Updated By: nx-libs-3.5.99.17-0.0build1.1.git20181127.3188.main.el7.x86_64 (x2go-release-epel)
               nx-libs(x86-64) = 3.5.99.17-0.0build1.1.git20181127.3188.main.el7
Error: Package: libNX_X11-3.5.99.16-1.el7.x86_64 (@epel)
           Requires: nx-libs(x86-64) = 3.5.99.16-1.el7
           Removing: nx-libs-3.5.99.16-1.el7.x86_64 (@epel)
               nx-libs(x86-64) = 3.5.99.16-1.el7
           Updated By: nx-libs-3.5.99.17-0.0build1.1.git20181127.3188.main.el7.x86_64 (x2go-release-epel)
               nx-libs(x86-64) = 3.5.99.17-0.0build1.1.git20181127.3188.main.el7

The solution to this is to uninstall all of x2go and then reinstalling the x2go-server.

Have a nice day,
Franz Lückl
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Mon Jan 21 22:43:06 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.