X2Go Bug report logs - #1132
Color issue with x2go not present in NX with certain applications

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: "Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc]" <brian.a.town@nasa.gov>

Date: Mon, 9 Jan 2017 14:30:01 UTC

Severity: normal

Found in version 4.0.5.2

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1132: [X2Go-Dev] Bug#1132: Bug#1132: Color issue with x2go not present in NX with certain applications
Reply-To: "Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc]" <brian.a.town@nasa.gov>, 1132@bugs.x2go.org
Resent-From: "Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc]" <brian.a.town@nasa.gov>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Tue, 24 Jan 2017 13:40:02 +0000
Resent-Message-ID: <handler.1132.B1132.148526492323250@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 1132
X-X2Go-PR-Package: x2goclient
X-X2Go-PR-Keywords: 
Received: via spool by 1132-submit@bugs.x2go.org id=B1132.148526492323250
          (code B ref 1132); Tue, 24 Jan 2017 13:40:02 +0000
Received: (at 1132) by bugs.x2go.org; 24 Jan 2017 13:35:23 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=3.0 tests=BAYES_00,URIBL_BLOCKED
	autolearn=ham version=3.3.2
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id D5D2E3CDDB
	for <1132@bugs.x2go.org>; Tue, 24 Jan 2017 14:35:21 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id XNxdw9yln45G for <1132@bugs.x2go.org>;
	Tue, 24 Jan 2017 14:35:15 +0100 (CET)
X-Greylist: delayed 526 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Tue, 24 Jan 2017 14:35:12 CET
Received: from ndmsvnpf101.ndc.nasa.gov (NDMSVNPF101.ndc.nasa.gov [198.117.0.151])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 0CD9B3CDDA
	for <1132@bugs.x2go.org>; Tue, 24 Jan 2017 14:35:11 +0100 (CET)
X-Comment: SPF check N/A for local connections - client-ip=198.117.0.68; helo=ndmsppt103.ndc.nasa.gov; envelope-from=brian.a.town@nasa.gov; receiver=1132@bugs.x2go.org 
Received: from ndmsppt103.ndc.nasa.gov (ndmsppt103.ndc.nasa.gov [198.117.0.68])
	by ndmsvnpf101.ndc.nasa.gov (Postfix) with ESMTP id D0EB240149A9;
	Tue, 24 Jan 2017 07:26:06 -0600 (CST)
Received: from pps.filterd (ndmsppt103.ndc.nasa.gov [127.0.0.1])
	by ndmsppt103.ndc.nasa.gov (8.16.0.20/8.16.0.20) with SMTP id v0ODGBoh027972;
	Tue, 24 Jan 2017 07:26:06 -0600
Received: from ndmscht104.ndc.nasa.gov (ndmscht104-pub.ndc.nasa.gov [198.117.0.204])
	by ndmsppt103.ndc.nasa.gov with ESMTP id 285qja24mt-1;
	Tue, 24 Jan 2017 07:26:06 -0600
Received: from NDMSMBX301.ndc.nasa.gov ([169.254.4.150]) by
 NDMSCHT104.ndc.nasa.gov ([198.117.0.174]) with mapi id 14.03.0319.002; Tue,
 24 Jan 2017 07:26:06 -0600
From: "Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc]"
	<brian.a.town@nasa.gov>
To: "uli42@gmx.de" <uli42@gmx.de>, "1132@bugs.x2go.org" <1132@bugs.x2go.org>
Thread-Topic: [X2Go-Dev] Bug#1132: Bug#1132: Color issue with x2go not
 present in NX with certain applications
Thread-Index: AQHSa07li5JG08tI6kKxoSg9bAyrKqFHs2yA
Date: Tue, 24 Jan 2017 13:26:05 +0000
Message-ID: <2565EDE93CACC9478E32CA6681CC015E0ABA1327@NDMSMBX301.ndc.nasa.gov>
References: <2565EDE93CACC9478E32CA6681CC015E0AB82718@NDMSMBX301.ndc.nasa.gov>
 <00aced92-99b4-ce71-b6ff-25ed36e89bba@baur-itcs.de>
 <2565EDE93CACC9478E32CA6681CC015E0AB82811@NDMSMBX301.ndc.nasa.gov>
 <CANVnVYLU0PdS0FS72vFt1Aa2m8zmARinnTN7xX4Zx89ff=BtiQ@mail.gmail.com>
In-Reply-To: <CANVnVYLU0PdS0FS72vFt1Aa2m8zmARinnTN7xX4Zx89ff=BtiQ@mail.gmail.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
x-originating-ip: [198.119.59.10]
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64
MIME-Version: 1.0
X-Proofpoint-Virus-Version: vendor=fsecure engine=2.50.10432:,, definitions=2017-01-24_08:,,
 signatures=0
My apologies but not seeing this sooner, we were told by the software devs that the program does source the rgb.txt file for color values. I must have completely missed this email somehow but will test out what was said.

Brian Town
Landsat 8
Goddard Space Flight Center



-----Original Message-----
From: Ulrich Sibiller [mailto:ulrich.sibiller@gmail.com] 
Sent: Tuesday, January 10, 2017 9:34 AM
To: Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc] <brian.a.town@nasa.gov>; 1132@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1132: Bug#1132: Color issue with x2go not present in NX with certain applications

On Mon, Jan 9, 2017 at 5:58 PM, Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc] <brian.a.town@nasa.gov> wrote:
> Darn was hoping to have won the prize! Haha
>
> I have tested a few different compression/slider options but still going through and see what each option gives me in. The software being used is open source for NASA missions I believe but closed outside of that, so not sure what all I can share on that just yet, I'll have to check.
>
> I did notice that selecting the "local desktop" option via the client on x2go provides me with the correct color, however it also produces a great deal of lag. Is the local desktop option doing basic VNC connection or Xforwarding? I couldn't find any information on that.
>
> I'm utilizing x2go in conjunction with a LTSP set up. If I use basic Xforwarding through the terminal I get the colors I need displayed properly. I'm not sure exactly where it's hanging up through the x2go client window.
>
> For the unix_kde_depth option, is there a setting to have it exceed 24? Some blogs I've noticed people their session.log files showing unix_kde_depth32 however mine is always at 24 and unsure where that setting would be located at.


Color issues might have to do with the rgb file not being found (or being incomplete). IIRC we have fixed something in the coming 3.6.x release in this regard. Please test if the problem persists with current nx beta, http://wiki.x2go.org/doku.php/doc:howto:nx-libs-betatesting.

You could also check if one of these rgb files exist (add .txt extension). They are searched in this order:

static char* nxAltRgbPaths[] = {"/etc/x2go/rgb", \
                                "/usr/share/x2go/rgb", \
                                "/usr/local/share/x2go/rgb", \
                                "/etc/nxagent/rgb", \
                                "/usr/share/nx/rgb", \
                                "/usr/local/share/nx/rgb", \
                                "/usr/NX/share/rgb", \
                                "/usr/share/X11/rgb", \
                                "/etc/X11/rgb"};


So if you find one compare it to the one you real X server is using (should be visible in /var/log/Xorg.0.log).

Or maybe, instead of checking all this: simply copy the rgb.txt from your X server to /etc/x2go/rgb.txt and retry.


Uli

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed May 29 08:08:18 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.