X2Go Bug report logs - #1072
X2Go Client: top 24 pixels in fullscreen session do not respond to mouse clicks

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Chris Martin <cmart.cyverse@gmail.com>

Date: Sat, 13 Aug 2016 03:30:02 UTC

Severity: normal

Found in version 4.0.5.1

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1072: [X2Go-Dev] Bug#1072: X2Go Client: top 24 pixels in fullscreen session do not respond to mouse clicks
Reply-To: Sylvain Cuaz <sylvain@ilm-informatique.fr>, 1072@bugs.x2go.org
Resent-From: Sylvain Cuaz <sylvain@ilm-informatique.fr>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Tue, 09 Feb 2021 14:05:02 +0000
Resent-Message-ID: <handler.1072.B1072.161287934123970@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 1072
X-X2Go-PR-Package: x2goclient
X-X2Go-PR-Keywords: 
References: <CAKsO3SX4Tz_PpHy97EgkOqWJRn7JT9bGkMy6tj4brObz2muyeg@mail.gmail.com>
Received: via spool by 1072-submit@bugs.x2go.org id=B1072.161287934123970
          (code B ref 1072); Tue, 09 Feb 2021 14:05:02 +0000
Received: (at 1072) by bugs.x2go.org; 9 Feb 2021 14:02:21 +0000
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on
	ymir.das-netzwerkteam.de
X-Spam-Level: **
X-Spam-Status: No, score=2.2 required=3.0 tests=BAYES_05,FAKE_REPLY_A1,
	RCVD_IN_MSPIKE_H3,RCVD_IN_MSPIKE_WL,SPF_HELO_NONE autolearn=no
	autolearn_force=no version=3.4.2
Received: from 19.mo4.mail-out.ovh.net (19.mo4.mail-out.ovh.net [87.98.179.66])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 722505DACE
	for <1072@bugs.x2go.org>; Tue,  9 Feb 2021 15:02:17 +0100 (CET)
Received: from player774.ha.ovh.net (unknown [10.108.20.179])
	by mo4.mail-out.ovh.net (Postfix) with ESMTP id 3BB3E26432A
	for <1072@bugs.x2go.org>; Tue,  9 Feb 2021 15:02:16 +0100 (CET)
Received: from ilm-informatique.fr (239.252.82.79.rev.sfr.net [79.82.252.239])
	(Authenticated sender: sylvain@ilm-informatique.fr)
	by player774.ha.ovh.net (Postfix) with ESMTPSA id C2B491AF7A514
	for <1072@bugs.x2go.org>; Tue,  9 Feb 2021 14:02:13 +0000 (UTC)
Authentication-Results:garm.ovh; auth=pass (GARM-101G0047181ee84-f517-4b57-8085-cb6a70cbda93,
                    570F0B1C6A415B2DB98E39377C13912C2E193CE0) smtp.auth=sylvain@ilm-informatique.fr
X-OVh-ClientIp:79.82.252.239
To: 1072@bugs.x2go.org
From: Sylvain Cuaz <sylvain@ilm-informatique.fr>
Message-ID: <b247ede2-ee93-911f-2f34-76348ca8607c@ilm-informatique.fr>
Date: Tue, 9 Feb 2021 15:02:10 +0100
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101
 Thunderbird/68.10.0
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 7bit
Content-Language: en-GB
X-Ovh-Tracer-Id: 10801602233260257087
X-VR-SPAMSTATE: OK
X-VR-SPAMSCORE: 0
X-VR-SPAMCAUSE: gggruggvucftvghtrhhoucdtuddrgeduledrheehgdeiudcutefuodetggdotefrodftvfcurfhrohhfihhlvgemucfqggfjpdevjffgvefmvefgnecuuegrihhlohhuthemucehtddtnecunecujfgurhepvffhuffkffgfgggtgfesthejredttdefjeenucfhrhhomhepufihlhhvrghinhcuvehurgiiuceoshihlhhvrghinhesihhlmhdqihhnfhhorhhmrghtihhquhgvrdhfrheqnecuggftrfgrthhtvghrnhepvedufeegtdelleefgedugedtgedvveeugeffgfefgfehkefgueduleejudeijeehnecukfhppedtrddtrddtrddtpdejledrkedvrddvhedvrddvfeelnecuvehluhhsthgvrhfuihiivgeptdenucfrrghrrghmpehmohguvgepshhmthhpqdhouhhtpdhhvghlohepphhlrgihvghrjeejgedrhhgrrdhovhhhrdhnvghtpdhinhgvtheptddrtddrtddrtddpmhgrihhlfhhrohhmpehshihlvhgrihhnsehilhhmqdhinhhfohhrmhgrthhiqhhuvgdrfhhrpdhrtghpthhtohepuddtjedvsegsuhhgshdrgidvghhordhorhhg
Hi,

This is still a problem on Ubuntu 20.04 with X2Go Client 4.1.2.2 connecting to XFCE through 
x2goserver 4.1.0.4-0~1914~ubuntu16.04.1

If I put both my local gnome panel and the remote XFCE panel at the top, then the top pixels in 
remote desktop cannot be clicked (tool tips work).

If I put my local gnome panel to the left, then only the top left corner pixels of the remote top 
panel have the problem (which is where they intersect).

If I switch my local desktop environment to XFCE, no matter where I put the panels, it always work.

Cheers.

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Mon Jan 30 01:47:41 2023; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.