X2Go Bug report logs - #1094
When connected to a x2go server that has nVidia's binary drivers most software will segfault.

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: zingmars <zingmars@playgineering.com>

Date: Tue, 27 Sep 2016 17:40:01 UTC

Severity: normal

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox):

Received: (at submit) by bugs.x2go.org; 27 Sep 2016 17:37:56 +0000
From zingmars@playgineering.com  Tue Sep 27 19:37:56 2016
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: *
X-Spam-Status: No, score=1.3 required=3.0 tests=BAYES_50,DKIM_SIGNED,
	DKIM_VALID,RCVD_IN_SORBS_SPAM,URIBL_BLOCKED autolearn=no version=3.3.2
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id CBD545DA95
	for <submit@bugs.x2go.org>; Tue, 27 Sep 2016 19:37:55 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id eUCYv9B-g6KY for <submit@bugs.x2go.org>;
	Tue, 27 Sep 2016 19:37:49 +0200 (CEST)
Received: from mail-lf0-f47.google.com (mail-lf0-f47.google.com [209.85.215.47])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id E88CF5DA94
	for <submit@bugs.x2go.org>; Tue, 27 Sep 2016 19:37:48 +0200 (CEST)
Received: by mail-lf0-f47.google.com with SMTP id l131so30888667lfl.2
        for <submit@bugs.x2go.org>; Tue, 27 Sep 2016 10:37:48 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=playgineering-com.20150623.gappssmtp.com; s=20150623;
        h=to:from:subject:message-id:date:user-agent:mime-version;
        bh=FW9VQ6OKdT+5MPQDIpjeFpYURSmAHT9saceXqlg2uC0=;
        b=xC/+klyXpCv6itX/jHmBbJUOWK81At54X6WycLozs0uSEGhxflmWgb7LkgWRlqK+In
         gU+8ZnYYnV4BpVymUDW2H9x3NWI9hRPf9+ByvxO19yQmTuSg37Wc/MVQilPCryLmh+bl
         JzjUFeojnWX25VZG2RlF13ajrhS6B5ArOYe5C9cVjlfFiDnEELfOUf2jGXfrM+gRzzyU
         h0NojMD1x2t1lMrPgMhV4KW5ULB+Z9Ko4Gt3aNqX+u9fTB0cImbZDoKE5YUH9bYvRSzm
         Om3FlREunx18qp5NQrwBLRFwSvBje/ULH1YHjwsTdIxH3v50mBdOKIGYZkM/c2yhbh17
         i/yQ==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20130820;
        h=x-gm-message-state:to:from:subject:message-id:date:user-agent
         :mime-version;
        bh=FW9VQ6OKdT+5MPQDIpjeFpYURSmAHT9saceXqlg2uC0=;
        b=Nn0JvgD2nWhp0Z8ej6tpdShJrV7vkG4dTbb78+CmTOTCI/XH9l1DtWBKt+kNffgmQd
         Zx1qpcCR6MtEIZS6/EaQHkBV4OWaFatmsFiBAtiEGNCUkctuM94j4m6JvvnVh/EGgQDO
         Xc4Ys/k4WRDCwH9MyEwfTQW+pV3gLaRb+2e5pxch0yyhzE0WbzdCgZ2iXX9QEeu5gprm
         MKhz6EDo4vNF8/uOWu0owKSBtEHS9HyjLq+t9r6sXDsyWB+0R2Kkjwyg9TLH4ChjIUl4
         QKUYbrUAEbN8M2c/2dJ871AOnt+/puu/eE83TaPrA99x76nFUJJN9nW0iOUcEAECRxUv
         7jJg==
X-Gm-Message-State: AA6/9RkYfedFzcCkLfycejXAj+HaODGh/IfWcxb5QeT3nBuLFKAzhRI+vqiZo8ON8qFplV/n
X-Received: by 10.25.18.21 with SMTP id h21mr950369lfi.115.1474997867912;
        Tue, 27 Sep 2016 10:37:47 -0700 (PDT)
Received: from [192.168.1.175] ([91.142.12.15])
        by smtp.gmail.com with ESMTPSA id h41sm587608lji.28.2016.09.27.10.37.46
        for <submit@bugs.x2go.org>
        (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
        Tue, 27 Sep 2016 10:37:47 -0700 (PDT)
To: submit@bugs.x2go.org
From: zingmars <zingmars@playgineering.com>
Subject: When connected to a x2go server that has nVidia's binary drivers most
 software will segfault.
Message-ID: <ce36625b-ec5d-44b7-26f3-36cc9076cd45@playgineering.com>
Date: Tue, 27 Sep 2016 20:37:23 +0300
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101
 Thunderbird/45.3.0
MIME-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha256;
 protocol="application/pgp-signature";
 boundary="h0TfwKGDQWFKjV34UW1HpNwOw97ofUlCN"
[Message part 1 (text/plain, inline)]
Package: x2goserver

Version: 4.0.1.19


When I connect to a x2go server that has an nVidia GPU using nVidia's
binary drivers most software (such as Firefox, Thunderbird, Cheese,
Transmission GUI etc.) will segfault on launch.

This can seemingly be fixed by setting the LD_LIBRARY_PATH variable to
wherever the nVidia drivers are (i.e. for nVidia-361 drivers just run
LD_LIBRARY_PATH=/usr/lib/nvidia-361" in the server's terminal.
Alternatively it seems that you can switch to the Noveau driver and the
issue won't occur, but this might not always be an option.

There's also a thread on ubuntuforums
(https://ubuntuforums.org/showthread.php?t=2337814) that also has a
video of this bug in action.

I'm using Ubuntu 16.04 with MATE.

[m7g2NXy.png (image/png, attachment)]
[signature.asc (application/pgp-signature, attachment)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Jul 23 02:54:52 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.