X2Go Bug report logs - #939
downgrading libssh4 required when installing x2goclient on opensuse tumbleweed

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Nikolai Maziashvili <nikolai@cyclinggeorgian.com>

Date: Fri, 4 Sep 2015 11:35:01 UTC

Severity: normal

Found in version 4.0.2.1-1.7

Done: Mihai Moldovan <ionic@ionic.de>

Bug is archived. No further changes may be made.

Full log


🔗 View this message in rfc822 format

MIME-Version: 1.0
X-Mailer: MIME-tools 5.502 (Entity 5.502)
X-Loop: owner@bugs.x2go.org
From: owner@bugs.x2go.org (X2Go Bug Tracking System)
Subject: Bug#939 closed by Mihai Moldovan <ionic@ionic.de> (Re: [X2Go-Dev]
 downgrading libssh4 required when installing x2goclient on opensuse
 tumbleweed)
Message-ID: <handler.939.b939.144319973227572.notifdone@bugs.x2go.org>
References: <56057AF2.3090203@ionic.de>
X-X2go-PR-Message: they-closed 939
X-X2go-PR-Package: x2goclient
X-X2go-PR-Source: x2goclient
Date: Fri, 25 Sep 2015 16:50:02 +0000
Content-Type: multipart/mixed; boundary="----------=_1443199802-27784-0"
[Message part 1 (text/plain, inline)]
This is an automatic notification regarding your Bug report
which was filed against the x2goclient package:

#939: downgrading libssh4 required when installing x2goclient on opensuse tumbleweed

It has been closed by Mihai Moldovan <ionic@ionic.de>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mihai Moldovan <ionic@ionic.de> by
replying to this email.


-- 
939: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=939
X2Go Bug Tracking System
Contact owner@bugs.x2go.org with problems
[Message part 2 (message/rfc822, inline)]
From: Mihai Moldovan <ionic@ionic.de>
To: Nikolai Maziashvili <nikolai@cyclinggeorgian.com>, 939@bugs.x2go.org
Subject: Re: [X2Go-Dev] downgrading libssh4 required when installing x2goclient on opensuse tumbleweed
Date: Fri, 25 Sep 2015 18:48:50 +0200
[Message part 3 (text/plain, inline)]
Control: close -1

On 04.09.2015 01:23 PM, Nikolai Maziashvili wrote:
> Package: x2goclient
> Version: 4.0.2.1-1.7
> 
> 
> Client machine: openSUSE Tumbleweed
> 
> Dear X2GO dev team,
> 
> I have encountered problem installing x2goclient on openSUSE Tumbleweed 
> machine from "dedicated" repository: 
> http://download.opensuse.org/repositories/X11:/RemoteDesktop:/x2go/openSUSE_Tumbleweed/

This repository is stale and unmaintained by us. Please use our "private"
repository as outlined on
http://wiki.x2go.org/doku.php/doc:installation:x2goserver#suse

Closing this bug report. If you can reproduce it with our repository, feel free
to reopen.



Mihai





[signature.asc (application/pgp-signature, attachment)]
[Message part 5 (message/rfc822, inline)]
From: Nikolai Maziashvili <nikolai@cyclinggeorgian.com>
To: submit@bugs.x2go.org
Subject: downgrading libssh4 required when installing x2goclient on opensuse tumbleweed
Date: Fri, 04 Sep 2015 13:23:58 +0200
Package: x2goclient
Version: 4.0.2.1-1.7


Client machine: openSUSE Tumbleweed

Dear X2GO dev team,

I have encountered problem installing x2goclient on openSUSE Tumbleweed 
machine from "dedicated" repository: 
http://download.opensuse.org/repositories/X11:/RemoteDesktop:/x2go/openSUSE_Tumbleweed/

Installing x2goclient results in zypper warning:

Problem: x2goclient-4.0.2.1-1.7.x86_64 requires 
libssh.so.4(LIBSSH_0.6.5)(64bit), but this requirement cannot be 
provided
  uninstallable providers: 
libssh4-0.6.5-23.1.x86_64[X11_RemoteDesktop_x2go]
 Solution 1: Following actions will be done:
  downgrade of libssh4-0.7.1-2.1.x86_64 to libssh4-0.6.5-23.1.x86_64
  install libssh4-0.6.5-23.1.x86_64 (with vendor change)
    openSUSE  -->  obs://build.opensuse.org/X11
 Solution 2: do not install x2goclient-4.0.2.1-1.7.x86_64
 Solution 3: break x2goclient-4.0.2.1-1.7.x86_64 by ignoring some of its 
dependencies

My initial thought was - if this is a dedicated x2go Tumbleweed repo why 
do they (x2go dev team) provide libraries already present on Tumbleweed 
systems (upstream) and why it is in older version. It only contributes 
to dependency problems...but then again, i have no idea if there are 
technical reasons for you to specifically provide older version of this 
particular lib... i do know that if i go ahead and downgrade libssh4 to 
get x2goclient installed on the system, very next system update will be 
hassle to do.
Again, without knowing x2goclient code, would it be possible to build 
rpm in such a way that it would require libraries from upstream repos 
instead of dedicated x2go repos, except, of course, those libs that are 
so specific to x2go that they are not present in "general" upstream 
repos.

Thanks,
Nikolai (and thnx for wonderful effort, amazing project you guys/gals 
have going there)

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Jun 16 22:48:17 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.