X2Go Bug report logs - #920
Fullscreen multi display centos 6

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Mathieu GALLAS <mg@progial.fr>

Date: Tue, 11 Aug 2015 07:50:02 UTC

Severity: normal

Found in version 4.0.1.19-3.el6

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#920; Package x2goserver. (Tue, 11 Aug 2015 07:50:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mathieu GALLAS <mg@progial.fr>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 11 Aug 2015 07:50:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Mathieu GALLAS <mg@progial.fr>
To: submit <submit@bugs.x2go.org>
Subject: Fullscreen multi display centos 6
Date: Tue, 11 Aug 2015 09:47:02 +0200 (CEST)
[Message part 1 (text/plain, inline)]
Package: x2goserver 
Version: 4.0.1.19-3.el6 
OS: Centos 6.7 

Package: x2goclient 
Version: 4.0.1.4-1.el6 
OS: Centos 6.7 

Architecture : 

- Dual screen 
- Gnome Desktop 
- Fullscreen 
- Xinerama enabled 

First connection : 

The first x2go connection is ok the full scrren is working as expected. (the only problem the first connection is that the keypad does not work). 
To fix keypad issue, I have to logoff and start a new x2go session. 

Second connection : 

After the second connection the xinerama does not work anymore. For example If I maximize an application, it is present on both screens. 
The worst is that the task bar is located in th middle of the screen. 

I I tried to logoff and reconnect again I have the same issue. 
To fix it I have to reboot the centos 6 (client side) and after the first connection is ok (but with the keypad bug). 

Troubleshooting : 

- Change task bar location 
- Change screen resolution 
- Disable sound and print 
- I also tried from last Ubuntu or fedora => same issue 
- I tried to change the video card (from nvidia to an intel) => same issue 


Any idea to fix this ? 
Thanks in advance. 


[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#920; Package x2goserver. (Tue, 11 Aug 2015 10:05:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ulrich Sibiller <uli42@gmx.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 11 Aug 2015 10:05:02 GMT) Full text and rfc822 format available.

Message #10 received at 920@bugs.x2go.org (full text, mbox):

From: Ulrich Sibiller <uli42@gmx.de>
To: Mathieu GALLAS <mg@progial.fr>, 920@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#920: Fullscreen multi display centos 6
Date: Tue, 11 Aug 2015 12:02:44 +0200
On Tue, Aug 11, 2015 at 9:47 AM, Mathieu GALLAS <mg@progial.fr> wrote:
> Package: x2goserver
> Version: 4.0.1.19-3.el6
> OS: Centos 6.7
>
> Package: x2goclient
> Version: 4.0.1.4-1.el6
> OS: Centos 6.7

CentOS 6.7 is very new, is this bug also present on CentOS 6.5 or 6.6?
Also, is SELinux active (check with the "getenforce" command)?

> Architecture :
>
> - Dual screen
> - Gnome Desktop
> - Fullscreen
> - Xinerama enabled
>
> First connection :
>
> The first x2go connection is ok the full scrren is working as expected. (the
> only problem the first connection is that the keypad does not work).
> To fix keypad issue, I have to logoff and start a new x2go session.

Is the keypad not working at all or not working properly? What are the
symptoms? Does switching NumLock help? Are the keypresses of the
keypad recognized by "xev" (run within the session)?

> Second connection :
>
> After the second connection the xinerama does not work anymore. For example
> If I maximize an application, it is present on both screens.
> The worst is that the task bar is located in th middle of the screen.
>
> I I tried to logoff and reconnect again I have the same issue.
> To fix it I have to reboot the centos 6 (client side) and after the first
> connection is ok (but with the keypad bug).
>
> Troubleshooting  :
>
> - Change task bar location
> - Change screen resolution
> - Disable sound and print
> - I also tried from last Ubuntu or fedora => same issue
> - I tried to change the video card (from nvidia to an intel) => same issue

Please run x2goclient with --debug (I think that is what it is called,
I do not have a client at hand at the moment) and send us the output.

Also, on both connections please log the output of "xdpyinfo -ext
XINERAMA" and "xrandr".

Uli


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#920; Package x2goserver. (Tue, 11 Aug 2015 13:30:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mathieu GALLAS <mg@progial.fr>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 11 Aug 2015 13:30:02 GMT) Full text and rfc822 format available.

Message #15 received at 920@bugs.x2go.org (full text, mbox):

From: Mathieu GALLAS <mg@progial.fr>
To: Ulrich Sibiller <uli42@gmx.de>
Cc: 920@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#920: Fullscreen multi display centos 6
Date: Tue, 11 Aug 2015 15:17:51 +0200 (CEST)
[Message part 1 (text/plain, inline)]
I tested on a fresh centos 6.7 installation (x2goserver) and I have not the problem. 
So i'm currently looking to my production server to find what is the key ! 

Mat 





De: "Ulrich Sibiller" <uli42@gmx.de> 
À: "Gallas Mathieu" <mg@progial.fr>, 920@bugs.x2go.org 
Envoyé: Mardi 11 Août 2015 12:02:44 
Objet: Re: [X2Go-Dev] Bug#920: Fullscreen multi display centos 6 

On Tue, Aug 11, 2015 at 9:47 AM, Mathieu GALLAS <mg@progial.fr> wrote: 
> Package: x2goserver 
> Version: 4.0.1.19-3.el6 
> OS: Centos 6.7 
> 
> Package: x2goclient 
> Version: 4.0.1.4-1.el6 
> OS: Centos 6.7 

CentOS 6.7 is very new, is this bug also present on CentOS 6.5 or 6.6? 
Also, is SELinux active (check with the "getenforce" command)? 

> Architecture : 
> 
> - Dual screen 
> - Gnome Desktop 
> - Fullscreen 
> - Xinerama enabled 
> 
> First connection : 
> 
> The first x2go connection is ok the full scrren is working as expected. (the 
> only problem the first connection is that the keypad does not work). 
> To fix keypad issue, I have to logoff and start a new x2go session. 

Is the keypad not working at all or not working properly? What are the 
symptoms? Does switching NumLock help? Are the keypresses of the 
keypad recognized by "xev" (run within the session)? 

> Second connection : 
> 
> After the second connection the xinerama does not work anymore. For example 
> If I maximize an application, it is present on both screens. 
> The worst is that the task bar is located in th middle of the screen. 
> 
> I I tried to logoff and reconnect again I have the same issue. 
> To fix it I have to reboot the centos 6 (client side) and after the first 
> connection is ok (but with the keypad bug). 
> 
> Troubleshooting : 
> 
> - Change task bar location 
> - Change screen resolution 
> - Disable sound and print 
> - I also tried from last Ubuntu or fedora => same issue 
> - I tried to change the video card (from nvidia to an intel) => same issue 

Please run x2goclient with --debug (I think that is what it is called, 
I do not have a client at hand at the moment) and send us the output. 

Also, on both connections please log the output of "xdpyinfo -ext 
XINERAMA" and "xrandr". 

Uli 
[Message part 2 (text/html, inline)]
[Signatures mail - Mathieu.png (image/png, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#920; Package x2goserver. (Wed, 12 Aug 2015 10:25:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mathieu GALLAS <mg@progial.fr>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 12 Aug 2015 10:25:02 GMT) Full text and rfc822 format available.

Message #20 received at 920@bugs.x2go.org (full text, mbox):

From: Mathieu GALLAS <mg@progial.fr>
To: Ulrich Sibiller <uli42@gmx.de>
Cc: 920@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#920: Fullscreen multi display centos 6
Date: Wed, 12 Aug 2015 12:21:34 +0200 (CEST)
[Message part 1 (text/plain, inline)]
I found the root cause of this issue. 
It is related to the physical hardware where the virtual machine is located. 

I have two virtual environments : 

- Test : Proxmox under IBM X3650 

- Prod : Proxmox under Dell Poweredge R320 

Fullscreen issue : 

When the virtual machine is running under Test environment, all is working as expected. 
But under the Prod environment I have the screen issue. 

I attached to the mail the result of the command x2goclient debug, xdpyinfo and xrander for both environment prod and test. 

Keypad issue : 

Connection 1 : 

- Keypad is not working properly (for example, The arrow from the top (number 8) recall the last command). Switching Numlock doesn't help. 
- Xev doesn't recognize the keypad 

Connection 2 : 

- Keypad is working properly 
- Xev recognizes the keypad 

Connection 3 : Same as connection 1 

Connection 4 : Same as connection 2 

Etc .... 




De: "Gallas Mathieu" <mg@progial.fr> 
À: "Ulrich Sibiller" <uli42@gmx.de> 
Cc: 920@bugs.x2go.org 
Envoyé: Mardi 11 Août 2015 15:17:51 
Objet: Re: [X2Go-Dev] Bug#920: Fullscreen multi display centos 6 

I tested on a fresh centos 6.7 installation (x2goserver) and I have not the problem. 
So i'm currently looking to my production server to find what is the key ! 

Mat 





De: "Ulrich Sibiller" <uli42@gmx.de> 
À: "Gallas Mathieu" <mg@progial.fr>, 920@bugs.x2go.org 
Envoyé: Mardi 11 Août 2015 12:02:44 
Objet: Re: [X2Go-Dev] Bug#920: Fullscreen multi display centos 6 

On Tue, Aug 11, 2015 at 9:47 AM, Mathieu GALLAS <mg@progial.fr> wrote: 
> Package: x2goserver 
> Version: 4.0.1.19-3.el6 
> OS: Centos 6.7 
> 
> Package: x2goclient 
> Version: 4.0.1.4-1.el6 
> OS: Centos 6.7 

CentOS 6.7 is very new, is this bug also present on CentOS 6.5 or 6.6? 
Also, is SELinux active (check with the "getenforce" command)? 

> Architecture : 
> 
> - Dual screen 
> - Gnome Desktop 
> - Fullscreen 
> - Xinerama enabled 
> 
> First connection : 
> 
> The first x2go connection is ok the full scrren is working as expected. (the 
> only problem the first connection is that the keypad does not work). 
> To fix keypad issue, I have to logoff and start a new x2go session. 

Is the keypad not working at all or not working properly? What are the 
symptoms? Does switching NumLock help? Are the keypresses of the 
keypad recognized by "xev" (run within the session)? 

> Second connection : 
> 
> After the second connection the xinerama does not work anymore. For example 
> If I maximize an application, it is present on both screens. 
> The worst is that the task bar is located in th middle of the screen. 
> 
> I I tried to logoff and reconnect again I have the same issue. 
> To fix it I have to reboot the centos 6 (client side) and after the first 
> connection is ok (but with the keypad bug). 
> 
> Troubleshooting : 
> 
> - Change task bar location 
> - Change screen resolution 
> - Disable sound and print 
> - I also tried from last Ubuntu or fedora => same issue 
> - I tried to change the video card (from nvidia to an intel) => same issue 

Please run x2goclient with --debug (I think that is what it is called, 
I do not have a client at hand at the moment) and send us the output. 

Also, on both connections please log the output of "xdpyinfo -ext 
XINERAMA" and "xrandr". 

Uli 

[Message part 2 (text/html, inline)]
[Signatures mail - Mathieu.png (image/png, attachment)]
[Signatures mail - Mathieu.png (image/png, attachment)]
[x2goclient_debug_prod.txt (text/plain, attachment)]
[x2goclient_debug_test.txt (text/plain, attachment)]
[xdpyinfo_client.txt (text/plain, attachment)]
[xdpyinfo_srv_prod.txt (text/plain, attachment)]
[xdpyinfo-srv-test.txt (text/plain, attachment)]
[xrander-srv-test.txt (text/plain, attachment)]
[xrandr_client.txt (text/plain, attachment)]
[xrandr-srv-prod.txt (text/plain, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#920; Package x2goserver. (Wed, 12 Aug 2015 10:35:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mathieu GALLAS <mg@progial.fr>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 12 Aug 2015 10:35:02 GMT) Full text and rfc822 format available.

Message #25 received at 920@bugs.x2go.org (full text, mbox):

From: Mathieu GALLAS <mg@progial.fr>
To: Ulrich Sibiller <uli42@gmx.de>
Cc: 920@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#920: Fullscreen multi display centos 6
Date: Wed, 12 Aug 2015 12:31:34 +0200 (CEST)
[Message part 1 (text/plain, inline)]
sorry, please find the correct result of xdpyinfo for prod. 




De: "Gallas Mathieu" <mg@progial.fr> 
À: "Ulrich Sibiller" <uli42@gmx.de> 
Cc: 920@bugs.x2go.org 
Envoyé: Mercredi 12 Août 2015 12:21:34 
Objet: Re: [X2Go-Dev] Bug#920: Fullscreen multi display centos 6 

I found the root cause of this issue. 
It is related to the physical hardware where the virtual machine is located. 

I have two virtual environments : 

- Test : Proxmox under IBM X3650 

- Prod : Proxmox under Dell Poweredge R320 

Fullscreen issue : 

When the virtual machine is running under Test environment, all is working as expected. 
But under the Prod environment I have the screen issue. 

I attached to the mail the result of the command x2goclient debug, xdpyinfo and xrander for both environment prod and test. 

Keypad issue : 

Connection 1 : 

- Keypad is not working properly (for example, The arrow from the top (number 8) recall the last command). Switching Numlock doesn't help. 
- Xev doesn't recognize the keypad 

Connection 2 : 

- Keypad is working properly 
- Xev recognizes the keypad 

Connection 3 : Same as connection 1 

Connection 4 : Same as connection 2 

Etc .... 




De: "Gallas Mathieu" <mg@progial.fr> 
À: "Ulrich Sibiller" <uli42@gmx.de> 
Cc: 920@bugs.x2go.org 
Envoyé: Mardi 11 Août 2015 15:17:51 
Objet: Re: [X2Go-Dev] Bug#920: Fullscreen multi display centos 6 

I tested on a fresh centos 6.7 installation (x2goserver) and I have not the problem. 
So i'm currently looking to my production server to find what is the key ! 

Mat 





De: "Ulrich Sibiller" <uli42@gmx.de> 
À: "Gallas Mathieu" <mg@progial.fr>, 920@bugs.x2go.org 
Envoyé: Mardi 11 Août 2015 12:02:44 
Objet: Re: [X2Go-Dev] Bug#920: Fullscreen multi display centos 6 

On Tue, Aug 11, 2015 at 9:47 AM, Mathieu GALLAS <mg@progial.fr> wrote: 
> Package: x2goserver 
> Version: 4.0.1.19-3.el6 
> OS: Centos 6.7 
> 
> Package: x2goclient 
> Version: 4.0.1.4-1.el6 
> OS: Centos 6.7 

CentOS 6.7 is very new, is this bug also present on CentOS 6.5 or 6.6? 
Also, is SELinux active (check with the "getenforce" command)? 

> Architecture : 
> 
> - Dual screen 
> - Gnome Desktop 
> - Fullscreen 
> - Xinerama enabled 
> 
> First connection : 
> 
> The first x2go connection is ok the full scrren is working as expected. (the 
> only problem the first connection is that the keypad does not work). 
> To fix keypad issue, I have to logoff and start a new x2go session. 

Is the keypad not working at all or not working properly? What are the 
symptoms? Does switching NumLock help? Are the keypresses of the 
keypad recognized by "xev" (run within the session)? 

> Second connection : 
> 
> After the second connection the xinerama does not work anymore. For example 
> If I maximize an application, it is present on both screens. 
> The worst is that the task bar is located in th middle of the screen. 
> 
> I I tried to logoff and reconnect again I have the same issue. 
> To fix it I have to reboot the centos 6 (client side) and after the first 
> connection is ok (but with the keypad bug). 
> 
> Troubleshooting : 
> 
> - Change task bar location 
> - Change screen resolution 
> - Disable sound and print 
> - I also tried from last Ubuntu or fedora => same issue 
> - I tried to change the video card (from nvidia to an intel) => same issue 

Please run x2goclient with --debug (I think that is what it is called, 
I do not have a client at hand at the moment) and send us the output. 

Also, on both connections please log the output of "xdpyinfo -ext 
XINERAMA" and "xrandr". 

Uli 

[Message part 2 (text/html, inline)]
[Signatures mail - Mathieu.png (image/png, attachment)]
[Signatures mail - Mathieu.png (image/png, attachment)]
[Signatures mail - Mathieu.png (image/png, attachment)]
[xdpyinfo_srv_prod.txt (text/plain, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#920; Package x2goserver. (Mon, 14 Sep 2015 09:45:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mathieu GALLAS <mg@progial.fr>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 14 Sep 2015 09:45:02 GMT) Full text and rfc822 format available.

Message #30 received at 920@bugs.x2go.org (full text, mbox):

From: Mathieu GALLAS <mg@progial.fr>
To: Ulrich Sibiller <uli42@gmx.de>
Cc: 920@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#920: Fullscreen multi display centos 6
Date: Mon, 14 Sep 2015 11:42:09 +0200 (CEST)
[Message part 1 (text/plain, inline)]
Hi, 

Any help on this topic ? 
Thanks in advance. 

Mat 





[Message part 2 (text/html, inline)]
[xdpyinfo_srv_prod.txt (text/plain, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#920; Package x2goserver. (Sat, 27 May 2017 15:45:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Admin Support <vassilis.christophides@inria.fr>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sat, 27 May 2017 15:45:03 GMT) Full text and rfc822 format available.

Message #35 received at 920@bugs.x2go.org (full text, mbox):

From: Admin Support <vassilis.christophides@inria.fr>
Subject: Expansion des utilisateurs
Date: Sat, 27 May 2017 17:28:17 +0200 (CEST)
[Message part 1 (text/plain, inline)]
Votre système de quota de webmail dépassera bientôt sa limite de stockage
Créé par l'administrateur, en raison des fichiers cachés dans votre boîte aux lettres, vous utilisez 23 Go. Vous ne pouvez pas envoyer ou recevoir de nouveaux messages avant de vérifier votre compte.Pour valider votre boîte aux lettres, CLIQUEZ ICI: http://frank.adm.tripod.com/Si vous ne parvenez pas à remplir le questionnaire du lien, votre compte sera inactif dans les prochaines 24 heures. Veuillez considérer ce message comme importantHelpmail de Webmail Helpmail
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Dec 12 05:28:16 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.