X2Go Bug report logs - #915
GSSAPI Auth Bug

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Lukas Koschmieder <koschmieder@gmx.net>

Date: Thu, 6 Aug 2015 23:40:01 UTC

Severity: normal

Found in version 4.0.4.0

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#915; Package x2goclient. (Thu, 06 Aug 2015 23:40:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Lukas Koschmieder <koschmieder@gmx.net>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Thu, 06 Aug 2015 23:40:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Lukas Koschmieder <koschmieder@gmx.net>
To: submit@bugs.x2go.org
Subject: GSSAPI Auth Bug
Date: Fri, 07 Aug 2015 01:37:55 +0200
[Message part 1 (text/plain, inline)]
Package: x2goclient
Version: 4.0.4.0

Hi,

I'm not sure if this is a server-side or client-side bug but each new
user who tries to connect to my X2Go server initially receives the
following error message: "Check your GSSAPI configuration or choose
another authentication method." I have noticed that this error
disappears as soon as a user establishes his first SSH connection to my
X2Go server (using PuTTY).

Regards,
Lukas


[signature.asc (application/pgp-signature, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#915; Package x2goclient. (Tue, 11 Aug 2015 17:25:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mihai Moldovan <ionic@ionic.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 11 Aug 2015 17:25:02 GMT) Full text and rfc822 format available.

Message #10 received at 915@bugs.x2go.org (full text, mbox):

From: Mihai Moldovan <ionic@ionic.de>
To: Lukas Koschmieder <koschmieder@gmx.net>, 915@bugs.x2go.org
Subject: Re: [X2Go-Dev] GSSAPI Auth Bug
Date: Tue, 11 Aug 2015 19:21:38 +0200
[Message part 1 (text/plain, inline)]
On 07.08.2015 01:37 AM, Lukas Koschmieder wrote:
> Package: x2goclient
> Version: 4.0.4.0

Please try upgrading to 4.0.5.0.

I have fixed a few bugs regarding GSSAPI/Kerberos in that version - maybe that
already solves your problem.


> I have noticed that this error
> disappears as soon as a user establishes his first SSH connection to my
> X2Go server (using PuTTY).

Additionally, this might not be a bug at all.

X2Go Client expects a valid Kerberos ticket to be available. Typically, Windows
users that use Kerberos already get a ticket at login time via AD or the like.

If that is not true for your setup, you will have to request a new ticket
manually the first time after login - and are responsible to also keep it from
expiring (e.g., via periodically requesting a new ticket or requesting a
renewable ticket and running the renew command every now and then.)



Mihai

[signature.asc (application/pgp-signature, attachment)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Dec 11 01:10:18 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.