X2Go Bug report logs - #914
X2Go Logout Issue with Mate on Centos7

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Robert Dinse <nanook@eskimo.com>

Date: Wed, 5 Aug 2015 19:25:02 UTC

Severity: normal

Found in version 4.0.1.19-3.el7

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#914: X2Go Logout Issue with Mate on Centos7
Reply-To: Robert Dinse <nanook@eskimo.com>, 914@bugs.x2go.org
Resent-From: Robert Dinse <nanook@eskimo.com>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Wed, 05 Aug 2015 19:25:02 +0000
Resent-Message-ID: <handler.914.B.143880268527239@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: report 914
X-X2Go-PR-Package: <x2goserver>
X-X2Go-PR-Keywords: 
Received: via spool by submit@bugs.x2go.org id=B.143880268527239
          (code B); Wed, 05 Aug 2015 19:25:02 +0000
Received: (at submit) by bugs.x2go.org; 5 Aug 2015 19:24:45 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.8 required=5.0 tests=BAYES_50,URIBL_BLOCKED
	autolearn=ham version=3.3.2
X-Greylist: delayed 489 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Wed, 05 Aug 2015 21:24:43 CEST
Received: from mail.eskimo.com (mail.eskimo.com [204.122.16.4])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 1CF733BC49
	for <submit@bugs.x2go.org>; Wed,  5 Aug 2015 21:24:42 +0200 (CEST)
Received: from shellx.eskimo.com (shellx.eskimo.com [204.122.16.2])
	by mail.eskimo.com (Postfix) with ESMTPS id 557AD171E
	for <submit@bugs.x2go.org>; Wed,  5 Aug 2015 12:16:31 -0700 (PDT)
Date: Wed, 5 Aug 2015 12:16:31 -0700 (PDT)
From: Robert Dinse <nanook@eskimo.com>
To: submit@bugs.x2go.org
Message-ID: <Pine.LNX.4.64.1508051154270.4827@shellx.eskimo.com>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed
X-Virus-Scanned: clamav-milter 0.98.7 at mail.eskimo.com
X-Virus-Status: Clean
Package: <x2goserver>
Version: <4.0.1.19-3.el7>

     X2Goserver installed on a CentOS7 system with Mate desktop.  When I
logout, the top and bottom bars disappear but the background image remains
and in this state it hangs indefinitely.

     If I then use alt-control-M to minimize the screen, click on the little
white seal and when the initial screen comes up, terminate the session, it
terminates.

     This behavior did not exist when I first installed Mate and X2Go server
on this machine, something has changed recently.

     Also perhaps relevant, I have exactly the same version of x2go server
and Mate installed on a Scientific Linux 7 machine and it terminates the
session properly when I logout so this behavior appears to be specific to
Centos 7.

     This is the x2goserver.conf, it is identical on both the Centos7 machine
that doesn't logout properly and the scientific7 machine which does, I have 
not altered it from the defaults:

 ---------------------------------------------------------------------------

[limit users]
#user-foo=1

[limit groups]
#bar-group=1

[security]
# SSHFS umask for client-side folder sharing. Leave uncommented to keep the 
server's default umask
#umask="0117"

[log]
# possible levels are: emerg, alert, crit, err, warning, notice, info, debug
loglevel=notice

 --------------------------------------------------------------------------

     I thought maybe the contents of x2go_logout.d which is a single script
called 010_userscripts.sh containing:

 --------------------------------------------------------------------------
# call $HOME/.x2go_logout script...

test -r $HOME/.x2go_logout && . $HOME/.x2go_logout
 --------------------------------------------------------------------------

     ... might be relevant but that to is identical on both machines as are
$HOME/.x2go_logout which actually is non-existent on both machines (actually
home directory is identical as it is NFS mounted on both machines from a
common server).

     The one thing that is different is the version of mate-desktop, on the
broken box it's version 1.8.2-2.el7 and on the working system 1.10.1-2.el7.

     I upgraded the broken box to Mate 1.10.1-2.e17, the same as the working
machine but logout still hangs.

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
 Eskimo North Linux Friendly Internet Access, Shell Accounts, and Hosting.
   Knowledgeable human assistance, not telephone trees or script readers.
 See our web site: http://www.eskimo.com/ (206) 812-0051 or (800) 246-6874.

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Aug 4 03:17:09 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.