X2Go Bug report logs - #854
Ubuntu 14.04: xinerama broken

version graph

Packages: nx-x11-common, x2goclient; Maintainer for nx-x11-common is (unknown); Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: uli42@gmx.de

Date: Sat, 25 Apr 2015 08:15:02 UTC

Severity: normal

Found in version 4.0.3.2-0~800~ubuntu14.04.1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>, owner@bugs.x2go.org:
Bug#854; Package x2goclient, nx-x11-common. (Sat, 25 Apr 2015 08:15:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to uli42@gmx.de:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>, owner@bugs.x2go.org. (Sat, 25 Apr 2015 08:15:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Ulrich Sibiller <ulrich.sibiller@gmail.com>
To: submit@bugs.x2go.org
Subject: Ubuntu 14.04: xinerama broken
Date: Sat, 25 Apr 2015 10:13:51 +0200
[Message part 1 (text/plain, inline)]
Package: x2goclient, nx-x11-common
Version: 4.0.3.2-0~800~ubuntu14.04.1

As far as I know opening an x2go session from a display that uses xinerama
should do the following on the server side:
- create a xinerama.conf with the xinerama setting on the client side
- set NX_XINERAMA_CONF in the envrionment
- extend the LD_LIBRARY_PATH to point to the nx xinerama lib.

When I open an x2go session to my local machine (the same where the
x2goclient is running) this does not work for several reasons:
1. /usr/lib/nx/X11/Xinerama/libXinerama.so.1 points to the i386 version of
the lib which is not existing on my 64 bit machine. dpkg -S shows that this
is coming from the package nx-x11-common. So obviously this is broken.
2. After fixing issue 1 by linking to the 64bit version it still does not
work. This is because for Ubuntu there is only x2goclient 4.0.3 but you
need 4.0.4 for xinerama... So could someone please update the Ubuntu repo?

The xinerama feature is enabled for the session as well as for x2goclient
(--xinerama).

I am using ubuntu 14.04 with these x2go packages. These are the most
current packages the repos provide and all oft Thema have been freshly
installed yesterday.

libnx-x11 2:3.5.0.29-0~505~ubuntu14.04.1 (does not contain any files)
libnx-x11-6:amd64 2:3.5.0.31-0~605~ubuntu14.04.1
libnx-xcomposite1:amd64 2:3.5.0.31-0~605~ubuntu14.04.1
libnx-xdamage1:amd64 2:3.5.0.31-0~605~ubuntu14.04.1
libnx-xdmcp6:amd64 2:3.5.0.31-0~605~ubuntu14.04.1
libnx-xext6:amd64 2:3.5.0.31-0~605~ubuntu14.04.1
libnx-xfixes3:amd64 2:3.5.0.31-0~605~ubuntu14.04.1
libnx-xinerama1:amd64 2:3.5.0.31-0~605~ubuntu14.04.1
libnx-xpm4:amd64 2:3.5.0.31-0~605~ubuntu14.04.1
libnx-xrandr2:amd64 2:3.5.0.31-0~605~ubuntu14.04.1
libnx-xrender1:amd64 2:3.5.0.31-0~605~ubuntu14.04.1
libnx-xtst6:amd64 2:3.5.0.31-0~605~ubuntu14.04.1
nx-x11-common 2:3.5.0.31-0~605~ubuntu14.04.1
nxagent 2:3.5.0.31-0~605~ubuntu14.04.1
nxproxy 2:3.5.0.31-0~605~ubuntu14.04.1
x2goagent 2:3.5.0.31-0~605~ubuntu14.04.1
x2goclient 4.0.3.2-0~800~ubuntu14.04.1
x2godesktopsharing 3.1.1.2-0~170~ubuntu14.04.1
x2goserver 4.0.1.19-0~1064~ubuntu14.04.1
x2goserver-common 4.1.0.0-0~1257~ubuntu14.04.1
x2goserver-extensions 4.0.1.19-0~1064~ubuntu14.04.1
x2goserver-xsession 4.0.1.19-0~1064~ubuntu14.04.1
x2gothinclient 1.1.0.2-0~469~ubuntu14.04.1
x2gothinclientmanagement 1.1.0.2-0~469~ubuntu14.04.1
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>, owner@bugs.x2go.org:
Bug#854; Package x2goclient, nx-x11-common. (Sat, 25 Apr 2015 10:55:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mihai Moldovan <ionic@ionic.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>, owner@bugs.x2go.org. (Sat, 25 Apr 2015 10:55:02 GMT) Full text and rfc822 format available.

Message #10 received at 854@bugs.x2go.org (full text, mbox):

From: Mihai Moldovan <ionic@ionic.de>
To: uli42@gmx.de, 854@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#854: Ubuntu 14.04: xinerama broken
Date: Sat, 25 Apr 2015 12:51:33 +0200
[Message part 1 (text/plain, inline)]
On 25.04.2015 10:13 AM, Ulrich Sibiller wrote:
> Package: x2goclient, nx-x11-common
> Version: 4.0.3.2-0~800~ubuntu14.04.1
> 
> As far as I know opening an x2go session from a display that uses xinerama should do the following on the server side:
> - create a xinerama.conf with the xinerama setting on the client side
> - set NX_XINERAMA_CONF in the envrionment
> - extend the LD_LIBRARY_PATH to point to the nx xinerama lib.
> 
> When I open an x2go session to my local machine (the same where the x2goclient is running) this does not work for several reasons:
> 1. /usr/lib/nx/X11/Xinerama/libXinerama.so.1 points to the i386 version of the lib which is not existing on my 64 bit machine. dpkg -S shows that this is coming from the package nx-x11-common. So obviously this is broken.

That's a problem. Will take a look at this.


> 2. After fixing issue 1 by linking to the 64bit version it still does not work. This is because for Ubuntu there is only x2goclient 4.0.3 but you need 4.0.4 for xinerama... So could someone please update the Ubuntu repo?

I've fixed Xinerama in 4.0.4.0 thanks to other people's patches, yes. I haven't released this version yet, though, because it's not done for release.
Thus, 4.0.4.0 is only available via the heuler/nightly PPA atm.



Mihai

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>, owner@bugs.x2go.org:
Bug#854; Package x2goclient, nx-x11-common. (Mon, 27 Apr 2015 23:35:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mihai Moldovan <ionic@ionic.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>, owner@bugs.x2go.org. (Mon, 27 Apr 2015 23:35:02 GMT) Full text and rfc822 format available.

Message #15 received at 854@bugs.x2go.org (full text, mbox):

From: Mihai Moldovan <ionic@ionic.de>
To: uli42@gmx.de, 854@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#854: Bug#854: Ubuntu 14.04: xinerama broken
Date: Tue, 28 Apr 2015 01:34:53 +0200
[Message part 1 (text/plain, inline)]
On 25.04.2015 12:51 PM, Mihai Moldovan wrote:
> On 25.04.2015 10:13 AM, Ulrich Sibiller wrote:
>> Package: x2goclient, nx-x11-common
>> Version: 4.0.3.2-0~800~ubuntu14.04.1
>>
>> As far as I know opening an x2go session from a display that uses xinerama should do the following on the server side:
>> - create a xinerama.conf with the xinerama setting on the client side
>> - set NX_XINERAMA_CONF in the envrionment
>> - extend the LD_LIBRARY_PATH to point to the nx xinerama lib.
>>
>> When I open an x2go session to my local machine (the same where the x2goclient is running) this does not work for several reasons:
>> 1. /usr/lib/nx/X11/Xinerama/libXinerama.so.1 points to the i386 version of the lib which is not existing on my 64 bit machine. dpkg -S shows that this is coming from the package nx-x11-common. So obviously this is broken.
> 
> That's a problem. Will take a look at this.

I can't do anything about this. No idea why launchpad would create a broken package. Our (self-built) Debian packages do not show this problem and building an Ubuntu package via pbuilder-dist likewise doesn't reproduce it.

Further, I've noticed that for our nightly builds, nx-x11-common is *completely* missing as a package. It looks like Launchpad is detecting it as empty and not building it at all, for whatever reason. The correct symlink that is supposed to be part of the package gets created at install time, but the build system just never copies it to the binary package staging zone.

I have tried debugging this, but cannot reproduce the problem with pbuilder-dist. For what it's worth, pbuilder-dist creates working packages, as they should have been to begin with...


Thus, I created a bug report on launchpad: https://bugs.launchpad.net/x2go/+bug/1449199



Mihai

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>, owner@bugs.x2go.org:
Bug#854; Package x2goclient, nx-x11-common. (Thu, 02 Mar 2017 13:10:42 GMT) Full text and rfc822 format available.

Acknowledgement sent to Manuela Wendler <manuelahendler@gmx.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>, owner@bugs.x2go.org. (Thu, 02 Mar 2017 13:10:42 GMT) Full text and rfc822 format available.

Message #20 received at 854@bugs.x2go.org (full text, mbox):

From: Manuela Wendler <manuelahendler@gmx.com>
To: 854@bugs.x2go.org
Subject: Nachricht empfangen am_k_leinanzeigen
Date: Thu, 2 Mar 2017 11:07:51 +0100 (CET)
[Message part 1 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu Dec 13 15:31:55 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.