X2Go Bug report logs - #852
No clipboard sharing via desktop sharing

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Anatoly Smaznov <mrjavum@gmail.com>

Date: Thu, 23 Apr 2015 08:40:01 UTC

Severity: normal

Tags: build-win32

Found in version 4.0.3.2

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#852; Package x2goclient. (Thu, 23 Apr 2015 08:40:01 GMT) (full text, mbox, link).


Acknowledgement sent to Anatoly Smaznov <mrjavum@gmail.com>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Thu, 23 Apr 2015 08:40:02 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

From: Anatoly Smaznov <mrjavum@gmail.com>
To: submit@bugs.x2go.org
Subject: No clipboard sharing via desktop sharing
Date: Thu, 23 Apr 2015 14:39:06 +0600
[Message part 1 (text/plain, inline)]
Package: x2goclient
Version: 4.0.3.2

Clipboard works well, when I open new session. But when I connect to
current desktop session clipboard won't work...

Client - Win7 x64 SP1.
Server - archlinux x86_64

uname -a
Linux home 4.0.0-2-ARCH #1 SMP PREEMPT Tue Apr 14 07:14:46 CEST 2015 x86_64
GNU/Linux

DE: XFCE 4.12
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#852; Package x2goclient. (Sat, 09 Dec 2017 21:25:02 GMT) (full text, mbox, link).


Acknowledgement sent to Peter Hendricks <beddhist@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sat, 09 Dec 2017 21:25:02 GMT) (full text, mbox, link).


Message #10 received at 852@bugs.x2go.org (full text, mbox, reply):

From: Peter Hendricks <beddhist@gmail.com>
To: 852@bugs.x2go.org
Subject: Bug confirmed on slightly different platforms
Date: Sun, 10 Dec 2017 10:21:38 +1300
Copy/paste works in both directions with new XFCE session, but doesn't
work when connected to current desktop.

Client: 4.1.0.0
Win10 amd64

Server:

Linux minty 4.10.0-32-generic #36~16.04.1-Ubuntu SMP Wed Aug 9 09:18:53
UTC 2017

Linux Mint 18.2 XFCE 64bit

AMD64


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#852; Package x2goclient. (Sat, 09 Dec 2017 21:50:01 GMT) (full text, mbox, link).


Acknowledgement sent to Peter Hendricks <beddhist@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sat, 09 Dec 2017 21:50:02 GMT) (full text, mbox, link).


Message #15 received at 852@bugs.x2go.org (full text, mbox, reply):

From: Peter Hendricks <beddhist@gmail.com>
To: 852@bugs.x2go.org
Subject: Bug confirmed in client 4.1.0.0
Date: Sun, 10 Dec 2017 10:48:42 +1300
[Message part 1 (text/plain, inline)]
Copy/paste works in both directions with new XFCE session, but doesn't
work when connected to current desktop.

Client: 4.1.0.0
Win10 amd64

Server:

x2goserver 4.0.1.22-0~1197~ubuntu16.0.4.1
Linux minty 4.10.0-32-generic #36~16.04.1-Ubuntu SMP Wed Aug 9 09:18:53
UTC 2017

Linux Mint 18.2 XFCE 64bit

AMD64



-- 

P & S Contracting
Ph  +64-9-4591469
Mob +64-21-02502582
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#852; Package x2goclient. (Sat, 23 Jun 2018 03:35:02 GMT) (full text, mbox, link).


Acknowledgement sent to Peter Hendricks <beddhist@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sat, 23 Jun 2018 03:35:02 GMT) (full text, mbox, link).


Message #20 received at 852@bugs.x2go.org (full text, mbox, reply):

From: Peter Hendricks <beddhist@gmail.com>
To: 852@bugs.x2go.org
Subject: Bug confirmed in client 4.2.1.0
Date: Sat, 23 Jun 2018 15:30:25 +1200
This bug is still present in the latest version. Is there any chance
that this over 3 year old bug will get looked at in the near future?

Regards,
Peter.


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#852; Package x2goclient. (Sat, 23 Jun 2018 04:00:03 GMT) (full text, mbox, link).


Acknowledgement sent to Mike DePaulo <mikedep333@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sat, 23 Jun 2018 04:00:04 GMT) (full text, mbox, link).


Message #25 received at 852@bugs.x2go.org (full text, mbox, reply):

From: Mike DePaulo <mikedep333@gmail.com>
To: Peter Hendricks <beddhist@gmail.com>, 852@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#852: Bug confirmed in client 4.2.1.0
Date: Fri, 22 Jun 2018 23:56:30 -0400
[Message part 1 (text/plain, inline)]
Tags: build-win32

On 06/22/2018 11:30 PM, Peter Hendricks wrote:
> This bug is still present in the latest version. Is there any chance
> that this over 3 year old bug will get looked at in the near future?
> 
> Regards,
> Peter.

I understand your situation.

As the volunteer X2Go Client for Windows maintainer, I have been very
busy putting in overtime at work over the last few years, so I have not
fixed as many bugs as I used to.

Right now I am focusing my efforts on 3rd party security updates (high
priority) and reviewing patches (low effort for possibly high reward)
given the limited time I have, rather than investigating and fixing
issues all by myself.

I can tell you that I rarely use desktop sharing. It's not the primary
use case for most X2Go users, or FreeNX. It was never as mature as
regular sessions. Even for VNC servers & Microsoft RDC, their
"pixel-scraping" performance for desktop sharing is worse than it is for
regular "virtual" sessions.

-Mike

[signature.asc (application/pgp-signature, attachment)]

Added tag(s) build-win32. Request was from Mike DePaulo <mikedep333@gmail.com> to control@bugs.x2go.org. (Sat, 23 Jun 2018 22:20:02 GMT) (full text, mbox, link).


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#852; Package x2goclient. (Wed, 13 Mar 2019 17:30:01 GMT) (full text, mbox, link).


Acknowledgement sent to Martin <sognata@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 13 Mar 2019 17:30:01 GMT) (full text, mbox, link).


Message #32 received at 852@bugs.x2go.org (full text, mbox, reply):

From: Martin <sognata@gmail.com>
To: 852@bugs.x2go.org
Subject: No clipboard sharing via desktop sharing
Date: Wed, 13 Mar 2019 18:29:02 +0100
Can reproduce in v4.1.2.0 with Cinnamon shared desktop on Linux Mint 19
(Server) and Win7 x64 (Client).


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#852; Package x2goclient. (Sun, 03 May 2020 11:35:01 GMT) (full text, mbox, link).


Acknowledgement sent to Evgen <altsyde@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sun, 03 May 2020 11:35:01 GMT) (full text, mbox, link).


Message #37 received at 852@bugs.x2go.org (full text, mbox, reply):

From: Evgen <altsyde@gmail.com>
To: 852@bugs.x2go.org
Subject: No clipboard sharing via desktop sharing
Date: Sun, 3 May 2020 14:30:01 +0300
I've got clipboard working after running autocutsel on server

autocutsel -s PRIMARY -fork


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#852; Package x2goclient. (Mon, 04 May 2020 06:55:02 GMT) (full text, mbox, link).


Acknowledgement sent to Evgen <altsyde@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 04 May 2020 06:55:02 GMT) (full text, mbox, link).


Message #42 received at 852@bugs.x2go.org (full text, mbox, reply):

From: Evgen <altsyde@gmail.com>
To: 852@bugs.x2go.org
Subject: Re: No clipboard sharing via desktop sharing
Date: Mon, 4 May 2020 09:53:51 +0300
[Message part 1 (text/plain, inline)]
On Sun, 3 May 2020 14:30:01 +0300 Evgen wrote:
> I've got clipboard working after running autocutsel on server
>
> autocutsel -s PRIMARY -fork
>
Sorry for misinformation, it doesn't work. I probably used regular 
session...
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#852; Package x2goclient. (Sat, 20 Nov 2021 18:40:01 GMT) (full text, mbox, link).


Acknowledgement sent to tomasz <tomasz@t.k.pl>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sat, 20 Nov 2021 18:40:01 GMT) (full text, mbox, link).


Message #47 received at 852@bugs.x2go.org (full text, mbox, reply):

From: tomasz <tomasz@t.k.pl>
To: 852@bugs.x2go.org
Subject: Re: Bug confirmed on slightly different platforms
Date: Sat, 20 Nov 2021 19:36:11 +0100
On Sun, 10 Dec 2017 10:21:38 +1300 Peter Hendricks <beddhist@gmail.com>
wrote:
> Copy/paste works in both directions with new XFCE session, but doesn't
> work when connected to current desktop.
> 
> Client: 4.1.0.0
> Win10 amd64
> 
> Server:
> 
> Linux minty 4.10.0-32-generic #36~16.04.1-Ubuntu SMP Wed Aug 9 09:18:53
> UTC 2017
> 
> Linux Mint 18.2 XFCE 64bit
> 
> AMD64
> 

Copy/paste works in both directions with new XFCE session, but doesn't
work when connected to current desktop.

Client: 4.1.2.2
Kubuntu 20.04

-- 
Pozdrowienia Tomasz
tomasz@t.k.pl


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Nov 27 15:39:53 2022; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.