X2Go Bug report logs - #788
Pyhoca-Gui freezes when connection to desktop

version graph

Package: x2goserver-xsession; Maintainer for x2goserver-xsession is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver-xsession is src:x2goserver.

Reported by: "Ja Bi" <Bi.Ja@seznam.cz>

Date: Thu, 12 Feb 2015 13:30:01 UTC

Severity: normal

Tags: pending

Merged with 632, 808

Found in version 4.0.1.18

Fixed in version 4.0.1.19

Done: Mihai Moldovan <ionic@ionic.de>

Bug is archived. No further changes may be made.

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#788: [X2Go-Dev] Bug#788: Bug#788: Pyhoca-Gui freezes when connection to desktop
Reply-To: Mihai Moldovan <ionic@ionic.de>, 788@bugs.x2go.org
Resent-From: Mihai Moldovan <ionic@ionic.de>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: owner@bugs.x2go.org
X-Loop: owner@bugs.x2go.org
Resent-Date: Sun, 01 Mar 2015 14:30:02 +0000
Resent-Message-ID: <handler.788.B788.14252201475487@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 788
X-X2Go-PR-Package:  pyhoca-gui-0.5.0.3, python-x2go 0.5.0.2, x2goserver-4.0.1.18-r2
X-X2Go-PR-Keywords: 
Received: via spool by 788-submit@bugs.x2go.org id=B788.14252201475487
          (code B ref 788); Sun, 01 Mar 2015 14:30:02 +0000
Received: (at 788) by bugs.x2go.org; 1 Mar 2015 14:29:07 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-0.5 required=5.0 tests=BAYES_05,T_DKIM_INVALID,
	URIBL_BLOCKED,URIBL_DBL_ABUSE_REDIR autolearn=ham version=3.3.2
Received: from Root24.de (powered.by.root24.eu [5.135.3.88])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id EBFCB5DCA8
	for <788@bugs.x2go.org>; Sun,  1 Mar 2015 15:29:05 +0100 (CET)
Received: from nopileos.local (home.ionic.de [217.92.117.31])
	by mail.ionic.de (Postfix) with ESMTPSA id 88B384F08215;
	Sun,  1 Mar 2015 15:29:04 +0100 (CET)
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=ionic.de; s=default;
	t=1425220145; bh=5jqTT/Ec2hJChkPKOx45cDX8A4TWCE3vvqiL375IQEg=;
	h=Date:From:To:CC:Subject:References:In-Reply-To:From;
	b=TfRD+w77kCXsVyeDF1S5KnCNwGH7Xjn0NoVbf/SxvyHSeoEoR7GtVs/Wnudsm2VO0
	 Tn8QKnA/0CZ3Cfg1VupKHt9RLmVUx2rMNbSsU/7FXqdwRWhqytn6E0s5tbmimeKYh7
	 oNc7+mRLtrDPfTJ9AKwMt8YStD26vDN+oiuXMtSw=
Message-ID: <54F3221C.4030401@ionic.de>
Date: Sun, 01 Mar 2015 15:28:44 +0100
From: Mihai Moldovan <ionic@ionic.de>
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Thunderbird/31.4.0
MIME-Version: 1.0
To: Ja Bi <Bi.Ja@seznam.cz>
CC: 788@bugs.x2go.org
References: <7mn.NYtI.2Bw1kTgaKM2.1KwIhS@seznam.cz>	<54EA1435.8080300@ionic.de>	<20150223053707.Horde.qOyTHhqQzNXyPOzWnVB8nw1@mail.das-netzwerkteam.de>	<54EABD37.4090206@ionic.de>	<4Cu.NYmU.5}fg}ajyKRN.1Kx4WZ@seznam.cz>	<54EC903C.2070203@ionic.de>	<5j{.NYpw.4FMP3OTHiW9.1Kx9}H@seznam.cz>	<54EF53BA.2070600@ionic.de>	<20150227211838.Horde.AUzZ4tII0XKTYP6mjcQGGg6@mail.das-netzwerkteam.de>	<54F0E1D5.2040100@ionic.de> <K7U.NYei.4venCz6b4IL.1Kyl7E@seznam.cz>
In-Reply-To: <K7U.NYei.4venCz6b4IL.1Kyl7E@seznam.cz>
Content-Type: multipart/signed; micalg=pgp-sha512;
 protocol="application/pgp-signature";
 boundary="BBncEEfaeGTnC6I3sBFs9MJ91HwGw0Dno"
[Message part 1 (text/plain, inline)]
On 01.03.2015 12:02 PM, Ja Bi wrote:
> Ok, probably solved.
>
> I removed /etc/x2go/xinitrc.d/vmware-xsession-gdm.sh
> and now it works as it should.

Wait, did you complete remove it?

x2goserver 4.0.1.19[1] should have fixed such problems (it's also
available in Gentoo as of a few days) so there's no need to complete
remove that file, if you still need it.

Thus, you're free to put it back after upgrading to x2goserver 4.0.1.19.

Note that /etc/x2go/xinitrc.d is a SYMLINK to /etc/X11/xinit/xinitrc.d
which is a system folder.


Glad it works for you! Is this really fixed now?


Mihai

[1] http://goo.gl/ZbV5oH

[signature.asc (application/pgp-signature, attachment)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Jul 21 00:39:22 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.